Trying to connet to Telia(Skanova) ADSL provider in Sweden with 837

Discussion in 'Cisco' started by Christer Bergstrom, Jul 9, 2005.

  1. Dear Sirs

    I have an Cisco 837 where the CRWS-interface goes into an infinite
    loop when trying to configure the 837 to my ISP. They have recently
    removed login with username/password, so I tried to let the 837 via
    the CRWS-interface findout the config parameters via Quick-setup, then
    the infinite loop starts. If I monitor the 837 through consol, I can
    se that it starts with someting.
    sh ver for my 837:

    Cisco Internetwork Operating System Software
    IOS (tm) C837 Software (C837-K9O3SY6-M), Version 12.2(13)ZH2, EARLY
    DEPLOYMENT RELEASE SOFTWARE (fc1)
    Synched to technology version 12.2(14.5)T
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2003 by cisco Systems, Inc.
    Compiled Tue 22-Jul-03 09:28 by ealyon
    Image text-base: 0x800131E8, data-base: 0x80B50C04

    ROM: System Bootstrap, Version 12.2(8r)YN, RELEASE SOFTWARE (fc1)
    ROM: C837 Software (C837-K9O3SY6-M), Version 12.2(13)ZH2, EARLY
    DEPLOYMENT RELEASE SOFTWARE (fc1)

    Router uptime is 44 minutes
    System returned to ROM by power-on
    System image file is "flash:c837-k9o3sy6-mz.122-13.ZH2.bin"

    CISCO C837 (MPC857DSL) processor (revision 0x500) with 44237K/4915K
    bytes of memory.
    Processor board ID AMB08191KCX (3757405852), with hardware revision
    0000
    CPU rev number 7
    Bridging software.
    1 Ethernet/IEEE 802.3 interface(s)
    1 ATM network interface(s)
    128K bytes of non-volatile configuration memory.
    12288K bytes of processor board System flash (Read/Write)
    2048K bytes of processor board Web flash (Read/Write)

    Configuration register is 0x2102

    sh run shows:

    Current configuration : 881 bytes
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname Router
    !
    logging queue-limit 100
    !
    ip subnet-zero
    ip dhcp excluded-address 10.10.10.1
    !
    ip dhcp pool CLIENT
    import all
    network 10.10.10.0 255.255.255.0
    default-router 10.10.10.1
    lease 0 2
    !
    !
    ip audit notify log
    ip audit po max-events 100
    no ftp-server write-enable
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0
    ip address 10.10.10.1 255.255.255.0
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    ip classless
    ip http server
    no ip http secure-server
    !
    access-list 23 permit 10.10.10.0 0.0.0.255
    !
    line con 0
    exec-timeout 120 0
    no modem enable
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    access-class 23 in
    exec-timeout 120 0
    login local
    length 0
    !
    scheduler max-task-time 5000
    !
    end

    As the CRWS-interface went into an loop and as I am not so familiar
    with Cisco-router setup, I would be wery grateful if somebody would
    take some of their time to help me with this task, I have seen some
    configs in this group, but they all applies to username/password login
    to ISP.

    best regards

    Christer Bergström
    Viker
    Sweden
     
    Christer Bergstrom, Jul 9, 2005
    #1
    1. Advertisements

  2. Christer Bergstrom

    BradReeseCom Guest

    BradReeseCom, Jul 9, 2005
    #2
    1. Advertisements

  3. Hello
    I have now an config like this:

    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname Router
    !
    logging queue-limit 100
    !
    ip subnet-zero
    ip dhcp excluded-address 192.168.0.1
    ip dhcp excluded-address 195.67.199.9
    !
    ip dhcp pool balja
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.1
    dns-server 195.67.199.9 195.67.199.10
    !
    !
    ip audit notify log
    ip audit po max-events 100
    no ftp-server write-enable
    !
    !
    !
    !
    !
    bridge irb
    !
    !
    interface Ethernet0
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 8/35
    encapsulation aal5snap
    !
    dsl operating-mode auto
    bridge-group 1
    !
    interface BVI1
    ip address dhcp client-id Ethernet0
    ip nat outside
    !
    ip nat inside source list 1 interface BVI1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 BVI1
    ip http server
    no ip http secure-server
    !
    access-list 1 permit 0.0.0.1 255.255.255.0
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
    exec-timeout 120 0
    no modem enable
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    access-class 23 in
    exec-timeout 120 0
    login local
    length 0
    !
    scheduler max-task-time 5000
    !

    when executing sh arp, it gives this:

    Protocol Address Age (min) Hardware Addr Type Interface
    Internet 81.226.72.239 7 0002.3b00.d94b ARPA BVI1
    Internet 192.168.0.119 1 0006.5b57.4731 ARPA Ethernet0
    Internet 81.226.84.203 - 0000.0c46.2a10 ARPA BVI1
    Internet 192.168.0.1 - 000f.8f60.c97d ARPA Ethernet0
    Internet 81.226.67.77 2 0002.3b00.d94b ARPA BVI1

    It indicates some connection to the outside.

    Where am I wrong in the configuration?

    best regards
    Christer Bergström
    Viker
    Sweden
     
    Christer Bergstrom, Jul 10, 2005
    #3
  4. Christer Bergstrom

    Brian V Guest

    Your NAT acl is messed up, your only allowing deices with X.X.X.1 addresses
    to be nated (which in your subnet is only your ethernets interface).

    conf t
    no access-list 1 permit 0.0.0.1 255.255.255.0
    access-list 1 permit 192.168.0.0 0.0.0.255
    exit
    wr mem

    -Brian
     
    Brian V, Jul 10, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.