Trying to avoid slow response time with ADSL when there is traffic

Discussion in 'Cisco' started by Guest, Jan 18, 2006.

  1. Guest

    Guest Guest


    We have a 1200 downstream, 500 upstream ADSL connection with a Cisco 836
    ADSL modem/router. I've noticed that as soon as there is a bit of
    serious traffic going through, the response time of applications like
    PING and SSH get quite bad. A ping takes for example 300 ms instead of
    30 ms.

    I tryed activating WFQ (Weight Fair Queuing) but didn't see any
    improvements. Does anyone know how I can deal with this problem and make
    response time better ?

    Many thanks
    Guest, Jan 18, 2006
    1. Advertisements

  2. Guest

    luqs Guest

    Use strict priority queue.
    u can set the bandwidth for each protocol differently

    access-list 110 permit tcp any any eq 22
    access-list 120 permit icmp any any
    access-list 5 permit ip any any

    class-map match-any ssh_or_ping
    match access-group 110
    match access-group 120

    class-map match-any rest
    match access-group 5

    policy-map test
    class ssh_or_ping
    bandwidth xxx (say 20%)
    class rest
    police xxxx (set it not to exceed 80% of link)

    int dialer 1
    service-policy output test

    I may have made mistakes in the above...refer to the document
    luqs, Jan 18, 2006
    1. Advertisements

  3. Guest

    luqs Guest

    Forgot to mention, I have tried most queues and found little noticeable
    difference among them.I actually carried out timed tests. But you could
    apply the q i mentioned above and give me some feedback.
    luqs, Jan 18, 2006
  4. Try to use the tx-ring-limit parameter under the pvc definition.
    It defaults to 16 packets, tune it to 4 or even lower.
    Joop van der Velden, Jan 18, 2006
  5. Guest

    Guest Guest

    I've now setted this parameter to 3, I saw it also mentioned in the
    Cisco docu for VoIP usage they recommend 3.

    Also thanks to luqs for your detailed answer about the strict queue, if
    I see no significant improvement with this tx-ring-limit parameter I
    will try to add your strict queues to it.

    Guest, Jan 19, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.