Total flash size decreaing with newer IOS image on 2600

Discussion in 'Cisco' started by MC, Feb 24, 2004.

  1. MC

    MC Guest

    When I look at the flash contents on a 2610 router with a 12.0 IOS I see the
    full size of the flash, which is 8MB.

    When I look at another router with a 12.3 IOS same feature set the flash
    only reports a little over 7MB total flash.

    I tried to tftp a 12.0 image to a 2600 router that cam with 12.3 series IOS,
    same falsh size and memory size as all other routers running 12.0 but could
    not load the 12.0 series IOS due to not enough space. Tried to erase the
    flash but only reports a little over 7MB not the 8MB. Was sucsessfull
    loading the 12.0 IOS with the tftpdnld command from rommon and now the flash
    reports 8MB total?

    As a note, We run all same hardware configuration and all same IOS release
    on all of these routers, very static environement but all routers have to be
    on the same IOS until we can upgrade them all at the same time for now.

    Has anyone seen this before ?
    MC, Feb 24, 2004
    1. Advertisements

  2. MC

    Joe Rankin Guest

    This probably is related to the squeeze capability in 12.2 and later
    code. When the flash is erased under 12.2 and later, flash space is
    allocated for the squeeze operation to work. When you erased it from
    rommon using tftpdnld, the flash was erased under the rommon version and
    lost the squeeze capability, therefore you see all 8 MB.
    Joe Rankin, Feb 24, 2004
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.