thumb drive problem with Windows 98

Discussion in 'Computer Information' started by dh, Apr 10, 2007.

  1. dh

    Peter Guest

    Hmmm, bit weird that, and doesn't make much sense. A registry backup is
    just that and is not reliant on any other registry backup for it to make
    an appearance. All registry backups should be completely independent of
    all other registry backups in order to guarantee that they can be
    restored if needed. Still, at least you managed to recover from
    whatever strange behaviour was going on.
     
    Peter, Apr 12, 2007
    #21
    1. Advertisements

  2. dh

    Franc Zabkar Guest

    Go to Start -> Run and type "regedit".

    Then navigate to ...

    HKEY_LOCAL_MACHINE\Enum
    HKEY_LOCAL_MACHINE\Enum\USB
    HKEY_LOCAL_MACHINE\Enum\USBSTOR

    Look for a device with a VID (vendor ID) and PID (product ID) that
    matches what you found with usbview.exe.

    You could also go to Start -> Run and type "msinfo32". This will dump
    your system configuration information.

    Otherwise I suggest that you repost your question to the
    microsoft.public.win98.gen_discussion newsgroup where this problem is
    discussed on an almost weekly basis.

    - Franc Zabkar
     
    Franc Zabkar, Apr 13, 2007
    #22
    1. Advertisements

  3. dh

    dh Guest

    I don't know if I even have a driver. I finally learned to select
    a new driver for it, but it couldn't find one in the folder it was
    supposed to be in. Here is what's in the folder:

    dokhdc.inf
    dokusb.inf
    SafeEject.EXE

    Are any of those things drivers, or do I need to try finding one
    someplace else?
     
    dh, Apr 17, 2007
    #23
  4. dh

    dh Guest

    That's pretty much what life means to me.
    If I remember right there was only one option to begin with, and then
    there were two. So when I selected the first one might it have saved the
    current settings, thusly creating the second?
    I'm very thankful for that.
     
    dh, Apr 17, 2007
    #24
  5. dh

    dh Guest

    I finally did all that, and then double clicked the nusb31e.exe icon.
    It had me agree, and then it flashed everything by so fast I don't know
    where anything was installed. I couldn't find any Read Me or anything
    to explain where to find anything that might be of use, so I'm still sol since
    I don't know what to specifically look for, or where to look for it.
     
    dh, Apr 17, 2007
    #25
  6. dh

    dh Guest

    In case anyone is reading this and has the same problem, I finally
    got mine working by installing the NUSB package Franc mentioned
    by downloading nusb31e.exe (an English version) from:

    http://www.technical-assistance.co.uk/kb/usbmsd98.php

    after uninstalling the driver recommended by the manufacturer which
    did not work. The nusb install was so fast I couldn't tell where it put
    anything, so I used a video camera to record the download window
    as the install flashed by on the computer monitor, and found that the
    destination was:

    C:\WINDOWS\OPTIONS\CABS

    After rebooting I stuck in the thumbdrive, opened My Computer--Control
    Panel--System--Device Manager and found the device with the "?",
    selected Properties, clicked the Driver tab, pressed Update Driver,
    agreed with the wizard, chose Specify a location, Browse, and then
    found the CABS folder. That worked for me :)
     
    dh, Apr 18, 2007
    #26
  7. dh

    Franc Zabkar Guest

    On my machine the usbstor.inf file is written to both the OPTIONS\CABS
    and INF directories.

    If you had opened the nusbxx.exe file with Winzip, you would have seen
    the INF files and you could then have searched your HD for them.
    Having said that, I'm wondering why Win98 didn't automatically look in
    your INF directory.

    - Franc Zabkar
     
    Franc Zabkar, Apr 19, 2007
    #27
  8. dh

    funlife_inc Guest

    Dude...my Os is win98SE.....n iwas able 2 get my pen drive started due
    2 ur guidelines!!!!!!!!! (data traveler 2.0) dti/1gb..........thanx a
    ton man
     
    funlife_inc, Apr 27, 2007
    #28
  9. dh

    dh Guest

    I keep having problems with mine. What kind are you using?
     
    dh, May 2, 2007
    #29
  10. dh

    dh Guest

    It can't do much of anything right. Every time I install the thumbdrive
    I have to go through all the driver loading junk too. And by now it knows
    where it is but I still have to accept and agree with everything...
     
    dh, May 2, 2007
    #30
  11. [email protected], writes:


    snip
    You still around David?
    I have just obtained the Kingston 4Gb model of the pesky varmint you
    have, same problems, exactly.
    Thumb Drive (TD)
    Kingston DTI/4GB
    CN 030407 5v (volt?)
    05360-358.A00LF China

    Same GUI also, with a maybe small difference that should have no
    bearing on what you are experiencing. This 98se GUI is fully patched
    with no Active X or MS "fone home" tools on board. The install has
    been enhanced with this tool.
    http://www.litepc.com/98lite.html

    I post as I am working on a permanent fix for this Kingston TD so
    hopefully the fix can get archived.
    I found the thread on Google/Deja, I post from <a.c>.

    Two things first.
    A lot of your troubles come from not being setup in a manner that
    allows you to see what is happening on installs, David... of anything.
    Fix that with EasiClean, an old app but very very efficient at doing
    registry checks and logs.
    http://www.bkedv.de/website/
    If there is a problem getting a version to run on 98se, say so and I
    will get a patched copy uploaded.
    [XP users could well use the newest version of this app]

    Secondly, _any_ user of 98se needs to know how to backup and clean
    (manual edit) <user.dat>. Being "in the dark" on this one is simply
    going to create more angst than is necessary in using Win9x.* as
    a regular platform. I attach (as an addendum] a tutorial written in
    2002. I could not find it on Google/Deja despite being certain it was
    uploaded at the time.


    Back to the problem....
    What I have found so far?
    Remove USB devices from the target machine..all of them.
    Remove "USB Hub & Controller" from Devices in
    Control Panel>System>Device Manager

    [Note: the "Other Devices" you are looking for is a red
    herring by Kingston 'help'. That listing does not show until
    one of the drivers they offer is loaded. The /other devices//
    you want is in the "add new hardware wizard", as an option.
    Always use it when you are installing devices that give you
    problems using "conventional methods" - none of that helps
    you with this baby<s>]

    Reboot.
    Allow the system to find and install the "USB Hub & Controller".
    Reboot
    Use another USB device you know works, as a /test tool//,
    connect it and make sure the system /sees// it.
    If you are using a USB cable make sure you have this insitu also.
    All working? Great, on with the show.

    Disconnect that USB device you just tested.

    Ok, now the fun starts<g>

    First you have to prepare that TD.
    You need.
    1. A clean TD. Use FDISK & FORMAT to strip whatever is on the TD to
    a FAT32 formatted partition. These tools can be run in a
    D0S window on 98se.
    [note: For some TDs this step is maybe only necessary when you are not
    certain the TD is "good to go". FDISK will soon tell you if the drive
    is /good//. You can also use FDISK to partition the drive at a later
    date should you so choose]

    Next you need the boot information that will make your new TD emulate
    a floppy.
    1. Win98se "startup Disk" or a method to store all the D0S boot
    files that are written to Disc01 of D0S 6,22 + generic
    drivers for CD booting (atapi.sys)/mscd001) and mouse driver.
    2. WinImage, as a tool to make an image of and to then extract the
    boot files from your "startup disk".
    [note: There are any number of ways to create a boot image. The
    suggestion here is for those familiar with Win32 interfaces only]

    Once you have this material & a clean TD you will need these tools to
    actually write the drive to the boot partition.
    1. A WinXP machine with a working USB hub.
    2. This generic boot sector tool for TDs.

    http://h18000.www1.hp.com/support/files/serveroptions/us/download/20306.html
    <SP27213.exe>
    [note: this version of this tool has to be run on the XP platform, the
    kernel version is not compatible with 98se]
    3. This generic USB storage driver.
    http://www.technical-assistance.co.uk/kb/usbmsd98.php
    <nusb31e.exe>

    The process is:
    1. Make a new 98se boot floppy. Using WinImage extract the boot files
    from the newly minted disk and store them in a folder you can easily
    access at root on the XP machine..
    c:\USBdrv ....is good.
    2. Install the <SP27213.exe> tool to the XP machine.
    3. Connect the prepared TD to the XP machine and run the HP boot
    sector write tool.
    The GUI will ask you to locate the D0S files to load. Point it at the
    root folder you made earlier.
    The tool will then complete, setting the USB boot sector as "active".
    Remove your TD and go boot whatever with it !

    When you want to use a 98se machine to write data to the TD you may
    need to run the generic USB driver <nusb31e.exe> first. I found that
    other TD driver installs covered this , for me..YMMV.

    That easy !

    Supplementary:
    In cobbling together this /fix// I discovered a number of "Catch 22's"
    and confirmed many I did read of, including David's original dilemma.
    To wit: The Kingston driver patches simply do not work. In fact one of
    them writes USB information to the IDE entries in the registry causing
    98se to think it is another AIDE drive, sicken bizarre!
    I list some others here, should any be happy enough to "not bother"
    with trying some obvious fixes, or what were obvious fixes, to myself.
    -=-FDISK. No doubt there is a boot manager in Tux (Linux) that will
    allow FDISK to create more than one Active partition on a Linux
    system. D0S FDISK does not. Absolutely refuses to allow more than
    one Active on a FAT system.
    -=-CD booting (D0S) requires D0S drivers for a USB mount to enable a
    USB drive in D0S. D0S drivers for USB TD's are not available.
    -=-WIN IMAGE is set by default to only recognise A: and B: drives.
    Any boot image created by Win IMAGE cannot be written directly to the
    TD in a Win32 environment.
    -=-HP boot sector write tool writes the whole of the USB drive as one
    partition, removing any previous structure. This could be a good thing
    or a bad thing, depending on what you previously had mounted on the
    TD.

    I have bundled some of this information together with drivers used and
    uploaded them to:
    http://members.driverguide.com
    Search for "Kingston TD-4GBfix"
    I do this should the links I use here get munged with page changes.
    Support DriverGuide and get a membership. It was free at time of
    writing this info up.

    At time of writing Kingstons only advice on this issue is:
    <quote>
    You void warranty on our product in carrying out technical change.
    </quote>
    HPD

    --
    ==================================================
    How to "Pontius Pilate" Windows 9x. Platforms- by warrigal
    ==================================================
    IMPORTANT NOTICE
    Why?? because IF U stuff your machine and thereby (for some) your life
    its YOUR doing.
    Forget the Lame Whine "it didn't work ..baaahhhwwaaaaa".
    The method is proven on Windows 95B (all versions) and
    Windows98SE/Lite.
    I have no doubt it would work (with minor changes) on any WinX system
    that uses User.dat type control hierarchy in file/registry tracking.
    The method was developed from advice given to clean WinME.

    READ carefully and BACKUP before you start the fire!

    ====================================================
    To create/refresh a new registry:
    0r
    How to remove unwanted dats from <user.dat>

    ------------------------------------------------------------------------------------------
    U need:
    3.5" Floppy as a Bootable System disk with all "extras" like
    edit.com/attrib.exe/smartdrv/regedit.exe/attrib.exe/command.com
    D0S version of those files MUST be of the same genre as the version of
    D0S you are booting with!!
    -------------------------------------------------------------------------------------------
    Set up 2 folders under ../!reg/
    ...!reg/Support
    ...!reg/backup

    ...//Support is simply somewhere to store copies of
    regedit.exe;smartdrv;edit.com;attrib.exe
    just in case your floppy fails during the process (it happens) you
    have ready access to these needed files
    ...//backup is the folder to store your original dat files and to write
    your saved file/s to.

    METHOD

    After booting from the floppy run smartdrv.exe.
    Setup !reg dir if not already done.
    Create <nureg.txt> and <oldreg.txt> in ../!reg if not already done.
    Remove attributes ASHR from <system.dat> and <user.dat>
    Run regedit and export registry to ..//oldreg.txt
    Example:
    Remember you can get regedit syntax help by typing at a:\
    regedit /?

    Depending on size of registry the file could take up to 30mins to
    build.

    When a:\ reappears, reboot and in Windows examine ..//oldreg.txt for
    those entries to change/delete.
    *NOTE*
    A text editor is important as <edit.com> and NotePad are not enough to
    see the whole of the registry file and Windows programs like NotePro
    and WordPad introduce WinX syntax into the changes (IF they will look
    at them). So use only a bare text editor, EditPad works.

    When changes are complete save file as ..//nureg.txt
    You should move a backup of <oldreg.txt> to the backup folder *before*
    editing.

    Reboot

    Do not forget to have SmartDrive running to do all procedures in D0S.
    Remove attributes ASHR from <system.dat> and <user.dat>
    Erase the <system.dat> and <user.dat> files.
    Run regedit to import new registry from <nureg.txt> to <system.dat>
    Depending on size of registry the registry could take up to 30mins to
    rebuild.

    Remember you can get regedit syntax help by typing at a:\
    regedit /?

    Reboot Windows and using both Regedit and Wgrep make sure the changes
    are effected.

    Always keep your original DAT files in ..//!reg/backup/* until the
    time when you are sure the rebuild is kosha..usually some months!

    NOTES:
    Regedit4 has the unique ability to "remove" any unlinked references in
    the user.dat file when invoked using the above method. Experience has
    shown that this is the ONLY way short of rewriting the drive after a
    low level format to remove those indications of data having once been
    on your machine. Note particularly the reference to "unlinked". IF the
    data is on your drive in some other form other than what you can
    recognise (eg. hidden attrib 0r encrypted, changed filename)and thus
    still "linked" then this method will NOT remove indication of its
    presence to an auditor. Therefore it is important that you have a
    comprehensive knowledge of what is on your machine and "how to" find
    it. It gets back to good housekeeping.
    Registry editing programs tried do not prove sufficient to do
    "refresh". This because they insist on making "bakups" or "undos".
    This has the effect of not allowing the unwanted data to EVER leave
    your machine.
    Be aware that Windows (95&98) both show evidence of "creating their
    own syntax" . eg If you type in "John Brown" as a UID in a program it
    can be seen in the registry as "John" and in a separate entry "Brown".
    So when searching for changes remember to use variations of the syntax
    in your search.
    Lesson = DO NOT use anything other than native WinX RegEdit4 and
    always use a regular expression finder to check the syntax is
    gone/present.
    Experiment shows that entries can be found by GREP that RegEdit4 does
    not detect.

    Synopsis:
    I may be slow but in the 6years since I started playing with WinX I
    only recently came across this method of "cleaning" and that was for a
    Millennium registry!
    I have/had asked the question many times in a number of arenas "How do
    U clean unwanted dats from <user.dat>" and nary had more than either
    'blank stare' 0r absolutely BS responses that even I at my level
    figured were uttering's of 'wannabe's'.
    I tried variations of what I 'found' on both 95B and 98SE/lite and
    easily developed the method above as a proven "goer".
    When the tools are right and its practised a few times it really is a
    peice0piss to do.
    Not scary at all..have fun :)

    ======================================
     
    Hoo Phung Dungh, Jun 7, 2007
    #31
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.