thumb drive problem with Windows 98

Discussion in 'Computer Information' started by dh, Apr 10, 2007.

  1. dh

    dh Guest

    I was told to just put the drive in the USB slot and it
    would work. Having been led to believe it would take
    care of everything by itself, when it asked about
    drives I just hit the next buttons thinking it would
    figure it out. I was online at the time, and it asked if
    I wanted it to find the driver(s) online so I said okay.
    It did whatever it did, and I haven't gotten a thing
    out of it since. Putting it in does nothing, and I've
    been able to find no icons or anything for it, etc.

    It is a Kingston DataTraveler DTI/1GB. I read the
    Read Me at:

    http://tinyurl.com/2thq64

    and downloaded the driver. Thinking that something
    mut have gotten screwed up the first time I put it in,
    I tried following this:
    _________________________________________________________
    Q. During the installation of the Data Traveler the Hardware Wizard did
    not locate a proper driver for the Data Traveler and now there is an
    "Other Devices" listed in the Device Manager and the new drive letter
    for the Data Traveler is not displayed in "My Computer."

    A. You have not properly installed the drivers for your Data Traveler. In
    order to resolve you will need to first download the appropriate driver.
    Please use the URL provided to download the proper DTI driver.
    http://www.kingston.com/support/downloads/usbdatatrav/DTI.EXE
    Be sure to download this driver to a location that you can remember.
    Now you will need to update the driver for the Data Traveler listed under
    "Other Devices." In order to do this, please follow the steps provided.

    1)In Device Manager, Right click on the Data Traveler listed
    under "Other Devices," and select "Properties."
    2)Access the "Driver" tab and select "Update Driver." This will
    begin the "Update Driver Wizard."
    3)During the "Update Driver Wizard" be sure to select the
    "Search for a better driver" option and click next.
    4)In the "search for updated drivers," window, make sure "Specify
    a location," is the only option selected, then click Browse.
    5)Locate the driver that you have previously downloaded and click
    O.K.
    6)Now you are ready to install the drivers for the Data Traveler.
    Click Next>Next>Finished.
    7)Once you close the "Update Device Driver Wizard," the
    installation should complete and a new
    "Removable Disk," icon should display in "My Computer."
    ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯
    but there is nothing called "Other Devices" that I can find on this
    PC, and so there is no Data Traveler listed under "Other Devices".
    I'm using Windows 98, not SE afaik, so is that part of it? Will these
    things just not work with regular Windows 98?

    When things didn't work out like the instructions suggested they
    would during the first attempt I made, I did all this:
    _________________________________________________________
    Windows 98SE Users:

    NOTE: DO NOT INSERT DATATRAVELER I BEFORE THE DRIVER
    IS INSTALLED AND SYSTEM HAS REBOOTED!

    1. Download the file named "DTI.EXE".

    2. Decompress the "DTI.EXE" file by double clicking on it. Extract it to
    a location of your choice. Be sure to note the location where the files
    are extracted. The default location is c:\temp

    3. Double click on the DTI.exe icon in the location from step 2 to start
    the installation program.

    4. Follow the directions on the screen. Click "Yes" and "Next" where
    appropriate.

    5. The Install Shield will display a "Please remove DataTraveler 2.0"
    information message. Please confirm that the DataTraveler is not
    plugged into the USB port, then click OK.

    6. Windows will install the appropriate driver for the DataTraveler, then
    display: "InstallShield Wizard Complete." You will also be prompted
    to restart your computer. Please select "Yes, I want to restart my
    computer now" then click Finish.

    7. DO NOT INSERT THE DATATRAVELER YET! A driver database
    will build itself and you will then receive a message which reads,
    "You may insert the DataTraveler 2.0 device at anytime." DO NOT
    INSERT THE DATATRAVELER YET! Please click Finish and allow
    the computer to completely reboot prior to inserting the DataTraveler
    into the USB port.
    ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯
    but still when I insert the device nothing happens. If my system can't
    even detect the device, then it seems that it wouldn't have been able
    to try setting up drivers for it the first time I plugged it in. But if it can
    detect the thing, why won't it work now that I have installed the right
    driver?

    Thanks for any help!
    David
     
    dh, Apr 10, 2007
    #1
    1. Advertisements

  2. dh

    Frank McCoy Guest

    Um ... That works for Win-XP; but not for Win-98 (as you just found
    out).
    In Win-98:
    Start => Settings => Control Panel => System => Device Manager
    The "Other Devices" should show up in this case with a big yellow
    question-mark.

    BTW: 98, not SE, sucks really bad when it comes to large devices.
     
    Frank McCoy, Apr 10, 2007
    #2
    1. Advertisements

  3. dh

    meerkat Guest

    meerkat, Apr 10, 2007
    #3
  4. dh

    Pipboy Guest

    Works for WinME too which is an updated Win98 so it was half right.
     
    Pipboy, Apr 10, 2007
    #4
  5. dh

    Peter Guest

    How long ago did you do this? It may be possible to roll back your
    registry to before the original attempt to install, if done soon enough.

    Do you know about pressing F8 during startup to give you various boot
    options? If you can then do so and select 'command prompt' from the
    list. Once at the command prompt type:

    scanreg /restore

    This should bring up a list of previously saved registry backups.
    Hopefully you can roll the registry back to a date before the install.

    If you were successful you can install the drivers as per the
    instructions and hopefully your memory stick will be detected
    successfully afterwards.
     
    Peter, Apr 10, 2007
    #5
  6. dh

    dh Guest

    dh, Apr 10, 2007
    #6
  7. dh

    dh Guest

    It's not there. No "Other Devices", and I can't find Data Traveler
    listed under anything else either.
    I don't doubt it but that's what I've got, so I'm trying to make it work.
     
    dh, Apr 10, 2007
    #7
  8. dh

    dh Guest

    Yesterday.
    I remember something like that to get into safe mode...
    keep tapping F8 while it's booting up and it will eventually
    bring up some options?
    How?
    So if I do the roll back thing will it uninstall the drivers? Or
    do I need to delete them, do try the roll back trick, and then
    install them again?
     
    dh, Apr 10, 2007
    #8
  9. dh

    Franc Zabkar Guest

    Assuming that you can get other USB devices (eg printer, mouse,
    scanner) to work, then try the freeware Maximus Decim Native USB
    driver pack:

    http://rapidshare.com/files/19858514/nusb31e.exe.html

    You can also use a Win98 utility called usbview.exe to detect USB
    devices even if their drivers are not loaded. Usbview should be on
    your Win98 CD.

    - Franc Zabkar
     
    Franc Zabkar, Apr 10, 2007
    #9
  10. dh

    dh Guest

    Oops, I might have been wrong about that. Looking at the general
    system properties it says Windows 98 Second Edition 4.10.2222A, so
    maybe it will work if I can get it working...
     
    dh, Apr 10, 2007
    #10
  11. dh

    dh Guest

    Okay, thanks. I found it online and downloaded it from:

    http://www.usbman.com/WebDrivers/USBview/

    I opened it and it detected nothing in either USB port. Then I
    plugged in the thumb drive, opened it again, and it detected
    it in Port2. So now what?
     
    dh, Apr 10, 2007
    #11
  12. dh

    Franc Zabkar Guest

    Usbview is telling you that your hardware is OK. It is a diagnostic
    utility, not a driver.

    The NUSB driver is a universal Win98 driver for all sorts of USB
    storage devices. Install it and you should be up and running. You may
    need to uninstall your other driver(s) first, though.

    - Franc Zabkar
     
    Franc Zabkar, Apr 11, 2007
    #12
  13. Whoever told you that probably assumed that you had Windows ME or
    newer.
    You should be able to get the answer at www.usbman.com or www.everythingusb.com,
    but generally you can get a stubborn device to install if you:

    1. Uninstall driver program
    2. Reboot into Safe Mode
    3. Call up the System Device Manager
    4. Remove all mentions of the troublesome device and similar
    nonexistent devices
    5. Reboot
    6. CTRL-ALT-DEL and turn off everything except Internet Explorer and
    Systray
    7. Reinstall driver program
    8 Reboot
    9. Install USB device
     
    larry moe 'n curly, Apr 11, 2007
    #13
  14. dh

    Peter Guest

    After you've typed

    scanreg /restore

    from the command prompt a list of saved registry backups should appear
    on screen, listed under the date they were saved. All you need to do is
    use the up/down arrow keys on your keyboard to highlight the backup you
    want to restore to and then press 'return'. You will then be told if
    the replacement was successful or not. If its good then just re-boot.
    The registry holds all info about which drivers/devices have been
    installed. If you roll back the registry to prior to your original
    attempt to install the memory stick then as far as Windows 98 is
    concerned you 'never' installed the stick in the first place.

    So you can start out afresh. :)
     
    Peter, Apr 11, 2007
    #14
  15. dh

    dh Guest

    That kicked my ass! I didn't have a printer, it changed all
    my settings, it didn't detect my modem, and I don't know what
    all else. It was horrible. I freaked out, but did the same thing
    again hoping there was a way of undoing whatever hell was
    going on, and fortunately it came back around when I selected
    the more recent whatever it was. But damn dude! You're not
    kidding about starting "afresh". You should warn somebody
    before you suggest doing something like that.
     
    dh, Apr 11, 2007
    #15
  16. dh

    Peter Guest

    Ok, my bad. However, I was unaware that you must have also installed
    various other devices recently also. Normally speaking, the registry
    backups will only go back about 4 or 5 days and so this kind of recovery
    shouldn't have any major affect like it did on your machine because,
    generally speaking, it is done to recover from one, very recent, problem
    and shouldn't mess up devices that were installed weeks/months earlier.
     
    Peter, Apr 11, 2007
    #16
  17. dh

    jinxy Guest

    Have you tried downloading the windows 98 driver for that device from
    Kingston's website? http://www.kingston.com/support/downloads/usbdatatrav/default.asp
    I bought one awhile back (128mb) and had the same trouble. Forget all
    that other stuff and try the simple route first.
    -J
     
    jinxy, Apr 11, 2007
    #17
  18. dh

    jinxy Guest

     
    jinxy, Apr 12, 2007
    #18
  19. dh

    dh Guest

    I don't understand anything about it, but the first time there was only
    one choice, so that's what I chose and that's what screwed everything
    up. When I opened it up again in the hopes of having a solution, there
    were 2 choices so I chose the most recent one. I believe that option
    must have come into existence because of the action you suggested,
    but I don't understand the basics of the whole thing. The other option,
    which must be the one I tried out, was dated back in the 1990s I believe.
     
    dh, Apr 12, 2007
    #19
  20. dh

    dh Guest

     
    dh, Apr 12, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.