this is driving me nuts!

Discussion in 'A+ Certification' started by Michael, Oct 16, 2004.

  1. Michael

    Michael Guest

    A few days ago, a problem came up that doesn't make sense to me.

    Whenever my home Win XP machines does a cold boot (either from power off or
    hibernate), it has no internet (or LAN )connectivity. When I do a
    "ipconfig /all" the only thing I get is the first line ("Windows IP
    Configuration") of the usual information that's given by that command. When
    I check "View Network Connections," the usual "Local Area Connection" is
    missing! Of course, I can't ping my gateway, but the loopback ping works.

    All I have to do to fix this problem, is to do a warm reboot (restart) and
    everything is back to normal.

    I've have a D-Link DI-604 router which connects this computer along with
    another computer to a broadband connection. My other computer works fine.
    I've re-set the router and even upgraded the firmware to the latest patch. I
    am using DHCP with my router. I even tried to assign a static DHCP address,
    but it's not help. The only thing that I changed to my system in the last
    few days, is that I added a second hard drive, which works fine.

    What could possibly be causing this? It's annoying to have to boot my
    computer twice each time I turn it on.
    Michael, Oct 16, 2004
    1. Advertisements

  2. Michael

    DirtyHeel Guest

    Interesting. I wish I could help, but I just wanted to say that I have the
    same router and I have a similar problem, but my problem only occurs if I
    re-activate my PC from standby mode. The way I get the net to start working
    is I unplug then re-plug the router. That might be a faster option than
    resetting your computer :s
    DirtyHeel, Oct 17, 2004
    1. Advertisements

  3. Michael

    Michael Guest

    The router is left on all the time. I now don't believe it's the router,
    especially since my other computer works fine. See my reply to the next
    Michael, Oct 18, 2004
  4. Michael

    Michael Guest

    Unplugging and re-plugging the router didn't do anything. I now believe that
    it can't be the router and here's why.

    When I disconnect the cable from my router to the computer, the same thing
    happens. Yeah, I know that you are all saying that of course, with no cable,
    you won't get a connection, but wait:

    On a cold boot, the icon for "Local Area Connection" in "View Network
    Connections," is still missing, cable or no cable. That means that I can't
    configure TCP/IP or check the settings. As I have said, I also get nothing
    for using ipconfig at the command line.

    However, if I restart the computer (warm boot), despite the fact that my
    cable is unplugged, at *least* I now see the "Local Area Connection" icon
    and can check my TCP/IP configuration. I even get the task bar icon that
    warns me that a cable is unplugged as expected.

    Should I repair Windows? What is happening with the cold boot vs. a reboot?

    Michael, Oct 18, 2004
  5. Michael

    D V. Brown Guest

    Have you checked Event Viewer to see what service(s) may have failed to
    start or other possible related issues?
    D V. Brown, Oct 18, 2004
  6. I'm thinking the same thing....
    Eliminate all possible hardware issues ( you started with the router...)
    I would also swap ports on the router... it's possible that one might be
    Try swapping NICs....
    I have a sneaking suspicion you have some third party software on that
    that is causing the problem....
    «bonehead;\), Oct 18, 2004
  7. Michael

    Michael Guest

    Did good.
    I can't. The NIC is onboard.
    Could be. The only major change was putting Windows 2003 on another drive as
    a demo. I did that about the same time the problems began.
    Michael, Oct 18, 2004
  8. Michael

    Michael Guest

    Good suggestion:

    This is what I get:
    IPSec Services: IPSec Services failed to initialize IKE module with error
    code: The attempted operation is not supported for the type of object

    .. IPSec Services could not be started.

    IPSec Services: IPSec Services has experienced a critical failure and has
    shut down with error code: The network connection was aborted by the local

    .. Stopped IPSec Services can be a potential security hazard to the machine.
    Please contact your machine administrator to re-start the service.

    Sounds scary, no? It actually says that the network connection was aborted.
    But what doesn't make sense is that these same event viewer messages come up
    even when I do the successful warm reboot and I have my normal connectivity.
    Also, I notice, whether I do a cold or warm boot, the IPSec service is
    running anyway. So, why is it telling me that the service couldn't start
    when it shows up in the processes list in Task Manager?

    The only other thing that I can think of is that about the time I started
    having problems is when I installed another hard disk with Windows Server
    2003 on it. That OS experiences the same problems that I have described,
    except that I don't get IPSec error messages in the Event Viewer.

    Maybe, it's time to do a System Restore?
    Michael, Oct 18, 2004
  9. Michael

    D V. Brown Guest

    Could be a corrupt or hijacked lsass.exe. Hijacked, maybe by trojan or
    spyware? Wouldn't hurt to do a scan and then maybe a system restore.
    I've seen where a virus over-wrote the lsass.exe and a repair was necessary
    after removing the virus. I think it was Sasser but I don't remeber now.

    Let us know what you find out.
    D V. Brown, Oct 18, 2004
  10. Michael

    Michael Guest

    Couldn't find any adware or viruses.

    Now get this one . I cannot use System Restore. I can select a restore
    point and it goes through the motions until it restarts and then I get the
    message that my computer cannot been restored. I try other restore points
    and get the same message.
    Michael, Oct 19, 2004
  11. Michael

    D V. Brown Guest


    I'm fresh out of ideas, I wonder if you remove the new drive with Serv 2003
    and then try the restore? But then it seems like the issue would return once
    you put the other drive back in. I wonder if you did a reinstall of XP with
    the repair option, probably what you where going to do all along.
    D V. Brown, Oct 19, 2004
  12. Michael

    Michael Guest

    I thought of the same thing. I took the other drive online and even
    uninstalled it in the CMOS settings, but same problem. The previous system
    restore points still don't work. And yes, I am considering doing the XP
    repair. Hmm..I wonder if I'll have to re-install Service Pack 2?

    And if that doesn't work, I guess I can just boot twice or leave the
    computer on all the time.
    Michael, Oct 19, 2004
  13. Michael

    D V. Brown Guest

    Service Pack 2.
    Try looking at your firewall settings. I hear there have been issues but not
    sure what they are. You may want to try a reboot with the firewall disabled
    to see if that is the problem. Just an idea...
    D V. Brown, Oct 19, 2004
  14. Michael

    Michael Guest

    Yep...tried that, too. Thanks, anyway

    Michael, Oct 19, 2004
  15. Michael

    Michael Guest

    First of all, thank you for all of your suggestions. I finally thought of
    something that I should have done earlier.

    I connected directly to my cable modem and bypassed my router. Bingo! No

    So, it turns out that I eliminated my router too easily, because my other
    computer worked fine.
    Michael, Oct 19, 2004
  16. Michael

    D V. Brown Guest

    Glad you got it, strange issue.
    D V. Brown, Oct 19, 2004
  17. Michael

    Michael Guest

    Well, it turns out I was wrong, my problem was not caused by my router.
    Yes, it was the onboard network interface. I bought a NIC today and
    installed it and now no problems.
    Michael, Oct 23, 2004
  18. Michael

    Brian M. Guest

    Did you update your modem driver? I was having this problem with my onboard
    NIC after I installed SP2, I would have to reset my router after PC reboot.
    The Nic wasn't trying to request a new IP address. I ended up going with the
    driver on the Windows update site and haven't had any problems since.
    Brian M., Nov 7, 2004
  19. Michael

    the yeti Guest

    Did you resolve the IPSec issue in the event log?

    Start --> Run ---> services.msc. Scroll down untill you see IPSEC
    listed. Set it to disabled. You don't need it, its for VPN and I
    doubt you are using an IPSec VPN at your house. Don't ask me why IPSEC
    VPN is a default startup service on XP, it makes no sense. Also make
    sure that its not in your Network Connections properties too. Make
    sure that the MS IPv6 isn't there either.

    Then try your onboard NIC again. $10 says it will work.
    the yeti, Nov 9, 2004
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.