The driver detected a controller error on \Device\Harddisk\x

Discussion in 'NZ Computing' started by BigAl.NZ, Jul 22, 2007.

  1. BigAl.NZ

    BigAl.NZ Guest

    Hi Guys,

    I help try to help friends fix there computers. I have had two
    computers recently that have had lines very similar to the following
    appearing repeatedly on the even log:

    The driver detected a controller error on \Device\Harddisk\x (where x
    is a numner)

    In both cases I scanned for viruses and found nothing.

    I also ran a surface test and both passed.

    One of them was a laptop and one was a desktop. With the desktop I
    replaced the IDE cable, but for the laptop there was not much I could
    do. The laptop was not booting until I rolled it back to a restore
    point a few days old.

    My questions are:

    Is this error likely to be a sign of impending doom?
    What else could be causing it and how do I diagnose it precisely?

    Thanks in advance

    -Al
    PS: Both PC's running winxp sp2. Hard disks were both Hitachis from
    memory.
     
    BigAl.NZ, Jul 22, 2007
    #1
    1. Advertisements

  2. BigAl.NZ

    BigAl.NZ Guest

    Sorry it should be device not driver detected a controller error
     
    BigAl.NZ, Jul 22, 2007
    #2
    1. Advertisements

  3. BigAl.NZ

    Malcolm Guest

    On Sun, 22 Jul 2007 01:58:29 -0000
    Hi
    Any tools available fro Hitachi to check the S.M.A.R.T. info? Can you
    install sisoft sandra or similar, I think you can still get a freware
    version.
     
    Malcolm, Jul 22, 2007
    #3
  4. BigAl.NZ

    Pennywise Guest

    Download HD Health http://www.panterasoft.com/ it reads the S.M.A.R.T
    info and gives a date of death (not to be taken seriously, unless it
    is something like yesterday).
     
    Pennywise, Jul 22, 2007
    #4
  5. BigAl.NZ

    BigAl.NZ Guest

    Those are all options, though in the past when I have put harddisks
    with bad SMART reports into my PC, my BIOS alerts me. I put both those
    HDD's in my PC, and got no SMART warnings....

    The plot thickens....
     
    BigAl.NZ, Jul 22, 2007
    #5
  6. BigAl.NZ

    Gordon Guest

    Good info, but it really should lead the post.
     
    Gordon, Jul 22, 2007
    #6
  7. BigAl.NZ

    Craig Sutton Guest

    If it did it about 20 times in a row in the log, Disable the DVD burner in
    device manager then also remove both IDE primary and secondary in device
    manager. Then reboot and the IDE controller should be rediscovered. Then
    reenable the DVD device.

    This fixed the issue on mine..
     
    Craig Sutton, Jul 22, 2007
    #7
  8. BigAl.NZ

    BigAl.NZ Guest

    Thats a good point - I just assumed it was a HDD, it could have infact
    been the other IDE device the CD/DVD. How do you tell which is which?
     
    BigAl.NZ, Jul 22, 2007
    #8
  9. BigAl.NZ

    Craig Sutton Guest

    From my experience with the problem doing as above fixed it. It stopped a
    run of about 20 of the above errors in event manager.

    It is some sort of hardware clash. You can try opening it up, d/c the IDE
    Burner then remove the primary and secondary in device manager reboot
    redetect them. See if errors have gone, test it out make sure errors are no
    longer in the log, then re add in the IDE burner. See if it returns.
     
    Craig Sutton, Jul 23, 2007
    #9
  10. BigAl.NZ

    Craig Sutton Guest

    Well any update?
     
    Craig Sutton, Jul 24, 2007
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.