Text over Text errors

Discussion in 'Firefox' started by letterman, Jun 2, 2008.

  1. letterman

    letterman Guest

    I have Firefox 2.0.0.11 under Windows98se.
    Although I like Firefox, I find that far too many times I get text
    overlayed over other text on webpages. This is most annoying.
    If I load the same page using IE6, I dont see this problem. Why does
    FF do this? Here's an example.
    If I load http://www.astro.com
    The blue box on the top left corner has text on top of other text.
    This box is under the words "Astrodienst Offers"
    I see this on far too many websites, and am finding myself using IE
    more and more often because I cant cope with these scrambled pages.

    I also have Opera installed, which I rarely use, (and dont much care
    for). I loaded this same page in Opera and I do not see this problem.
    Only FF seems to cause this. This is NOT acceptable !

    Anyone know why?
     
    letterman, Jun 2, 2008
    #1
    1. Advertisements

  2. sorry, but I see the same thing in IE as I do in FF,
    SeaMonkey, Netscape 9, Safari 3.1, and Opera. Perhaps you
    can post a screenshot of what you see.

    --
    *IMPORTANT*: Sorry folks, but I cannot provide email help!!!!

    Warning: Private emails sent to me may become public

    Peter Potamus & His Magic Flying Balloon:
    http://www.toonopedia.com/potamus.htm
     
    Peter Potamus the Purple Hippo, Jun 2, 2008
    #2
    1. Advertisements

  3. letterman

    TheGuy Guest

    Anyone know why?

    Looks perfect here (FF2, latest version).

    I *very* occasionally run into websites that don't display properly on
    FF, but only due to shitty HTML design, so it's unlikely that they
    display correctly on anything other than IE.
     
    TheGuy, Jun 2, 2008
    #3
  4. letterman

    letterman Guest

    Thanks for the feedback.
    It looks horrible here.

    I saved a screen capture of both the top part of the FF screen, and
    the same part of the IE screen. I'd like to post this so others can
    see it. I have parts of the top of the screen in that blue box and
    the very top of the page is chopped off. I tried changing the fonts,
    the view/screen size, and let FF choose the font (both on an off).
    Eirther way, it's horrid. I'd like to post the screen capture
    somewhere, but this is not a binary group and aioe.org does not allow
    binaries anyhow. Is there some website where I can post this .jpg
    capture without actually creating a webpage and all that hassle? Just
    some place to put the photo for temporary. I'd really like everyone
    to see this mess. Maybe someone can make sense of it by seeing it.
    It's too hard to explain.

    I'd hate to leave FF, but this is just intolerable, and I probably see
    this on about 35% of all web pages. This particular page is worse
    than usual. Some I can read if I struggle to see the text below the
    other text, but this page is just a mass of scrambled junk.

    Thanks for all help.
     
    letterman, Jun 2, 2008
    #4
  5. You could use <http://tinypic.com/> to host your screendumps; no
    registration required.

    Which extensions are you running? Maybe some extension is the cause of
    your troubles.

    Try to:
    clear your cache
    start Firefox in safe mode
    start Firefox with a new/clean profile.
    <http://kb.mozillazine.org/Standard_diagnostic_(Firefox)>
     
    Roland de Ruiter, Jun 2, 2008
    #5
  6. It looks fine using FF 2.0.0.14...maybe you should try hitting the increase
    or decrease text size (Ctrl - or Ctrl +).
     
    The Chief Instigator, Jun 2, 2008
    #6
  7. letterman

    letterman Guest

    OK, here's the link to the picture (I put both shots together and
    labelled them.
    http://i27.tinypic.com/ogvvbd.jpg
    Fasterfox 2.0
    Flashblock 1.5.4.1
    Download helper 2.5.3
    Image zoom 0.3
    Pdf download 0.9.3.2
    Dom Inspector 1.8.1.11
    Configuration Mania 1.09.2007122901
    Cache Viewer 0.4.4
    Adblock Plus 0.7.5.3
    Colorful Tabs 2.0.8
    Done that many times
    How do I do that?
    I dont want to lose my whole profile, should I just install another
    copy of Firefox in another folder? Or what's another way?

    Thanks for the advice.

    That tinypic.com will be useful in the future.
     
    letterman, Jun 2, 2008
    #7
  8. letterman

    letterman Guest

    I tried that, no changes.

    Thanks
     
    letterman, Jun 2, 2008
    #8
  9. I don't know what operating system you're using, but if its
    windows, close FF, then click on the windows start button,
    then run and enter:

    firefox.exe -safe-mode

    does the problem continue?
    when someone asks you to create a new profile, its usually
    for testing purposes to see if the problem continues in that.

    To create a test profile, again for windows, close FF, click
    on the start button, then run and enter:

    firefox.exe -p

    this will start the FF profile manager. Create a test
    profile. Does the problem continue in that?

    However, I would check your settings first. The problem
    looks like a font issue: Tools, Options, Advanced button for
    Fonts, and make sure that "allow pages to choose their own
    fonts . . . " is checked. Did that work?

    --
    *IMPORTANT*: Sorry folks, but I cannot provide email help!!!!

    Warning: Private emails sent to me may become public

    Peter Potamus & His Magic Flying Balloon:
    http://www.toonopedia.com/potamus.htm
     
    Peter Potamus the Purple Hippo, Jun 2, 2008
    #9
  10. letterman

    Rom Guest

    In my usual profile of Fx 2.0.0.14, Fx looked mostly like your Fx.
    Fx still looked the same in Fx Safe Mode.
    Fx looked normal in another near default profile.

    Of the extensions you listed, I have Flashblock, Cache Viewer and
    Adblock Plus. I noticed you had Image zoom, and I use No Squint.
    Setting No Squint back down to 100% only 'fixed' the text at the top.

    I had changed some of the fonts (face and size) in Fx some time back,
    so set them all back to defaults from looking at another Fx and that
    fixed the menu text problem. The font setting that fixed it here is:
    Tools > Options > Content, under Fonts & Colors, Advanced button,
    Minimum font size was not at the default of "None", but larger at 13,
    and displays okay when set at 10 (or None).

    The yellow star in the top left corner in your Fx image is much
    smaller, and the star was normal size here, so perhaps check the Image
    zoom extension you use.
     
    Rom, Jun 2, 2008
    #10
  11. Nope. Works fine here, using Firefox on linux.
     
    John Thompson, Jun 2, 2008
    #11
  12. Ok, what I see here in Firefox looks like what you're seeing in Internet
    Explorer. Have you tried a newer version of Firefox? v2.0.0.11 is fairly
    old already; the current stable release is 2.0.0.14.
     
    John Thompson, Jun 2, 2008
    #12
  13. letterman

    letterman Guest

    Thanks Rom

    I fixed it, or should I say YOU did.

    First I disabled "Image zoom" that made it a little better but still
    bad. Then I went to Tools > Options > Content, under Fonts & Colors,
    the Advanced button. The minimum font size was set to 15. I set it
    to NONE. That fixed the problem. I somewhat recall setting that a
    long time ago, because I dont have the best eyesite, However, it will
    stay at None from now on.

    I reenabled "Image Zoom" afain, and it still looks good. The whole
    problem was that "minimum font size".

    Thanks so much for the help. It helps to post a screen capture, as
    they say, a picture is worth a thousand words. It's nice to be able
    to see a useful screen again. That was really a mess before.

    By the way, how do I get FF into safe mode? I'm still not sure how, I
    did not even know there was such a thing in FF. Windows has it (at
    least Win98), but I never knew FF had it. I dont thing IE has it, or
    does it?????

    Thanks again
    LM
     
    letterman, Jun 3, 2008
    #13
  14. letterman

    Rom Guest

    On Mon, 02 Jun 2008 19:52:21 -0500, wrote:

    [...]
    Good to hear it's fixed now.

    Try the NoSquint extension in Fx2, as a default zoom level and zoom
    increment can be set, is able to remember the zoom level by site, has
    a status bar icon with the current zoom level, toolbar buttons etc.
    <https://addons.mozilla.org/en-US/firefox/addon/2592>
    Fx2 version now here :<http://urandom.ca/nosquint/>

    The zoom in Fx3 seems an improvement over Fx2, even if Fx3 didn't
    provide a pref to set a default zoom level or buttons, so still need
    NoSquint or other extension, and don't think Fx3 supports Win98SE.

    Firefox Safe Mode is not the same as Windows Safe Mode. There's a
    shortcut for Firefox Safe Mode in the Start menu (adjust for your OS):
    Start > All Programs > Mozilla Firefox > Mozilla Firefox (Safe Mode)

    More info: <http://support.mozilla.com/en-US/kb/Safe+Mode>

    IE7 on Vista (don't recall if IE7 on WinXP too) has a similar thing
    called "Internet Explorer (No Add-ons)".
     
    Rom, Jun 3, 2008
    #14
  15. letterman

    LetterG Guest

    I'll have to try the newer version (IF I can run it on Win98)
    One last thing. I have a homepage which is a simple HTM file I
    created. It's on my own computer. It's just a background with links
    to search engines, the weather, and other stuff I use often. The font
    is very small on that page now.

    Could you please tell me what the default fonts and font sizes should
    be. (In the advanced settings for fonts).

    Thanks
     
    LetterG, Jun 3, 2008
    #15
  16. I'm using Serif for proportional fonts (12pt Verdana), 12pt Arial for
    sans-serif, and 13pt Anonymous for monospace, with a minimum font size of 9.
     
    The Chief Instigator, Jun 3, 2008
    #16
  17. letterman

    Rom Guest

    Tools > Options > Content, under Fonts & Colors, the Advanced button:

    --Fonts for: [Western ]--

    Proportional: [Serif ] Size: [16 ]
    Serif: [Times New Roman ]
    Sans-serif: [Arial ]
    Monospace: [Courier New ] Size: [13 ]
    Minimal font size: [None ]

    [x]Allow pages to choose their own fonts, instead of my selections above

    --Character Encoding--
    Default Character Encoding: [Western (ISO-8859-1) ]


    I think an alternative would be to type about:config into the
    address bar and press Enter. In the Filter box type font.
    All prefs would show their status as default, and any not showing as
    default could be reset via the context menu or double-click.

    If that doesn't improve the text size of your home page of links, the
    NoSquint extension would, as zooming text level is adjustable.
    Otherwise, someone else may help with the HTML coding of your page.
     
    Rom, Jun 3, 2008
    #17
  18. letterman

    yogi22 Guest

    SNIP
    I think this is excellent advice. My old eyes love this one,
    especially as it "remembers" the settings for individual sites between
    sessions. Ctrl+ScrollWheel are getting rusty from only being used the
    first time I visit a new site.

    This would solve your innovative homepage font problem, as once you've
    set your preferred size, NoSquint will remember it for you. If you
    later have second thoughts, NoSquint will save the newer settings for
    you.
    kk
     
    yogi22, Jun 3, 2008
    #18
  19. On windows, go to "Start...Run" and type "firefox.exe -safe-mode" in
    the input box, click "Ok" and Firefox will come up without any
    extensions or themes.
     
    John Thompson, Jun 3, 2008
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.