Tearing my hair out

Discussion in 'Wireless Networking' started by GB, Sep 18, 2007.

  1. GB

    GB Guest

    Please, please see if you can help me!

    My desktop PC has a rather flakey wireless connection, as the router is at
    the other end of the house. Eventually, I ran a network cable from the
    router to the PC. Unfortunately, Windows still seems to prefer the wireless
    connection to the cable.

    Specifically, if I disable the wireless connection, I can connect to the
    router using the cable connection, but I can't get beyond the router to the
    outside www. I can ping the router and get a <1 ms response, and I can bring
    up the router's admin screen.

    I thought that maybe this is an issue with the cable or the router, but if I
    plug the cable into my laptop it connects just fine.

    Any ideas please?
     
    GB, Sep 18, 2007
    #1
    1. Advertisements

  2. GB

    Lem Guest

    It sounds as if there is no default gateway set on the Ethernet NIC in
    the desktop. Is that NIC configured to obtain an IP address
    automatically? If you have set a static IP, configure the default
    gateway to be the IP address that you use to access the router's admin
    utility.

    OR

    Open a command prompt window and type
    ipconfig /all [press enter]

    and post the results.
     
    Lem, Sep 19, 2007
    #2
    1. Advertisements

  3. GB

    GB Guest

    Thanks - please see the result of ipconfig/all below:

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Philip
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : Belkin

    Ethernet adapter Local Area Connection 2:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated
    Cont
    roller
    Physical Address. . . . . . . . . : 00-0F-1F-4A-3E-B7
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.2.15
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.2.1

    Ethernet adapter Wireless Network Connection 2:

    Connection-specific DNS Suffix . : Belkin
    Description . . . . . . . . . . . : Belkin Wireless Pre-N Notebook
    Netwo
    rk Card
    Physical Address. . . . . . . . . : 00-11-50-2E-59-BA
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.2.14
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.2.1
    DHCP Server . . . . . . . . . . . : 192.168.2.1
    DNS Servers . . . . . . . . . . . : 192.168.2.1
    Lease Obtained. . . . . . . . . . : 18 September 2007 23:54:53
    Lease Expires . . . . . . . . . . : 02 October 2007 23:54:53

    I then changed the properties of the tcp/ip of the ethernet adapter, and
    ipconfig/all gives this:

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Philip
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : Belkin
    Belkin

    Ethernet adapter Local Area Connection 2:

    Connection-specific DNS Suffix . : Belkin
    Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated
    Cont
    roller
    Physical Address. . . . . . . . . : 00-0F-1F-4A-3E-B7
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.2.18
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.2.1
    DHCP Server . . . . . . . . . . . : 192.168.2.1
    DNS Servers . . . . . . . . . . . : 192.168.2.1
    Lease Obtained. . . . . . . . . . : 19 September 2007 12:24:31
    Lease Expires . . . . . . . . . . : 03 October 2007 12:24:31

    Ethernet adapter Wireless Network Connection 2:

    Connection-specific DNS Suffix . : Belkin
    Description . . . . . . . . . . . : Belkin Wireless Pre-N Notebook
    Netwo
    rk Card
    Physical Address. . . . . . . . . : 00-11-50-2E-59-BA
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.2.14
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.2.1
    DHCP Server . . . . . . . . . . . : 192.168.2.1
    DNS Servers . . . . . . . . . . . : 192.168.2.1
    Lease Obtained. . . . . . . . . . : 19 September 2007 12:24:51
    Lease Expires . . . . . . . . . . : 03 October 2007 12:24:51
     
    GB, Sep 19, 2007
    #3
  4. GB

    GB Guest

    I don't know how you managed to solve my problem from so little information,
    but I guess that's why you're an MVP. Anyway, I opened the tcp/ip properties
    on the ethernet adapter and set both ip and dns to be obtained
    automatically. Problem now solved. Thanks very much!
     
    GB, Sep 19, 2007
    #4
  5. GB

    Lem Guest

    You're welcome.
     
    Lem, Sep 19, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.