"System" task hogging CPU

Discussion in 'Windows 64bit' started by Guest, May 14, 2006.

  1. Guest

    Guest Guest

    I am running XP x64 edition on a quad Opteron machine and have been very
    pleased with system stability and performance so far. Today I took a look at
    the system utilization in the task manager, and found out that the "System"
    task (that's the kernel I suppose) was hogging one of my four CPU's (always
    the 4th btw, strong affinity).

    I tried rebooting and shut down all system services and processes that let
    themselves be shutdown, without any effect. I can not tell what exactly
    caused this odd behavior, since I do not check resource utilization on a
    regular basis and a CPU hogging process can go undetected for a while on a MP

    Do you know of any tools I might use to narrow down the problem?
    Guest, May 14, 2006
    1. Advertisements

  2. Guest

    Guest Guest

    I forgot to tell that I already shut down the DCOM service, so that's not it.
    Guest, May 14, 2006
    1. Advertisements

  3. Hi Philipp

    Are you running Terminal Server on this machine (or Remote Access if it's an
    XP box) with a default printer selected?

    It's an 'undocumented feature' of Terminal Server that it can get sometimes
    get upset trying to talk to a printer (usually network) and nail one of the
    CPUs in the manner you describe. It's all to do with Winlogon and
    authenticating on the printer. Killing Spoolsvc.* usually works.

    I have seen this happen on 32 bit and 64 bit servers. There's also a
    background thread which zeros out pages on disk when you're not using the
    machine but that's not normally hogging the System.

    Try SysInternals Process Explorer
    (http://www.sysinternals.com/Utilities/ProcessExplorer.html) which includes
    a 'super task manager' which might help you.

    The x64 bit version can be downloaded from here:

    Hope this helps,

    Simon Meacham, MCP MBCS
    64 bit blog @ http://lxivdigiti.wordpress.com
    For email: Remove ".nospam" from end of address.
    Simon Meacham, May 14, 2006
  4. Guest

    Guest Guest

    Hi Simon. I disabled the remote service and removed all printers without any
    effect, so that does not appear to be the issue.
    This is really a great tool. It allowed me to pin-point the location in the
    System task where CPU cycles are wasted:


    There appears to be something going on between ACPI.sys and the
    Ipv4AddressToString function in the kernel.

    Apparently I get a lot of hardware interrupts and deferred procedure calls:


    When I look at the properties of the System task, I see 0 I/O operations or
    page fault deltas. However, the number of contexts constantly changes.

    I unplugged all externel peripherals without any effect on hardware
    interrupts or CPU utilization. I have a SoundBlaster X-Fi, a 3ware hardware
    RAID controller, and 2 GeForce 7800 installed, all working perfectly normal.

    Thanks for getting me thus far :) Any further ideas?

    Guest, May 15, 2006
  5. Hi Philipp

    It looks like a driver is to blame for one of your remaining cards. I was
    going to blame the Soundblaster (they have a bad rep for this) before seeing
    it's the new one with very low CPU usage.

    Then I found this thread
    http://www.sysinternals.com/Forum/forum_posts.asp?TID=837&PN=1 here on
    sysinternals from last year which seems very similar to the problem you're
    encountering. In all cases it appeared to be the NVidia Drivers which were
    to blame, ACPI.sys, high DPCs, one processor nailed at 100%.

    Trying uninstalling the graphics card and drivers, and see what happens to
    system performance then put it back again.

    Let us know how you get on.


    Simon Meacham, MCP MBCS
    64 bit blog @ http://lxivdigiti.wordpress.com
    For email: Remove ".nospam" from end of address.
    Simon Meacham, May 16, 2006
  6. Guest

    Guest Guest

    Thanks for your effort. It might very well be a driver issue. Indeed, I
    updated my graphics card drivers just a few days ago. I already suspected
    nVidia and downdated the drivers again --to no avail though. Then again,
    drivers often make irreversible changes to the system. I will keep working in
    that direction.

    Thanks again,
    Guest, May 16, 2006
  7. I don't know if this is of any help, but for nVidia drivers you may have to
    go all the way back to V. 7184 from a year ago, as I remember, that one ran
    anything you would throw at it.

    V. 77xx had problems, and later I've noticed several that had peculiar
    performance. Nothing clear to point my finger on.

    Also, NGOHQ.com have tweaked drivers, not just for performance - I recommend
    you give them the once-over at least.

    Regards, Tony. . .
    Tony Sperling, May 16, 2006
  8. Guest

    Guest Guest

    Hi Tony.

    I tried a variety of graphics, sound card, and RAID controller drivers
    today, without any effect on CPU utilization. I further reset my BIOS to
    defaults... nothing. Booting windows in safe mode does not change the
    situation. I even removed all cards (except the graphics cards of course)
    from the mainboard to no effect. Ah, and I removed those pesky StarForce
    drivers (how they passed the Windows Logo Test remains a mystery)... nada, of

    Now for the interesting part. I _suspended_ the ACPI.sys thread with the
    Process Explorer tool (brilliant piece of software btw), and my PC kept
    running just fine. In fact, I can play games, listen to music, browse the
    net, and access all my hard drives. Whatever is keeping me busy is not only a
    resource hog, but also completely useless.

    Here's a stack trace:


    Maybe someone working for Microsoft can figure that out. Since ACPI.sys
    appears to be stripped, I can only speculate that it is stuck in an infinite
    loop involving a spin lock. Whether that is a kernel bug introduced with one
    of the latest hotfixes, or a driver bug, I can not tell.
    Guest, May 16, 2006
  9. Well, at least it is far more interesting to follow your 'travails', than it
    is to try and wiggle out of it, I expect.

    Is this an early Opteron system? Like a first generation board - how about
    your BIOS, have you ever looked for an update? Some boards are said should
    not run with 'Cool&Quiet active, and you should try and disable any BIOS
    suppport that you do not use; just a couple of the things that has been
    giving people grey hairs here.

    And then there's my favorit helper - put the machine on to a well lit table
    and carefully remove every card and cable from it's connector and reseat
    them in succession, so as not to forget where they belong, this includes the
    memory as well. And of course, running a thorough memory test-suite over
    night as a minimum, is an option to.

    Have you thought about making a complete back-up, taking the system down and
    install clean, from scratch? It's amazing, in my experience, how much wisdom
    you pick up from daily contact with your digital 'pal', and seeing it naked
    after a while can give you a whole new perspective on those troubles. It is
    a 'fishy' one, though, I have to say.

    Perhaps you should pay AMD a visit, they have a little library of technical
    white papers in PDF format for each of their processors, if nothing turns
    up, let support have a look at those print-outs of your's - they have the
    expertise, after all.

    I hope I get to hear the good news at the end of all this!

    Tony. . .
    Tony Sperling, May 17, 2006
  10. Tony Sperling, May 17, 2006
  11. Guest

    Guest Guest

    Glad my misery has a positive side ;)
    It's a dual-socket Tyan K8WE Thunder with 2 Opteron 280, codename Italy,
    mounted. I bought them right when they became available, so it is probably an
    early stepping. Still, I have very little reason to suspect them of being the
    troublemakers here.
    I already removed everything from the board that was removable. If it's a
    hardware issue, it's permanent.
    Yes I did think about it. Then again, I am not one of they guys who readily
    accepts wiping his hard-disk every once in a while because Microsoft does not
    give me the forensic tools necessary to fix my system. Moreover, I have no
    interest in explaining some telephonist in Bangalore why I need yet another
    activation code.
    I would gladly contact AMD, Microsoft, or whoever might be of help. But
    unless I have hard evidence that points in any direction, I can not
    reasonably expect them to listen.
    So do I. Thanks for the cheers :)

    Btw, I checked out the AMD site. I had already installed the Cool&Quiet
    drivers, and I remember downloading some instruction set specifications for
    assembly optimizations (SSE/3DNow vectorizations) I wrote at work.


    P.S.: I don't have time to experiment tonight. Maybe I have more info
    Guest, May 17, 2006
  12. I once had an Asus dual proc board which worked fine in APM mode but when
    the bios was flashed to the (then new) ACPI it nailed one of the cpus to
    100% because an interupt line was physically wired wrong.

    I did some poking around about your board on the board on

    Last BIOS was late March of this year which shows an MP fix to do with an
    IRQ/APIC error in the IRQMAP which looked interesting...
    TYAN Thunder K8WE (S2895) V1.03 (ftp://ftp.tyan.com/bios/2895_103.zip)
    New features and Fixes :
    * Updated nVidia PXE version (v229.xxx)
    * Updated AMD PowerNOW! support
    * Fixed and issue with the LSI SCSI Option ROM not working
    correctly when enabled or disabled from the bios
    * Relate Sys Fan1 and Fan4 with Auto Fan control settings, Auto
    will run 50% output, Full will be 100% and Quiet 0%
    * Fixex an issue where Video does not come back on from an
    S1 state
    * Updated CPU temp reporting for greater accuracy
    * Update the max PCI scsi drive number to 16.
    * The device on IO4 has gotten incorrect APIC routing, update
    link2.asi to fix it.
    * Fixed some issues with the Option ROM's of some VGA cards
    which failed to boot up the system and hang at post code 49h
    * Enable IO APIC on IO4
    * Fixed a MP-BIOS error that indicated 8254 timer has not been
    connected to IOAPIC error by remove the INIT2 from legacy
    * Fix CPU temp offset has not been programmed properly
    problem by reverse the Offset programmed on both CPU.
    * Empty CPU socket will now report no temperature

    Also interesting was the previous fix which included the ominous statement

    "NOTE: If you are running a current OS installed with nVidia nForce driver
    v6.39 and bios version v1.01, you will need to re-install your OS using at
    least nVidia nForce driver v6.66 and bios v1.02."

    What's your BIOS rev? And have you reinstalled since BIOS 1.01?


    Simon Meacham, MCP MBCS
    64 bit blog @ http://lxivdigiti.wordpress.com
    For email: Remove ".nospam" from end of address.
    Simon Meacham, May 18, 2006
  13. Hi, Philipp.

    1. The reason for identifying the earliness of that system, was not to throw
    suspicion on the hardware - I was thinking of the BIOS.

    2. Having hard evidence is always nice. Yes, I know the feeling, but the
    technical division at AMD would be very interested in hearing about anything
    of this order, I'd suspect, the trouble, as you say is getting past the help
    desk! If you tell them as calmly as possible that you need to contact a
    technician because ACPI.SYS is strangling your processors, I'd be surprised
    if they (HD!) would have any more questions about the issue. I am possitive
    that you may very well expect them to listen.

    3. O.K. you have the C&Q drivers, but have you tried disabling it? And
    PowerNow to, as Simon is referring to below.

    Over all, Simon's findings seem to throw light on your problem, this is
    valuable research!

    Tony. . .
    Tony Sperling, May 18, 2006
  14. Guest

    Guest Guest

    Thanks for your input Simon and Tony.

    As for my BIOS and nForce driver. I have been running nForce 6.69 ever since
    I set up the system (December 2005). The problem appeared after installing
    the latest nForce driver (84.25) for x64. I am pretty sure of that after
    checking my system logs. I have not had installed anything driver-related for
    weeks before that.

    Since the problem appeared, I have tried a plethora of driver versions and
    even updated my BIOS and every flashable piece of firmware in the system. As
    I said, I even removed anything removable except the graphics cards and tried
    safe mode.

    Take a look at this thread I stumbled across:


    I have just appended my story to the end of it. It appears I am not alone,
    though my hardware configuration is rather unusual. Still, the problem
    appears to be fairly common with GeForce cards and dual-core CPUs.

    Since the RATTV3 tool does not work on x64, I can not (yet) verify that my
    graphics cards are to blame. I don't dare to reinstall x64, because it might
    very well be in vain... Maybe I will set up a 32-bit XP to see whether the
    problem transcends operating system boundaries and launch RATTV3 there.

    Guest, May 19, 2006
  15. I dare say you're not alone!Wow - this may warrant a kind of 'Spanish

    I mentioned the drivers from http://www.ngohq.com , did you ever try those?
    It's a long shot, and it's still the nVidia drivers but they have been
    re-worked enough to support all the cards that the original did not, and in
    your situation anything is worth trying, I suspect. Think of all those that
    would benefit with you!

    Several of the posters mentioned replacing the cards as working, I wonder if
    you should check withnVidia if they should happen to have a BIOS update
    laying around for your card?

    Tony. . .
    Tony Sperling, May 20, 2006
  16. Guest

    Guest Guest

    I tried the NGO and EVGA drivers. No effect on the interrupt bombardment :(
    NVidia does not appear to have firmware updates for their cards. The last
    time I ever updated a gfx card firmware was for my Matrox Mystique ;)

    I am thinking of writing my own ETW [1] client similar to RATTV3 because I
    can not find any decent tracing tools for x64. I won't have time to start
    with that for another week.

    Guest, May 21, 2006
  17. Guest

    Jud Hendrix Guest

    They do atually. Some time ago I pulled a BIOS-update of my 6600GT from the
    MSI-website. Did you check your manufacturers website?


    Inviato da X-Privat.Org - Registrazione gratuita http://www.x-privat.org/join.php
    Jud Hendrix, May 21, 2006
  18. Yes, EVGA do have BIOS Updates on their Drivers download list!


    (Good thinkin', Jud.)

    Tony. . .

    Tony Sperling, May 21, 2006
  19. I found this in the README to the AMD processor driver for XPx64:

    1) The processor performance state may not be restored to the maximum state
    if the CPU runs at 100 percent. This problem occurs if the computer is
    100 percent busywhen the power policy changes.

    For more information and support options, please refer to the following

    2) "System Properties" reports wrong processor speed.

    For more information, please refer to the following website:

    3) The Processor speed may be reported incorrectly in Windows XP.

    For more information, please refer to the following website:


    I have not made up my mind yet, if this has any significance?

    It sounds as though, if the processor is 100% busy the driver steps in wiith
    it's throttling algorithm and then never releases it again. This would be
    dependent in some fashion on ACPI, and may all-in-all show off a personality
    aspect with the dual processor set-up.

    This, in turn could mean that if one processor remains throttled, it has to
    work harder to keep up? In effect being locked at 100%, but still in a
    throttled condition.

    O.K. - I don't know - just one more thing to consider.

    Tony. . .
    Tony Sperling, May 22, 2006
  20. Guest

    Guest Guest

    I am happy to tell you, that I fixed the problem. A thread on sysinternals
    that linked the standby Mode to DPCs gave me the idea:


    I never use the Windows standby mode, but around the time the problems
    appeared, I remember accidentally pushing the standby mode, thereby crashing
    my PC. Obviously some piece of hardware or Windows itself remembered that
    failed standby attempt and kept flooding my kernel with interrupts ever
    since. I resolved the issue by sending the system to standby... this time
    without crash of course. Zero CPU usage since that.

    Thanks to everyone who helped. Btw, I am using ngohq drivers now for
    increased performance ;)

    Guest, May 29, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.