strongest AP not being chosen

Discussion in 'Wireless Networking' started by silvus, Mar 7, 2005.

  1. silvus

    silvus Guest

    Here is the setup: A mobile cart with 25 thinkpads. XP
    Sp2. 2 cisco access points with ssid broadcast enabled
    for cisco wap, the wap's are set as Preferred networks.
    The laptops and AP's are always in the same room.

    Here is what happens: The kids put the laptops to
    sleep(which means it holds the last ap), when the laptops
    are opened back up they get "limited internet
    connectivity" they have low signal and no "real"
    If I do a manual disconnect and reconnect it finds
    the APs on the cart, and everything is good.

    What I need: I need software or place to edit the
    registry so xp will always choose the ap with the
    strongest signal. I am fine with creating a button on
    the desktop, but whatever the solution it has to involve
    very little interaction(sixth graders will be using)

    If you need more info or have a solution feel free to
    mail me it or post here. Thanks for taking the time to
    peruse this mess.
    be well
    silvus Geeeemail Com
    ISAT Dot
    silvus, Mar 7, 2005
    1. Advertisements

  2. Hi,

    It sounds to me like the laptops are actually connecting to the wireless
    network, but they are not getting a DHCP address. Here's how you can check:

    1) Open up the laptop after it has been put into sleep mode
    2) Wait for the 'Limited or no connectivity' balloon to appear
    3) If the wireless icon in the toolbar has a red X on it, then you are
    not connected to any wireless network
    4) If you are connected to a wireless network, double click on the
    wireless toolbar icon. This should cause a status dialog to appear
    5) Check to see which network you are connected to.
    6) Click on the 'Support' tab at the top of the Status dialog. This
    will allow you to see what IP address you have.
    7) Try clicking on the 'Repair' button. This should reset the wireless

    If you are finding that the laptops are connecting to the wrong SSID,
    check the order of your preferred networks. It might be possible that a
    more preferred network is available.

    Here are some things you might also want to try:

    1) Check to see if there is an update to the driver for the wireless
    networking card on your laptop. This can be found either on the web site for
    the laptop manufacturer or the wireless card manufacturer
    2) Check the settings for DHCP on your Cisco APs
    3) You can also try running the command 'ipconfig /renew' from the
    command line prompt

    Also, for your information: The driver for the wireless network card is
    responsible for choosing which Access Point within a SSID to connect to.
    Windows XP and the Wireless Zero Config client merely tell the wireless
    driver to connect to a SSID using appropriate authentication and encryption
    settings. It's up to the driver to figure out which AP is the best one to
    connect to.

    Chris Gual [MSFT]
    Chris Gual [MSFT], Mar 7, 2005
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.