Strange HD Boot Problem

Discussion in 'Computer Information' started by mcp6453, Nov 20, 2005.

  1. mcp6453

    mcp6453 Guest

    I have a computer with an Intel D845GRG motherboard that is exhibiting a
    strange problem. When the computer boots for the first time, it does not
    see the hard drive on the Secondary IDE channel. If I reboot from there
    after the power has been on, it boots normally and recognizes the drive.

    1) The same behavior is seen with two different drives, both new.
    2) Increasing the wait-until-detect time for the IDE drives in the BIOS
    to 30 seconds did not make a difference. The Secondary channel drive
    does not even show up in the POST screen.
    3) Testing is done at DOS, so it is not a Windows problem.

    I cannot think of anything that it can be other than a motherboard
    problem that requires power to be applied for more than 30 seconds
    before the drive on the Secondary channel is detected. Any ideas?
     
    mcp6453, Nov 20, 2005
    #1
    1. Advertisements

  2. mcp6453

    Mark Mandell Guest

    Have you changed to a different IDE ribbon cable? Are the BIOS settings set
    for fail-safe, optimized?
     
    Mark Mandell, Nov 20, 2005
    #2
    1. Advertisements

  3. mcp6453

    Rod Speed Guest

    Thats unlikely, but possible.
    Are you sure you have both drives jumpered correctly ?
    You can get some odd effects when they arent.

    What happens if you have a different master ? It looks more likely
    that you have a pair of drives that dont coexist on a particular ribbon
    cable well. Try reversing the master/slave relationship.

    Try with both the new drives on that cable if you have them both at
    once. If that config still has the delay, its likely a bad motherboard.

    Try a new ribbon cable too, tho its not common to get that
    particular effect with a bad ribbon cable, its just cheap to try.

    It might be an inadequate power supply too. The slave may be
    coming up while the power isnt up to voltage properly and it
    needs a full reset with the power fully up to get the drive seen.
     
    Rod Speed, Nov 20, 2005
    #3
  4. mcp6453

    mcp6453 Guest


    All good suggestions. I will try each one of them as time permits. By
    the way, the ribbon cable is new, and I am positive that the jumpers are
    correct (evidenced by the fact that they drives work perfectly after the
    second boot) and are set for CS. The ribbon cable is 80-wire.
     
    mcp6453, Nov 20, 2005
    #4
  5. mcp6453

    Rod Speed Guest

    Can still be faulty.
    That doesnt prove that there isnt a problem, with some
    situations that arent correct, you can get some odd
    symptoms like that, only working in some situations.

    And some drive jumper diagrams can be quite confusing
    so while you may think you have them both jumpered for
    CS, that may not in fact actually be the case.
    Worth checking that you do have it the right way around,
    with the correct connector used for the motherboard end.
    You can get some odd effects with it on the wrong way around.
     
    Rod Speed, Nov 20, 2005
    #5
  6. mcp6453

    mcp6453 Guest

    The behavior is identical with the old cable as with the new cable.
    If the legend on the drive is correct, the jumpers are correct. I've
    been doing computer work since 1980 (TRS80 days).
    There are three connectors. Two are closer to one end. Those two
    connector to the drives. The farther connector is connected to the
    motherboard. That is the correct configuration. Again, though, since the
    old and the new cables act identically, I don't think there is a cable
    problem.
     
    mcp6453, Nov 20, 2005
    #6
  7. mcp6453

    Mark Mandell Guest

    Well it is indeed baffling and if all else fails, it's gotta be the mobo.
     
    Mark Mandell, Nov 21, 2005
    #7
  8. Further things to try:

    - change to a different Molex connector to power the drive.

    - disconnect non-essential IDE devices.

    - connect the drive to the slave connector of the primary IDE
    channel.

    - reset the CMOS memory on the motherboard
     
    Frazer Jolly Goodfellow, Nov 21, 2005
    #8
  9. mcp6453

    Rod Speed Guest

    OK that is certainly the evidence that the cable isnt the problem.
    Some of the legends are quite confusing and confuse those
    who have been doint computer work since well before that.
    Those should normally be grey and black.
    That should normally be blue.
    Sure, but you didnt mention that till now.
     
    Rod Speed, Nov 21, 2005
    #9
  10. Also, try jumpering as master/slave..

    --
    ******************************************************
    Most learned on these newsgroups
    Tumppi, Helsinki, FINLAND
    (translations from/to FI not always accurate)
    ******************************************************
     
    Thomas Wendell, Nov 21, 2005
    #10
  11. mcp6453

    Rod Speed Guest

    It wont be that if the effect he is getting is seen every time.
    Its only drives on that cable that matter.
    Wont be that either.
     
    Rod Speed, Nov 21, 2005
    #11
  12. mcp6453

    Robert Baer Guest

    I have read the other suggestions.
    Start with only one IDE device - one HD jumpered and positioned as
    Primary Master (without slave if Western Digital).
    Test first the "good" drive this way and use the BIOS for
    verification of drive type, etc.
    Then test the "bad" drive the same way and again use the BIOS for
    verification of drive type, etc.
    Now if the "bad" drive works without any problems this way, i bet
    that one of the drives is a Maxtor and the other one is not.
    If that is the case, toss the Maxtor (or give it away to your worst
    enemy).
    If they are both Maxtor drives, i bet that they are of different
    vintage; toss them both.
     
    Robert Baer, Nov 21, 2005
    #12
  13. mcp6453

    Odie Ferrous Guest

    Try reinstalling the motherboard drivers again - particularly the IDE
    drivers.


    Odie
     
    Odie Ferrous, Nov 21, 2005
    #13
  14. mcp6453

    The Outsider Guest

    Haha...I have this exact problem with an older 30gb Maxtor drive. As
    master on it's own it works fine but if it is on a cable with another
    drive I get the same symptoms the OP described. I still have the drive
    but I don't use it anymore.
     
    The Outsider, Nov 21, 2005
    #14
  15. mcp6453

    ReginaldP Guest

    Its a maxtor thing , certain drives only mix with other maxtors.
     
    ReginaldP, Nov 21, 2005
    #15
  16. mcp6453

    The_Jase Guest

    i just want to make a suggestion to upgrade the bios. the results just
    might surprise you....unless of course you've already done so.
     
    The_Jase, Nov 21, 2005
    #16
  17. mcp6453

    Brian Guest

    I had a similar problem with an AMD system and the problem was that the
    drives do not spin up fast enough before the newer motherboards complete the
    POST hence not recognized on initial boot. What I did as a work around
    (other than replacing the drives with faster speed drives) was allow the
    BIOS to run a full memory check and set the drives to autodetect on boot.
    That solved the problem for me. It gave the drives time to spin up while
    checking the memory and ensured they were detected with the autodetect.

    You can also bypass the memory check if it takes too long but if you don't
    mind waiting that extra 2 seconds for boot its a good thing to do anyway on
    a cold boot.
     
    Brian, Nov 22, 2005
    #17
  18. mcp6453

    Rod Speed Guest

    He already said that he had tried that.
     
    Rod Speed, Nov 22, 2005
    #18
  19. mcp6453

    Robert Baer Guest

    I have *yet* to see any other drive work with a Maxtor, except
    another Maxtor of the same vintage.
    I would be interested in learning about the exceptions that you
    allude to - byt be advised that non-response or generalities will be
    considered as "do not know".
     
    Robert Baer, Nov 22, 2005
    #19
  20. mcp6453

    Dave C. Guest

    I just recently added a second drive to my Dell (everything is fine) and
    noticed that on my secondary IDE cable, one lead is disabled. It has a
    short section, about 1/8 inch clipped out to disable it. If he has that in
    the primary position, would that cause his problem? Or does he need that
    line in the secondary cable disabled?

    Why is it disabled and if I ever has to replace the secondary cable, would I
    have to make sure that lead is disabled?

    (Running P4, in a two year old Dell, WinXP pro.)
     
    Dave C., Nov 22, 2005
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.