Strange duplex behavior on Cat 2940

Discussion in 'Cisco' started by Jens Haase, Jan 16, 2005.

  1. Jens Haase

    Jens Haase Guest

    Hi,

    I have two Cisco 2940 at a client site. Both have the same Problem:

    When I put the 100Mbit Ports and the Clients to "Duplex auto", everything
    works fine and the Clients connect and the Interfaces negotiate "Full
    Duplex".
    When I put the 100Mbit Ports to "Full Duplex" manually and change the
    configuration on the Clients to Full Duplex, the network becomes very slow.
    I tried this with different Network Cards in the Clients. Am I missing
    something?

    Jens
     
    Jens Haase, Jan 16, 2005
    #1
    1. Advertisements

  2. :I have two Cisco 2940 at a client site. Both have the same Problem:

    :When I put the 100Mbit Ports and the Clients to "Duplex auto", everything
    :works fine and the Clients connect and the Interfaces negotiate "Full
    :Duplex".
    :When I put the 100Mbit Ports to "Full Duplex" manually and change the
    :configuration on the Clients to Full Duplex, the network becomes very slow.
    :I tried this with different Network Cards in the Clients. Am I missing
    :something?

    Odd. That sounds exactly like what would happen if there were a duplex
    mismatch. When you turn off autonegotiation on the switch, then
    if you do not turn off autonegotiation on the client, the client
    is going to select half duplex instead of full duplex.

    Do not, by the way, trust that Windows 2000 will reliably report
    a negotiated duplex setting: I have encountered NICs which lie
    to Windows 2000, and Windows 2000 then passes the lie on to the
    user. If you have forced the duplex on the switch end, be sure
    to force it on the host end.
     
    Walter Roberson, Jan 16, 2005
    #2
    1. Advertisements

  3. Jens Haase

    Jens Haase Guest

    Actually there where 3Com Switches and Clients connectet to the Cisco Switch
    and I configured all devices manualy to 100Mbit full Duplex, just as the
    books tell us. When the windows guys told me, that network performance was
    poor, I switched back to "duplex auto" after 2 hours of troubleshooting.
    The problem only occurs, when the ports on the switch are set to "FULL
    DUPLEX" manualy. Setting the ports to 100MBIT does not make any difference.
    When set to "Auto Negotiation" the switch reports a 100Mbit Full Duplex
    Link.
    I think I will have to call TAC for this, but the Smartnets the clients
    ordered will not arrive before next week.

    Jens
     
    Jens Haase, Jan 16, 2005
    #3
  4. Jens Haase

    david Guest

    If they are working at 100Mb full duplex on auto and network performance
    is fine, why force it?

    If you set the switch to full and leave the windows machine to auto, is
    there any change in performance?

    You may want to check recalls on that switch also, there were a bunch of
    2900 switches that were giving false lights. They were being sold
    cheaply on the internet from Cisco dealers. I was in the market for a
    switch and found great prices but found out through Cisco.com that they
    had a faulty batch on the market.

    Check serial numbers and search the Cisco site for answers.
     
    david, Jan 17, 2005
    #4
  5. Jens Haase

    Hansang Bae Guest

    Probably not. Just another issue with 100Mbps based auto(non)
    negotiation. Some things to consider. Some NICs will lie to Windows.
    You have to hard code it with a utility that the vendor provides
    instead of doing it from windows.

    Try a different length cable. Yes, far fetched, but you wouldn't be
    the first one to hit this corner case.

    A question I have to ask "did you set the speed *and* the duplex? Or
    just the duplex setting?"





    hsb


    "Somehow I imagined this experience would be more rewarding" Calvin
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
     
    Hansang Bae, Jan 18, 2005
    #5
  6. Jens Haase

    Jens Haase Guest

    Hi,
    I set both speed and duplex, but only the duplex setting causes the problem.
    There are Clients and 3Com Switches connected to the 2940, and all devices
    have the same behavior.
    Another Strange issue is, that when I set the uplink port on the 2940 to
    100Mbit(Normally it is 1000MBit) it gets somewhat faster, but not as fast as
    it is when I set "duplex" to auto.
    The Problem occurs on both Switches on all Ports even with different length
    Cable.

    Jens
     
    Jens Haase, Jan 19, 2005
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.