Soho77: static nat with dynamic public ip

Discussion in 'Cisco' started by Sandrinho, Nov 16, 2006.

  1. Sandrinho

    Sandrinho Guest

    Hi everyone.

    I'm playing around with an old Soho77, bought used on Ebay :)

    I'm trying to configure a static nat with my adsl, and i have found this
    configuration line that works flawlessly:

    ip nat inside source static 192.168.1.1 88.149.140.xxx

    Unfortunately my IP address is dynamic, and this configuration works until
    atm interface is reset: if my public ip change, i lost connection with
    internet.
    I've tried this:

    ip nat inside source list 101 interface Dialer0 overload
    access-list 101 permit ip 192.168.1.0 0.0.0.255 any

    but this works only for outgoing connection... incoming connections are not
    forwarded to 192.168.1.1..

    I really need a static nat, with 1 to 1 IP mapping... PAT or DNAT don't work
    for me.

    Any hint?

    Thanks a lot.
    (my show r attached...)

    Current configuration : 1767 bytes
    !
    ! Last configuration change at 22:28:50 UTC Wed Nov 15 2006
    ! NVRAM config last updated at 22:29:10 UTC Wed Nov 15 2006
    !
    version 12.1
    no service single-slot-reload-enable
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname sandrouter
    !
    logging rate-limit console 10 except errors
    enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxx
    !
    ip subnet-zero
    no ip finger
    ip domain-name ngi.it
    ip name-server 88.149.128.12
    ip name-server 88.149.128.22
    ip dhcp excluded-address 192.168.1.254
    !
    ip dhcp pool LOCAL
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.254
    dns-server 88.149.128.12 88.149.128.22
    lease 0 0 1
    !
    no ip dhcp-client network-discovery
    !
    !
    !
    interface Ethernet0
    ip address 192.168.1.254 255.255.255.0
    ip broadcast-address 192.168.1.255
    ip nat inside
    no ip mroute-cache
    no cdp enable
    !
    interface ATM0
    no ip address
    no ip mroute-cache
    no atm ilmi-keepalive
    pvc 8/35
    encapsulation aal5snap
    protocol ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    hold-queue 224 in
    !
    interface Dialer0
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp pap sent-username xxxxxxxxxxx password 7 xxxxxxxxxxxxxxxxx
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    no ip http server
    !
    ip nat inside source static 192.168.1.1 88.149.140.149
    access-list 101 permit ip 192.168.1.0 0.0.0.255 any
    access-list 102 permit ip host 192.168.1.1 any
    dialer-list 1 protocol ip permit
    no cdp run
    !
    line con 0
    exec-timeout 120 0
    transport input none
    stopbits 1
    line vty 0 4
    access-class 23 in
    exec-timeout 120 0
    password 7 xxxxxxxxxxxxxxxxxxxx
    login local
    !
    scheduler max-task-time 5000
    sntp server 193.204.114.105
    end
     
    Sandrinho, Nov 16, 2006
    #1
    1. Advertisements

  2. try something like :
    ip nat inside source static 192.168.1.1 interface Dialer0 extendable

    HTH
    Martin
     
    Martin Bilgrav, Nov 19, 2006
    #2
    1. Advertisements

  3. Sandrinho

    Sandrinho Guest

    Yes, i've tried that syntax but it's not supported by my ios: 12.1(5)YB5

    Trying to update..

    Thanks a lot.
     
    Sandrinho, Nov 19, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.