Slow 54Mbps

Discussion in 'Wireless Networking' started by Rob Nicholson, Dec 10, 2005.

  1. I've had a D-Link DI-524 802.11g/2.4GHz wireless router for a while although
    I've not really used the wireless part aside from an occasional laptop at
    home. However, I've now building a Windows 2000 Server to which I've stuck
    in a D-Link GWL-G510 PCI 802.11g network card. Working fine except I often
    use Acronis True Image to image a server and on just running it, it's
    reported nearly one hour to image the C: drive across to my to main PC.

    This didn't seem right at all as a previous image across the wired network
    took about 4 minutes. I disabled the wireless and re-enabled the wired NIC
    and the same image was estimated to take 3 mins.

    When I look at the configuration tool, the wireless link rarely goes above
    12Mbps and seems to be stuck on 11Mbps. I know that the throughput is never
    really 54Mbps but it should be faster than this! The link quality is well
    over 90% usually around 98%. The signal strength is full. The server is
    actually only two feet away from the access point, actually 2 feet
    underneath with a wooden table in the way. Can wireless be too close to each
    other?

    Cheers, Rob.
     
    Rob Nicholson, Dec 10, 2005
    #1
    1. Advertisements

  2. Rob Nicholson

    Lem Guest

    Do you have either the router or the wireless NIC set to "mixed" or "b"
    rather the "g only"? I don't know about D-Link, but IIRC, Linksys
    routers default to "mixed mode" (b and g). If you only have one g-mode
    client, setting the router to mixed "shouldn't" make a difference, but
    I'd double check to see that each end of the link is set to g-only.
     
    Lem, Dec 10, 2005
    #2
    1. Advertisements

  3. Do you have either the router or the wireless NIC set to "mixed" or "b"
    The router is set to mixed mode. The NIC doesn't have a way of specifying
    the type so I assume it's fixed to "g". You can change the TX rate but
    that's currently set to auto.

    The TX rate does, very rarely, go up and I've seen it once say 54Mbps but
    when I'm stressing the link by copying a large file, I kind of expected it
    to go up and stay up for a while.

    Cheers, Rob.
     
    Rob Nicholson, Dec 10, 2005
    #3
  4. routers default to "mixed mode" (b and g). If you only have one g-mode
    I've set the router to "g" mode only to see if that makes any difference.

    Cheers, Rob.
     
    Rob Nicholson, Dec 10, 2005
    #4
  5. Rob Nicholson

    Guest Guest

    Make sure you are running the latest firmware for the DI-524.

    MD
     
    Guest, Dec 11, 2005
    #5
  6. Make sure you are running the latest firmware for the DI-524.

    Ahh there in lies a tale :) I upgraded yesterday to the v1.20 BIOS as I'm
    full aware of some of the problems with the firmware on the DI-524 in the
    past. I was still running the original BIOS as I had problems when I
    upgraded about a year ago. However, v1.20 does appear to be working fine.

    Cheers, Rob.
     
    Rob Nicholson, Dec 11, 2005
    #6
  7. Rob Nicholson

    Guest Guest

    I also found that setting up my network for WPA (vs WEP) slowed it down
    considerably - something you need to take into account.

    MD
     
    Guest, Dec 12, 2005
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.