Session.lcid has stopped working

Discussion in 'Computer Support' started by Bibble Babble, Oct 11, 2003.

  1. Hi, W2K SERVER, IIS, SQL 2000. I have an include file in an ASP page (not
    ..net), below is the first part of it. It basically sets the LCID to UK and
    then creates and opens the connection to the SQL database.

    Without the first line SESSION.LCID = 2057 then the page loads as it should,
    as soon as SESSIOIN is put back in then I get the error message below about
    an object required

    This used to work but it has been moved to another server and I can't find
    anything on either server that needs setting

    Any help is greatly appreciated


    <% session.LCID = 2057
    openstr = "Provider='SQLOLEDB.1';Password='*****';Persist Security
    Info='True';User ID='*****';Initial Catalog='*****';Data Source='*****'"
    set cn = server.createobject("ADODB.Connection")
    cn.Open OpenStr


    Microsoft VBScript runtime error '800a01a8'

    Object required: 'session'

    /genmed/aberdeen/Partners/.\partdbinclude.inc, line 1
     
    Bibble Babble, Oct 11, 2003
    #1
    1. Advertisements

  2. OK, once I had removed thumb from a** and cotton wool from brain, I realised
    I hadn't set the App Options in Applications Settings on Home Directory tab
    in web server properties

    Sorry to disturb, it is early Saturday morning and that's my excuse
     
    Bibble Babble, Oct 11, 2003
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.