seeking optipoint sip help

Discussion in 'VOIP' started by Rob Walford, May 31, 2005.

  1. Rob  Walford

    Rob Walford Guest

    I have a Siemens Optipoint 400 with SIP software.
    I have managed to set it up to nearly work.
    I am still unable to make or receive calls.

    The ethereal trace shows:
    SIP status : 407 Proxy Authentication Required
    so it looks like its trying to log on with sipgate.

    the sipgate softphone works fine from my PC.

    Has anyone had any experience with this handset?
    TIA.
     
    Rob Walford, May 31, 2005
    #1
    1. Advertisements

  2. Rob  Walford

    Rob Walford Guest

    apparently it wont work with internet sip providers, as it doesnt
    support stun servers.
    bugger.
     
    Rob Walford, Jun 2, 2005
    #2
    1. Advertisements

  3. That's not a big problem if you can configure your NAT router to
    forward to it the UDP ports used by SIP (5060) and by RTP (a range of
    ports usually configurable in the phone setup).

    Enzo
     
    Enzo Michelangeli, Jun 3, 2005
    #3
  4. Rob  Walford

    Rob Walford Guest

    its not the ports that is the problem. its authenticating with the
    sipgate server.
    i am unable to log on to my sipgate account, and therefore cannot make
    or receive calls.
     
    Rob Walford, Jun 3, 2005
    #4
  5. OK, but the logging is achieved through "REGISTER" messages, and those
    travel inside UDP packets which, like any UDP packet, have source and
    destination port numbers (16-bit integers). By default, the SIP
    protocol uses the port number 5060, so, if your phone can't make use of
    a STUN server to gather information about the NAT and modify the
    content of its SIP messages to work around it, you may still be able to
    make it talk with the server by programming the NAT opportunely. What
    are brand and model of your NAT router?

    Enzo
     
    Enzo Michelangeli, Jun 4, 2005
    #5
  6. Rob  Walford

    Rob Walford Guest

    My knowledge of SIP etc is not very deep.
    my router is a us robotics sureconnect modem/router 9003.
     
    Rob Walford, Jun 4, 2005
    #6
  7. I've never used that model, but from what I see at
    http://firewalling.com/usr/SureConnect9003-firewallallow.htm it should
    be possible to configure it to make your SIP phone work. The most
    difficult thing is to guess the range of UDP ports used by your SIP
    phone for the RTP packets that convey the voice data. The precise port
    number used for each connection is communicated inside SIP packets, so
    you should tell the router to forward all the ports in the range to the
    phone, plus the port used for SIP which is normally 5060. If the
    documentation of your phone doesn't tell and you want to play it safe,
    you may always forward ALL the UDP "high" ports (between 1024 and
    65535) to the phone; this will however prevent from working UDP-based
    applications (e.g., network games of filesharing programs) running on
    computers on the same LAN.

    Also, I think that you have to program the router to allow all the
    outgoing UDP packets FROM the phone TO anywhere. This too is documented
    at http://firewalling.com/usr/SureConnect9003-firewallallow.htm .

    Good luck!

    Enzo
     
    Enzo Michelangeli, Jun 5, 2005
    #7
  8. Rob  Walford

    Rob Walford Guest

    thanks for that.
    ive had a go, but still no joy.

    im not getting authentication failure message now, but i see four of
    these:

    SIP/SDP Request: INVITE sip:[email protected]:5060, with session
    description

    10000 is the sipgate test number that i am dialling and 217.10.79.219
    is the sipgate ip address and obviously 5060 is the port number.
    Obviously if i look into the messaging there is more stuff, but i cant
    work out whats going wrong.

    Im looking at captures with ethereal, but while i sort of understand
    what i am looking at, i dont really know what to look for with regards
    to what the phone is trying to do.

    Any more help greatly appreciated!!!
     
    Rob Walford, Jun 7, 2005
    #8
  9. The "INVITE" message is the one sent by the caller to the called party,
    usually passing through a middleman (the "outbound proxy") belonging to
    the provider. In cases like yours the message is also sent to the
    provider's server because the device you are calling is supposed to
    have registered with it, and the server will either pass the "INVITE"
    to the called device or, more infrequently, reply to you asking to send
    it directly to the called device at the IP address so-and-so, much like
    a web server when it sends an "HTTP redirect" (that would be the
    so-called stateless proxying).
    If the INVITE is repeated four times, probably your phone doesn't
    receive the "OK" from the server. This may be due to a number of
    reasons: the outgoing packet can't go through the router; the
    credentials (userID and password) that your phone uses to authenticate
    itself to the server are wrong; or the replies from the SIP server
    can't get in through the router and then arrive to the phone.

    Even after this problem is solved, you might have a connecton but no
    audio in one or both directions: this is usually due to problems with
    the RTP packets that carry the voice data. Again, that could be due to
    the router blocking them, or to the UDP port mapping done in a way
    different from what phone and server have negotiated (that also depends
    on whether or not phone and server abide by the rules described by
    http://www.ietf.org/rfc/rfc3581.txt ... If your phone supports
    "symmetric RTP", do enable it: it may enhance the chances of getting
    the audio working.

    If by now you are pulling your hair, take comfort in knowing that you
    are not, by any means, the only one... See e.g. the debate at
    http://www.isen.com/blog/2004/05/sip-was-good-idea-once.html .
    Unfortunatley Ethereal can only see the packets on the LAN side of the
    NAT, but can't tell you e.g. the UDP port numbers (both source and
    destination) on the external side.
    This introduction, especially the sections 1.4 and 1.5, should give you
    an idea of how SIP works (or is supposed to work ;-) ):

    http://www.iptel.org/ser/doc/sip_intro/sip_introduction.html

    This will help you making some sense of the packets sniffed by
    Ethereal.
    By the way, even before placing calls you should see the "REGISTER"
    transactions that your phone initiates in order to let the provider's
    server know its IP address and the fact that it's online. Until the
    REGISTER succeeds, there is little hope that other types of
    transactions (such as the INVITEs) may have better luck...

    Cheers --

    Enzo
     
    Enzo Michelangeli, Jun 8, 2005
    #9
  10. Rob  Walford

    John Guest

    Hi Rob,

    I myself have done battle with the optipoint 400, and Oh what a
    battle!!!
    I am a bit of a novice but can share what basics I have found so far!
    I purchased the phone of ebay so thankfully didn't pay too much for
    it.
    The phone is available from hellodirect.com for above $300 in the
    states, and the American version uses a different firmware that looks
    better specified than the standard SIP firmware from siemens in .DE.
    However I have emailed both siemens in Germany and the States and my
    requests have been totally ignored!!.
    I cannot get the phone to log on to sipgate at all and I think I have
    tried everything in my power to try and sort the problem.
    I have also tried Gradwell, Gossiptel without success.
    Now the sort of good news....
    I signed up for an account with voipfone.co.uk and to my surprise and
    joy!! I was able to receive and make calls, Oh the joy of hearing it
    ring!! After hours and days of wasted time trying to get it to work.

    I have looked at the active nat sessions in my draytek routers
    configuration and the phone uses ports 5010 and 5011 for voice and port
    5060 to communicate with.

    It is not 100% as I have had a few calls drop audio and it failing to
    respond to the voipfone server fairly often when the call is cleared.

    After extensive evaluation I have also discovered port 5060 is
    sometimes dropped from the NAT table, it comes back on and off during a
    call without affecting the call, but if you end the call while it has
    been dropped from the NAT table the phone reports "no server",
    sometimes it restores itself, other time only a reboot or disconnect /
    reconnect the LAN to the phone brings it back. Saying that I have been
    testing it just now and although port 5060 is shown in the table, after
    clearing down a test call the phone reports "no server" (it has just
    logged on itself after about 5 mins).

    When it works the audio is first class, it really is a great phone and
    a joy to use, a shame about the siemens support!!.

    I have the domain name set as voipfone.co.uk
    Registrar, server, gateway set to voipfone.co.uk
    OBP proxy nat.voipfone.co.uk
    Sip transport UDP
    Sip realm asterisk
    Sip user name (your voipfone number)
    Password (your password)
    Sip routing server
    Terminal number (your voipfone number)

    It may be worth a try to see if it works for you.

    Hope it helps!


    John
     
    John, Jun 11, 2005
    #10
  11. Rob  Walford

    Rob Walford Guest

    thanks john!
    when i have the time i'll have a play.
    so on your router how exactly have you got NAT / port forwarding set up
    for the 3 port numbers you stated? (im a bit of a novice myself!)
     
    Rob Walford, Jun 11, 2005
    #11
  12. Rob  Walford

    John Guest

    Probably the best way is to try the phone in the DMZ of the router,
    that way it should work OK.
    I think my router is fairly VOIP friendly as I have found that it makes
    no difference if I forward the ports, put it in the DMZ or just leave
    it to sort its self out.
    You could also try forwarding UDP ports 5010, 5012, and 5060 to the IP
    address of the phone.
    John
     
    John, Jun 11, 2005
    #12
  13. Rob  Walford

    Rob Walford Guest

    i signed up with voipfone, but when i use your settings, i get this
    message:
    The submitted data contained errors:

    * Invalid Terminal IP Address: voipfone.co.uk
    * Invalid Terminal IP Address: voipfone.co.uk
    * Invalid Terminal IP Address: voipfone.co.uk

    im guessing for the registrar, server, and gateway addresses.

    If i enter the ip address instead (212.187.162.78 then it takes it, but
    i get "no server" flashing on the display.
    I had it set for gateway when i tried to set up sipgate, so i changed
    it to that and it now looks ok. However, i still cant make any calls,
    so i guess i need to spend a bit more time.
    What version of f/w has your phone? mine is 2.3.14.
    i'll let you know how it goes.
     
    Rob Walford, Jun 11, 2005
    #13
  14. Rob  Walford

    RJHN *1JOD Guest

    Hi Rob

    I certainly had the same errors as you initially but can't remember
    exactly how I solved the problem.

    A few further thoughts,

    I would reset the settings on the IP and routing page and then check
    you have the domain name field set to "voipfone.co.uk" I have a feeling
    this needed setting before the settings on the system information page
    were filled in, and saved.

    I have had a play today to see if I could get the phone to behave
    itself after clearing down the call.
    It seems to make no difference whether the OBP setting is ticked or
    not, I currently have it un ticked and it makes no difference to the
    behaviour of the phone.

    I also changed the OBP domain to voipfone.co.uk; again this doesn't
    seem to make any difference, so I guess the phone is not providing the
    correct OBP information. So guess this is probably why the phone keeps
    loosing the vopifone server.

    Almost forgot, I am using the same firmware 2.3.14,

    Hope this helps!

    John
     
    RJHN *1JOD, Jun 12, 2005
    #14
  15. Rob  Walford

    Rob Walford Guest

    Fantastic! I can now make an outgoing call to a landline.
    I cant seem to call a sipgate phone (i have x-lite on my PC).
    i cant seem to receive a call though.
    I get either number incorrect from my mobile, or from my sipgate line i
    got a person unavailable message (possibly voicemail).
    My router doesn't have a DMZ. Maybe the port forwarding needs a bit
    more work.
     
    Rob Walford, Jun 12, 2005
    #15
  16. Rob  Walford

    RJHN *1JOD Guest

    Brilliant!!

    The 056 number wont work from my virgin mobile, but OK from the
    landline.

    I think the reason xlite wont call the siemens may be because they both
    use port 5060 for sip info, I seem to remember being unable to get
    xlite to work with an IP phone or xlite within the same LAN.I don't
    have xlite installed now.

    At least it's heading the right way!!!

    John
     
    RJHN *1JOD, Jun 12, 2005
    #16
  17. Rob  Walford

    RJHN *1JOD Guest

    Sorry forgot to mention,

    Forward UDP port "5060"
    Forward UDP ports "5010 to 5013" that way it includes port
    5010,5011,5012,5013, as when the optipoint talks to another optipoint
    the next pair of ports are used.
    Forward these to the IP address of the phone.

    John
     
    RJHN *1JOD, Jun 12, 2005
    #17
  18. Rob  Walford

    Rob Walford Guest

    ah! i was using a virgin mobile!
    trying to use 2 sip phones at once and it not working makes sense (cant
    see the wood for the trees!).
    of course they are trying to use the same port. doh!
    i'll have another play when i get a chance.
    thanks again.
     
    Rob Walford, Jun 12, 2005
    #18
  19. Rob  Walford

    Rob Walford Guest

    just tried to call from a landline and an O2 mobile and i get the
    voipfone voicemail greeting.
    strange......
     
    Rob Walford, Jun 13, 2005
    #19
  20. Rob  Walford

    RJHN *1JOD Guest

    Wonder if the phone is not responding because the voipfone server
    can't see the phone behind the router properly.

    I suppose when you make a call from the siemens it opens the ports
    through the router and so you are able to make a call.

    I guess the phone sends out the register requests and the
    firewall/router/NAT passes these through to the server, and because the
    phone initiated the request, the response from the server is passed
    through the firewall to the phone and it is able to log on/ make calls.


    If the server makes the request (for an incoming call) then maybe the
    firewall/NAT is unable to pass these correctly to the phone.

    May be worth checking the configuration of the router as Enzo mentions
    earlier in the thread, I start to quickly get out of my depth when
    discussing the protocols of SIP port redirection etc!

    As Enzo says, you would need to pass the ports (I mentioned earlier)
    from the IP of the phone to any destination in the routers
    configuration. May be worth doing a google for your router and SIP.

    It can get so complicated, as life seems to be these days!

    John
     
    RJHN *1JOD, Jun 13, 2005
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.