Securing Network files in XP

Discussion in 'Computer Support' started by cromi, Feb 20, 2004.

  1. cromi

    cromi Guest

    Securing Network files in XP

    I have recently installed a wireless network. Switched on WEP 128 bit
    encryption, locked it down by mac address etc. etc. I have a hardware
    Linksys router/switch WRT54 and two pcs one a notebook running 802.11g
    xp home and a desktop running xp pro

    The problem is I am running two firewalls Norton Internet Security and
    Zone Alarm but when I go to access a shared folder from the notebook
    on the desktop it doesn't stop me or ask me any questions at all. I
    am worried that somebody could come down the cable modem and access
    the shared files on the desktop. I have run shields up internet test
    and it says that everything is closed and stealthed and so does the
    Norton test. I have tcp/ip and ipx running

    Any ideas why neither firewall is blocking or asking if this is a
    trusted pc etc?

    I have checked the trusted zones on both pc's firewalls and there is
    nothing in there

    thanks
     
    cromi, Feb 20, 2004
    #1
    1. Advertisements

  2. cromi

    Dan Shea Guest

    AFAIK, Zone Alarm wouldn't ask if it's a trusted PC because it only
    asks about *types* of traffic you want to allow. If you've already
    instructed it to permit file sharing, it won't ask again. I would
    hazard a guess Norton works somewhat the same. Also, it may the case
    that since these are PCs on your private network, your software
    firewalls automatically consider them to be "trusted".

    FWIW, nobody is going to "come down the cable modem" unless you ask
    them to -- by installing some type of malware that permits that kind
    of access, or by forwarding the ports on the router in a bizarre and
    dangerous fashion. Your computers IP addresses are NATted and nobody
    on the other side of the router knows what they are.

    If you really want to be careful, disable File and Printer Sharing on
    the TCP/IP protocol. Install NetBEUI, and enable FPS on that. It's a
    non-routable protocol so it's perfectly safe. And unless you have
    need of IPX/SPX, get rid of it.

    Cheers,
    dan
     
    Dan Shea, Feb 20, 2004
    #2
    1. Advertisements

  3. cromi

    Mike245 Guest

    Your post is unclear. Do you mean the firewall isnt warning you or the OS?

    If you have the same username/password on both computers then the OS
    will not ask you for it.

    If you have the firewall set to Trust Zones for non-routable addresses
    then you will not get alerts - this is normal behavior.

    You can port scan yourself from the tools at dslreports.com. If you can
    still see ports 135-139 and 445 you are not protected properly.
     
    Mike245, Feb 21, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.