rundll32.exe is not a valid win32 application

Discussion in 'Computer Support' started by Abe Bill, Aug 27, 2004.

  1. Abe Bill

    Abe Bill Guest

    After destroying legions of vermin in an infested XP machine, (owned by a
    brite teen), I'm trying to restore functionality without going with a
    format and install. Sometimes determination hurts. ANY cONTROL pANEL
    SELECTION POPS UP THE ERROR MESSAGE "rundll32.exe is not a valid win32
    application". Microsoft support has NO info on this. I've tried expanding
    rundll32.exE from the recovery cd using this command: "expand \i386
    \rundll32.ex_ %Systemroot%\rundll32.exe". No successs...yipes...help
     
    Abe Bill, Aug 27, 2004
    #1
    1. Advertisements

  2. Abe Bill

    °Mike° Guest

    You say that the machine was (maybe still is) infested
    with "vermin", yet you don't say what, or how you
    went about removing such "vermin" -- there may be
    damaged files all over the hard drive. Have you tried
    the system file checker?

    Start --> Run --> sfc /scannow
     
    °Mike°, Aug 27, 2004
    #2
    1. Advertisements

  3. Abe Bill

    Abe Bill Guest

    Hello °Mike°, thanks for your interest. I disinfected occurances of 378
    worms, trojans, browser hijackers, dialers and viriii, etc., along with
    1250 infeected files. Where does one start the list? I used F-Prot in
    DOS before I was able to get XP to load. I then installed Avast and
    Spybot and both ran on a restart. I have not deleted Restore Points.
    Will do that next time I get in.

    I had not considered System File Check...thanks for mentioning it. If
    memory serves me...SFC is a find a file...prompt tp replace...find next
    file prompt tp replace...very tedious. Never ran it in XP, maybe I'm
    mistaken. If not, know of a way to batch it ?
     
    Abe Bill, Aug 28, 2004
    #3
  4. Abe Bill

    °Mike° Guest

    No, SFC will replace system files automatically. You
    will probably be prompted to reboot, to allow SFC to
    replace files 'in use'.


    <snip>
     
    °Mike°, Aug 28, 2004
    #4
  5. Abe Bill

    markyoung

    Joined:
    Aug 31, 2013
    Messages:
    1
    Likes Received:
    0
    Another possiblity is that you have a 0-length rundll32.exe in your documents. This is what I found.

    C:\>dir "\Documents and Settings\mark\rundll32.exe"
    Volume in drive C is _XP
    Volume Serial Number is E0E3-17FF
    Directory of C:\Documents and Settings\mark
    05/18/2013 10:11 AM 0 rundll32.exe
    1 File(s) 0 bytes
    0 Dir(s) 6,979,198,976 bytes free

    Here is the fix:

    C:\>del "\Documents and Settings\mark\rundll32.exe"

    C:\>dir \rundll32.exe /s/b <-- find all rundll32.exe
    C:\Documents and Settings\Mark\rundll32.exe <-- this one is not supposed to be there
    C:\i386\rundll32.exe
    C:\WINDOWS\$NtServicePackUninstall$\rundll32.exe
    C:\WINDOWS\ServicePackFiles\i386\rundll32.exe
    C:\WINDOWS\system32\rundll32.exe
     
    markyoung, Aug 31, 2013
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.