RTP packets not received at PC side

Discussion in 'Cisco' started by Guan Yang, Mar 6, 2004.

  1. Guan Yang

    Guan Yang Guest

    Hi, I posted a few days ago about a problem I'm having with my Cisco
    2611, NM-2V and VIC-2BRI-S/T-TE. I'm trying to call the Cisco with my
    mobile phone and to call to the mobile phone with a softphone. The
    softphone is SJPhone running on a Windows laptop, although I've tried
    other softphones.

    The packets are moving fine from laptop to 2611. When I speak into the
    laptop's microphone I can hear the sound excellently on my mobile. I can
    also see these packets in Ethereal.

    The 2611 also claims to be transmitting RTP packets. However I can't see
    these packets in Ethereal and they don't appear to be received by the
    softphone -- when I speak into the mobile phone's microphone I don't
    hear anything on the laptop.

    Here's an example of the debug voice rtp messages:

    *Mar 3 03:55:22.269: RTP(2592): fs rx d=192.168.1.101(16384), pt=8,
    ts=24E0, s7
    *Mar 3 03:55:22.281: RTP(8426): fs tx d=192.168.1.101(16384), pt=8,
    ts=293DC956
    *Mar 3 03:55:22.301: RTP(8427): fs tx d=192.168.1.101(16384), pt=8,
    ts=293DC9F6
    *Mar 3 03:55:22.321: RTP(8428): fs tx d=192.168.1.101(16384), pt=8,
    ts=293DCA96

    In fact, the *only* packets sent from the 2611 are these (transcription
    from Ethereal screen):

    SIP/SDP INVITE
    SIP ACK
    RTCP Sender Report
    RTCP Sender Report
    SIP 200 OK
    RTCP Receiver Report
    RTCP Receiver Report
    ICMP Destination Unreachable

    (over a 10-second call)

    That last packet is a UDP Destination Unreachable error. Source port
    17923, destination port 16387.

    I've pasted in my entire config (the only lines that are removed are the
    ones containing passwords). I'm positive that there's no kind of
    firewall running on the Windows laptop. Could there be some kind of
    problem on the 2611 that causes it not to send the packets?

    Thanks,
    Guan



    Current configuration : 2203 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    no service dhcp
    !
    hostname jefferson
    !
    boot-start-marker
    boot-end-marker
    !
    ! enable secret
    !
    clock timezone CET 1
    clock summer-time CEST recurring
    no aaa new-model
    ip subnet-zero
    no ip routing
    no ip cef
    !
    !
    ip domain name unicast.org
    ip name-server 192.168.1.103
    ip name-server 212.54.64.170
    ip name-server 212.54.64.171
    !
    isdn switch-type basic-net3
    !
    !
    !
    voice class codec 1
    codec preference 1 g711alaw
    codec preference 2 g729br8
    codec preference 3 g729r8
    codec preference 4 g723r63
    codec preference 5 g723r53
    codec preference 6 g711ulaw
    !
    voice class codec 2
    codec preference 1 gsmfr
    codec preference 2 gsmefr
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    no ip address
    !
    interface Ethernet0/0
    ip address 192.168.1.102 255.255.255.0
    ip access-group 1 in
    ip access-group 1 out
    no ip route-cache
    no ip mroute-cache
    full-duplex
    no cdp enable
    !
    interface BRI0/0
    no ip address
    no ip route-cache
    no ip mroute-cache
    shutdown
    isdn switch-type basic-net3
    no cdp enable
    !
    interface Ethernet0/1
    ip address 192.168.1.102 255.255.255.0
    no ip route-cache
    no ip mroute-cache
    shutdown
    full-duplex
    no cdp enable
    !
    interface BRI1/0
    no ip address
    no ip route-cache
    isdn switch-type basic-net3
    isdn incoming-voice voice
    isdn answer1 32580668
    isdn calling-number 32848286
    !
    interface BRI1/1
    no ip address
    no ip route-cache
    shutdown
    isdn switch-type basic-net3
    !
    ip http server
    ip classless
    !
    !
    access-list 1 permit any
    !
    !
    voice-port 1/0/0
    compand-type a-law
    cptone DK
    !
    voice-port 1/0/1
    compand-type a-law
    cptone DK
    !
    !
    !
    dial-peer voice 2 pots
    application session
    incoming called-number 32580668
    destination-pattern T
    direct-inward-dial
    port 1/0/0
    !
    dial-peer voice 1 voip
    application session
    destination-pattern 32580668
    voice-class codec 1
    session protocol sipv2
    session target sip-server
    session transport udp
    no vad
    !
    sip-ua
    sip-server ipv4:192.168.1.101
    !
    !
    line con 0
    exec-timeout 0 0
    line aux 0
    line vty 0 4
    ! password
    login
    !
    !
    !
    end
     
    Guan Yang, Mar 6, 2004
    #1
    1. Advertisements

  2. Guan Yang

    Rik Bain Guest

    Can you post a text dump of the ICMP packet(print packet in ethereal)?
    Is there any NAT between the GW and the SoftPhone?
    Does the PC running the SoftPhone running any type of firewall
    application?
    What is the ip address of the PC?

    Rik Bain

    Rik Bain
     
    Rik Bain, Mar 6, 2004
    #2
    1. Advertisements

  3. Guan Yang

    Guan Yang Guest

    There's no firewall or NAT and the IP address of the PC is 192.168.1.101,
    but I fixed the problem thanks to someone who emailed me. The trick was to
    add:

    ip routing
    !
    interface ethernet0/0
    ip route-cache

    to the config.

    Guan
     
    Guan Yang, Mar 7, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.