router wont prompt enable

Discussion in 'Cisco' started by jcharth, Aug 15, 2005.

  1. jcharth

    jcharth Guest

    Hello I just logged in to a remote router. i typed enable and it got me
    in enable mode without password. then i did config t and type password
    enable myenablepassword and write mem. i loged in again to the router
    but it did not prompt for enable password, does anyon know what could
    be wrong? thanks
     
    jcharth, Aug 15, 2005
    #1
    1. Advertisements

  2. jcharth

    Ivan Guest

    Hm.. if your line "password enable myenablepassword" is not a tipfeller,
    then you used wrong syntax. Real syntax is "enable password <pass>".

    If you actually used that, you should see if you can find that line in
    running config and if you can see any "enable secret" lines which have
    higher priority than "enable password".

    HTH,
     
    Ivan, Aug 15, 2005
    #2
    1. Advertisements

  3. jcharth

    jcharth Guest

    Yes i did enable secret mysecret and enable password mypassword and the
    router does not prompt for a password. it goes in enable mode as soon
    as i type enable. any ideas?
     
    jcharth, Aug 15, 2005
    #3
  4. jcharth

    Ivan Guest

    Have you checked for bugs in your specific IOS? This sounds like one...
     
    Ivan, Aug 15, 2005
    #4
  5. jcharth

    dt1649651 Guest

    Do you login with a username who already has priviledge 15 ? I think if
    it is the case, then 'enable' won't ask you a password any more.

    DT
     
    dt1649651, Aug 15, 2005
    #5
  6. jcharth

    jcharth Guest

    line vty 0 4
    privilege level 15
    password 7 XXXXXXXXXXXXXXXXXX
    transport input telnet
    !
    no scheduler allocate
    !
    end
    May be this explains something? but i still can figure out way. I was
    reading about auto enable. I believe my user privilage is 7. Looks
    normal. Thanks
     
    jcharth, Aug 16, 2005
    #6
  7. jcharth

    dt1649651 Guest

    For the above config, I believe anybody who can telnet to your router
    will have the privilege 15, which will give you the higest permission.
    So if you can login, you do not have to submit the enable password any
    more.

    You can delete that line "privilege level 15", and assign each user an
    appropriate privilege level. Then it will ask you for a password for
    the enable command.

    DT
     
    dt1649651, Aug 16, 2005
    #7
  8. jcharth

    jcharth Guest

    Thanks, i figure it out after googleing for a while.I was starting to
    think there was something wrong with the router.
     
    jcharth, Aug 17, 2005
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.