Reboot, reboot, reboot

Discussion in 'NZ Computing' started by Lawrence D'Oliveiro, Mar 6, 2009.

  1. Qt is a cross-platform GUI toolkit, used as the basis for KDE. From
    <http://arstechnica.com/open-source/...ocks-for-rapid-cross-platform-development.ars>:

    It is recommended that you close all other applications before starting
    Setup. This will make it possible to update relevant system files
    without having to reboot your computer.

    The Linux/Unix version doesn't require you to “close all other applicationsâ€
    or reboot while installing/upgrading it, so why does the Dimdows version?

    I blame Dimdows.
     
    Lawrence D'Oliveiro, Mar 6, 2009
    #1
    1. Advertisements

  2. Lawrence D'Oliveiro

    Your Name Guest

    The easy solution is not to use Microsloth's bug-ridden, flawed garbage. I
    avoid it like the plague unless I really, really, really have to use it
    (like now thanks to ihug's hopeless "service"!).
     
    Your Name, Mar 6, 2009
    #2
    1. Advertisements

  3. I'm an ihug customer, and I've never had to use Windows. What sort of issue
    is forcing you into it?
     
    Lawrence D'Oliveiro, Mar 6, 2009
    #3
  4. Unix/Linux systems go further than that: they allow you to delete files that
    are currently in use by a running program.

    This allows you, for example, to upgrade a currently-running server program
    with a new version. After all the time-consuming file-copying is over, you
    just stop the existing version, whereupon the old, obsoleted executable and
    libraries actually disappear. Then, when you start the service again, it
    immediately runs the new version of the files. Minimal downtime, and no
    system restart.
     
    Lawrence D'Oliveiro, Mar 6, 2009
    #4
  5. Standard practice I suppose. I never bother rebooting or closing
    programs when installing a new version of Qt and as far as I can
    remember, its never caused a problem.

    The close programs/reboot thing is just because Windows NT locks the
    file for any program that is currently executing. As the file is
    locked, NT wont allow it to be opened for write access and as such an
    installer is unable to overwrite or update it.

    UNIX doesnt seem to bother with such locking and doesnt care if
    running programs are overwritten.
     
    David Goodwin, Mar 6, 2009
    #5
  6. Lawrence D'Oliveiro

    Cima Guest

    Heh, my super-duper Kubuntu box (the one with the uber-neat go no higher than
    800x600 screen res -but that's another thread) told me I needed to reboot after
    installing some updates yesterday. WTF? SURELY NOT.
     
    Cima, Mar 6, 2009
    #6
  7. Yeah - I never have understood why the executable image is locked
    while it is running on Windows NT - UNIX just lets the file be
    overwritten and I suppose VMS just increments the version number.

    I imagine there is or was a good reason for Windows NT's behaviour
    though - its not like it was designed by clueless people who had never
    written a real operating system before.
     
    David Goodwin, Mar 6, 2009
    #7
  8. Not overwritten--replaced. The original file remains intact until it
    disappears.
    It was masterminded by Dave Cutler, who was also one of the brains behind
    VMS. But for some reason NT never carried over VMS's file version numbering.
    So the VMS approach of letting you create a new version of the file, while
    the existing running process continues to access the old version, was never
    available to them.
     
    Lawrence D'Oliveiro, Mar 6, 2009
    #8
  9. How many updates, and how many reboots?

    When I upgraded my Eee from Ubuntu Hardy (8.04) to Intrepid (8.10) a few
    months ago, it downloaded over 200MB of new packages, and required just one
    reboot.
     
    Lawrence D'Oliveiro, Mar 6, 2009
    #9
  10. Lawrence D'Oliveiro

    Your Name Guest

    There's never been any mention of it on ihug's / Vodafone's useless Network
    Status page, but ihug's servers will not authenticate Mac OS 9 dial-up
    customers, but the problem only affects some dial-up numbers. This means I
    can't even login via the national number, Auckland local number or Hamilton
    local number, but I can login if I want to pay for a toll call to use the
    Whangarei local number. It is a problem that has occurred about four times
    over the last couple of years and has been fixed before, but this time they
    simply refuse to fix it (the new Vodafone owners are simply too lazy or too
    stupid to fix it). I was told I either have to use Whangarei's number or
    upgrade my computer, and frankly that's extremely poor service. This means
    the only real way I can use the Internet is via this old Windoze 2000
    computer ... at least until I ditch hopeless Vodafone.
     
    Your Name, Mar 7, 2009
    #10
  11. Open Transport PPP has an option to log the authentication attempt, if II
    recall rightly. You can also manually authenticate through its terminal
    window. Have you tried using these functions to narrow down the problem?
     
    Lawrence D'Oliveiro, Mar 7, 2009
    #11
  12. Lawrence D'Oliveiro

    Your Name Guest

    My Mac sends all the correct data, either automatically or when I do it
    maually through the console / terminal window, but it always refuses to
    authenticate. Everything works fine, then one day it suddenly doesn't
    (roughly every six months). In the past ihug have fixed the problem at their
    end with no changes being made to my computer (once I have finally managed
    to convince the "help"desk that there is indeed a problem and they get their
    "top man" onto it!). It only affects some of ihug's dial-up numbers and when
    tested my Mac will happily log into an borrowed Xtra and Orcon accounts with
    no problems.

    The problem is 100% guaranteed to be at ihug's end (one of MANY problems
    they continually have with their servers), and after the usual hassle of
    getting someone to actually look into it, I did get a call from a technician
    who said it would be fixed "by Friday", only to be told when I phoned up the
    following week with it still not working that they weren't going to fix it
    all.
     
    Your Name, Mar 7, 2009
    #12
  13. Have you tried using the options to figure out why?
     
    Lawrence D'Oliveiro, Mar 7, 2009
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.