Random Network drop out issue

Discussion in 'Wireless Networking' started by BigAl.NZ, Jan 2, 2007.

  1. BigAl.NZ

    BigAl.NZ Guest

    Hi Guys,

    I will attempt to explain this problem as best I can. I recently got
    high speed access to the net via a wireless dish. The dish has some
    client equipment in it and is connected to my PC via wired Ethernet.

    My PC has been assigned a static IP for the network, and because we are
    behind a router its not a real world IP.

    The problem is that rnadomly I loose my connection to the internet. I
    still show a connection on the LAN indictaors on the status bar.

    Now I find that if I click Repair on the context menu for that
    connection everything is fine again.

    This can happen a few times a day. The service provider swears its
    nothing at his end, and the fact that I have to repair to fix it kinda
    supports this theory. I dont know much about the gear but that its
    Trango. I am on XP SP2 with the latest IE7.

    Anyone able to shed any light pease?

    Thanks

    -AL
     
    BigAl.NZ, Jan 2, 2007
    #1
    1. Advertisements

  2. BigAl.NZ

    Elmo Guest

    Open the Device Manager, locate the Ethernet card, open Properties and
    turn off the power option to "Allow the computer to turn off this device
    to save power".
     
    Elmo, Jan 2, 2007
    #2
    1. Advertisements

  3. BigAl.NZ

    Malke Guest

    The first thing to try is to disable power management on your computer's
    network adapter. Go to Control Panel>System>Hardware>Device Manager. Expand
    the network devices category and find your ethernet adapter. Double-click
    it to get its Properties. Click on the Power Management tab and uncheck the
    box that says "allow Windows to turn off this device when not in use". See
    if that helps and if it does not, then please post back with a bit more
    detail about your particular computer's hardware and its virus/malware
    status.

    Malke
     
    Malke, Jan 2, 2007
    #3
  4. hath wroth:
    Does it also have a statically defined gateway IP?

    Are the DNS servers listed or are they set to obtain their addresses
    from the ISP router? (This is important. Check the settings).
    The connection you're seeing in the system tray is the ethernet
    connection, not the wireless connection. You could block the wireless
    signal completely and it will still show that you're plugged into the
    Trango wireless bridge.
    Impossible. All the you're doing is repairing the ethernet
    connection. Others have suggested checking the power save setting. My
    guess(tm) is that you won't find a "wireless" connection in the:
    Control Panel -> Network
    window and that the ethernet device on your unspecified model computer
    does not have a power save feature.

    However, the question remains, why does it work for you. My guess is
    that you can get the exact same effect by simply unplugging the
    ethernet cable, waiting a few seconds, and plugging it back in. Does
    this also fix the problem?
    - How many times is "a few"? Numbers please.

    - Is there any pattern to the outages? For example, does it only
    happen during normal eating times, when microwave ovens tend to be
    operating? Is it different on weekends?

    - Are you using the computer when it dies, or have you left it idle
    for a long while?

    - You may have lost the internet, but have you checked if you've lost
    your ISP's gateway? Determine the gateway IP address by running:
    start -> run -> cmd <enter>
    ipconfig
    Then try pinging the gateway when it's working, and when it dies:
    ping ip_address_of_gateway
    If it does NOT work when it goes dead, you have lost your wireless
    connection to the WISP.

    - Does it *REQUIRE* that the connection be repaired, or does it fix
    itself if you wait long enough? How long? Use:
    start -> run -> cmd <enter>
    ping -t ip_address_of_gateway
    and watch the error messages. When normal results return, it's back
    to working. If the downtime is approximately that of cooking a
    microwave dinner, I think we have the culprit. There also ping tools
    which will help run this test continuously:
    No, it doesn't. For example, if the WISP's DNS servers were screwed
    up and not responding, it would appear that you can't surf the
    internet, while all that's happening is that you can't resolve the
    domain names into IP addresses. Try obtaining the IP address of a
    popular web site and using that instead of the name to see what
    happens when it does down. To get the IP address, run something like:
    ping www.yahoo.com
    then try the resultant IP address in the form:
    http://66.94.234.13
    If your wireless ISP is using some kind of DNS load balancing scheme,
    or you have one of the three possible DNS servers typed in wrong, you
    might see some problems.

    It may also be something as simple as the time delay required to
    repair the connection if the outages are fairly short in duration.
    Trango has a support forum. I suggest you ask about signal strength
    and interference problems.
    <http://www.trangobroadband.com/forum/default.aspx>
    If the diagnostics returns that you have a marginal signal to your
    WISP, you may need to tinker with the antenna, or do some
    repositioning to avoid interference.
    If shedding light is anything like shedding fur on a dawg, I don't
    think you will want it.

    My guess(tm) is that if you're absolutely sure your XP setup is
    correct, that your signal is good and strong, and that you have line
    of sight to your WISP, I would then look into interference problems. A
    "few" times per day sounds like a microwave oven. It does not need to
    be yours as anything along the line of sight (and beyond) to the ISP
    will cause problems. See the FAQ at:
    <http://wireless.wikia.com/wiki/Wi-Fi#Interference>
    for a laundry list of possible culprits.
     
    Jeff Liebermann, Jan 2, 2007
    #4
  5. BigAl.NZ

    BigAl.NZ Guest

    Gee - Thanks for all the great suggestions so far!!

    I have turned off power management for the adapter as instructed, but
    as i can not re[licate the problem at will, I will just have to wait
    and see.
    They are listed.
    I am running an Asus A8N32-SLI Deluxe motherboard with a AMD Athlon64
    2.2Ghz 3500+ chip. The twin onboard (motherboard) ethernet adapters are
    Marvel Yukon 88E8053 Gigabit Ethernet Controllers.

    Under power management for these adapters I have unchecked the setting
    "Allow the computer to turn off this device to save power"
    Will try that next time it does it.
    It varies, but the average would be twice.
    Thats a interesting point - because it has been happening in the
    mornings, but also happens overnight (I am not on my computer but my
    MSN is logged out suggesting a loss of connectivity)
    It has happened when I am using it, and I am pretty sure it has also
    happened when i am not.
    Good suggestion.
    Another good suggestion - will try that too.
    Someone else mentioned Malware/Virus? I thought about that too - I have
    had my HiJackThis log checked over at CastleCops- and I am clean. Also
    running Ewido and Kaspersky - all clean.

    Cheers

    -Al
     
    BigAl.NZ, Jan 2, 2007
    #5
  6. BigAl.NZ

    BigAl.NZ Guest

    Just after I posted my last message the connection dropped. So I can
    now offer the following info:

    When the connection first dropped I did a ping to the gateway within
    about 1 min. No ping.

    Then about 30 seconds of the first set of pings I pinged the gateway
    again and got a return, but no connection to the internet.

    Unplugging and plugging the ethernet cable back in had the same result
    as repair - it allowed me to connect to the internet again.

    Cheers

    -Al
     
    BigAl.NZ, Jan 2, 2007
    #6
  7. The gateway connection recovered but not the internet? Is this
    wireless contrivance part of a mesh network or does your WISP use a
    store and forward system for their access points? Having a radio
    disappear from a mesh network will cause the network to re-route
    packets around the node. That could explain why it doesn't recover
    immediately.

    If I really stretch my imagination, it's possible that the gateway
    might be alive, but no routing if there were some manner of exotic
    mesh routing protocol operating on this system. However, that's
    usually not the case. Does this wireless system include some manner
    of "monitor" program that is running on your computer that sends "keep
    alive" packets to the WISP?

    My overactive imagination can also contrive a situation where the
    default route changes in response to RIP2 updates from the ISP. That
    would give you a proper ping return from the gateway, but would route
    all your packets to nowhere in particular. Run:
    start -> run -> cmd <enter>
    route print
    before and after the connection drops and note the default route
    listed at the bottom.
    Ok, that's a good clue. Unplugging the ethernet connection usually
    causes the ethernet connection to reset and to obtain a new DHCP
    assigned IP address when plugged back in. However, you state that you
    have static IP address, gateway, and DNS servers, so that's not what's
    happening. Are you sure that they're static?

    It's possible that the Trango radio is part of the problem. If it has
    an IP address, try to ping it. If your lucky, it's one IP address
    above or below your assigned IP address. However, it may not be
    easily accessible from your Windoze box. Try running:
    arp -a
    and see if you can identify the box. Trango starts with:
    00-01-DE-xx-xx-xx

    My crystal ball still says it's interference. However, the question
    is why doesn't it recover by itself. It should recover, but without
    detailed knowledge of the wireless topology, I can only speculate.
     
    Jeff Liebermann, Jan 2, 2007
    #7
  8. BigAl.NZ

    Drake Guest

    Hopefully you are using high quality CAT6 cable?
     
    Drake, Jan 3, 2007
    #8
  9. BigAl.NZ

    Bill Kearney Guest

    I will attempt to explain this problem as best I can. I recently got
    Explain what equipment. Make, model and exact ways it's all wired together.
    What static IP? Presumably it's also got static DNS addresses too?
    Spell it 'lose'.
    Repair? With a static IP?

    When it's working, try opening a cmd prompt and typing "ipconfig /all" and
    post the results here. Then, when it dies, use the same command and see if
    there's *any* differences.

    When using the ping command, does it always return a successful ping to the
    gateway? Even before doing a repair or disconnect/reconnect of the ethernet
    cable from the PC to the router?

    When it's working, what lights are lit on the router *and* on the back of
    the PC? Does your network card in the PC have lights for connection, duplex
    and speed (often color-coded)?

    I'm left wondering if the wireless device isn't doing something to detect
    that the PC is connected and altering the wireless link. As in, it drops
    the internet link based on it thinking the PC isn't there. If that's the
    case then either your PC is "doing something" that confuses the router or
    the router itself is misconfigured or just plain defective.

    -Bill Kearney
     
    Bill Kearney, Jan 3, 2007
    #9
  10. BigAl.NZ

    Bill Kearney Guest

    For the connection from a PC to a router like this that's a useless
    suggestion. Plain old CAT5 would work fine. Presuming it's a good cable of
    course.
     
    Bill Kearney, Jan 3, 2007
    #10
  11. BigAl.NZ

    BigAl.NZ Guest

    Ok guys, an update,

    When I do the repair I have discovered what is fixing the problem, it
    is the clearing of the arp cache.

    I know this because I did a manual clear of the arp cache with "arp -d
    *" and that fixed it.

    I dont know much about arp but hopefully someone here can make some
    conclusions about this?
    Its a Trango Fox 5310 Subscriber Unit. The ethernet cable goes from the
    back of the PC into a Power over Ethernet box, out of there and up to
    the roof where the Trango is. No routers at my end.
    Yep - take a look at a screenshot here:
    http://img54.imageshack.us/my.php?image=ss1nr5.jpg

    Ok, here it is when its working:
    --------------------------------------------------------------------------------------------------------------------------------------------
    C:\Documents and Settings\Al>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : al-60c9aaef8b2d
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Marvell Yukon 88E8053 PCI-E
    Gigabit
    Ethernet Controller
    Physical Address. . . . . . . . . : 00-17-31-38-4E-0D
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.252.1
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.252.254
    DNS Servers . . . . . . . . . . . : 192.168.252.254
    210.55.12.1

    Ethernet adapter Bluetooth Network Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Description . . . . . . . . . . . : Bluetooth Device (Personal
    Area Netw
    ork)
    Physical Address. . . . . . . . . : 00-80-98-44-0B-1D
    ------------------------------------------------------------------------------------------------------------------------------------------------





    It always sends a successful ping to the gateway when working
    (occasionaly 1% loss)

    I did try to ping the gateway when the connection when down, and on my
    second attempt I got a return, initally I thought it was just the
    connection between me the gateway being fixed, but now I think the
    whole connection was repaired. Sometimes it fixes itself after a few
    minutes - sometimes it takes longer. Have not quite worked this out
    exactely yet.
    No router involved here - will check the PC.

    Thanks Bill - will post the ipconfig /all when its not working....

    -Al
     
    BigAl.NZ, Jan 3, 2007
    #11
  12. BigAl.NZ

    BigAl.NZ Guest

    PS:

    here is my arp -a result before a dropout:

    -------------------------------------------------------------------------------------------------------------------------------------------------
    C:\Documents and Settings\Al>arp -a

    Interface: 192.168.252.1 --- 0x2
    Internet Address Physical Address Type
    192.168.252.254 00-02-a5-02-44-bd dynamic
     
    BigAl.NZ, Jan 3, 2007
    #12
  13. I agree, the cable quality doesn't matter much for a short cable,
    but I have had some bad cables. Mostly, I believe, the contact
    between the cable and the connector, even with commercial cables.

    -- glen
     
    glen herrmannsfeldt, Jan 3, 2007
    #13
  14. In comp.dcom.lans.ethernet wrote:
    In that case, the one answer is another host trying to come
    online with the same IP address. The router will then put that
    host in its arp table, disconnecting you. Clearing the arp cache
    will usually cause your host to arp, adding it to the router arp
    table.

    One I did see once on a machine with both IP and Appletalk
    (ethertalk) was arp replies in both ethernet and SNAP format,
    causing the router to switch to SNAP format IP that the host
    would then ignore. A ping to any host not in the arp table
    would cause a new arp request, and the router would then stop
    sending SNAP encapsulated data. That is not likely to be
    your problem, though.

    -- glen
     
    glen herrmannsfeldt, Jan 3, 2007
    #14
  15. BigAl.NZ

    BigAl.NZ Guest

    Ok,

    Here ya go, I just lost the connection, and after I lost the
    connection, but before I repaired it this is what I got from IPCONFIG
    /ALL and ARP -a

    C:\Documents and Settings\Al>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : al-60c9aaef8b2d
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Marvell Yukon 88E8053 PCI-E
    Gigabit
    Ethernet Controller
    Physical Address. . . . . . . . . : 00-17-31-38-4E-0D
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.252.1
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.252.254
    DNS Servers . . . . . . . . . . . : 192.168.252.254
    210.55.12.1

    Ethernet adapter Bluetooth Network Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Description . . . . . . . . . . . : Bluetooth Device (Personal
    Area Netw
    ork)
    Physical Address. . . . . . . . . : 00-80-98-44-0B-1D

    C:\Documents and Settings\Al>arp -a

    Interface: 192.168.252.1 --- 0x2
    Internet Address Physical Address Type
    192.168.252.254 00-02-a5-02-44-bd dynamic

    C:\Documents and Settings\Al>arp -d *

    HTH?

    -Al
     
    BigAl.NZ, Jan 3, 2007
    #15
  16. BigAl.NZ

    BigAl.NZ Guest

    One more thing I had a packet sniffer, Ethereal running when it went
    down and came back up - not sure if the logs from this will help?

    -Al
     
    BigAl.NZ, Jan 3, 2007
    #16
  17. It might.

    Better would be the results of arp -a on the router machine
    before and after. Otherwise, if there are any arp packets just
    before it dies in the ethereal output, post them.

    -- glen
     
    glen herrmannsfeldt, Jan 3, 2007
    #17
  18. Agreed. CAT6 is overkill. What limits high speeds is crosstalk (NEXT
    and FEXT). For short lengths, such crosstalk is negligible and almost
    any type of wire or cable will work.

    All of the bad ethernet cables in my palatial office and trucker were
    made by me. There should be a clue here, but I'll pretend to ignore
    it. Most are visibly defective with:
    - creative wiring
    - split pairs
    - bad crimp
    - wrong type of RJ-45 plug
    - mangled plastic seperators between pins
    - partial crimp
    being the main culprits. In general, commercial cables are good
    enough.
     
    Jeff Liebermann, Jan 3, 2007
    #18
  19. Weird. You didn't answer my question as to whether your wireless ISP
    is part of a mesh network. If so, it would make sense that the
    destination gateway might change depending on the topology of the
    moment. I'll keep things simple and avoid this possibility.

    The obvious question is whether the MAC address of the gateway
    (192.168.252.254) changes before it disconnects, and after it
    recovers. Try it before and after and see if there's a change. If it
    does change, well then you'll need to do something to forcibly expire
    the arp cache and ping the gateway, which should renew the entry.

    However, if it doesn't change, then try this experiment. Run:
    arp -s 192.168.252.254 xx-xx-xx-xx-xx-xx
    to permanently set the MAC address of the gateway. If this fixes it,
    my guess(tm) is that either your ethernet driver or IP stack on your
    computah is having a bad day. It's suppose to send an ARP request to
    the gateway immediately after it detects a connection. It's not.

    I just tried to simulate your problem. I have an ancient DWL-900AP+
    setup in client mode connected to the neighbors WRT54G. Encryption is
    off. When I disconnect the antenna to simulate a connection loss, it
    takes about 2 minutes for XP to recognize that the connection is gone.
    Various services (AIM, Skype, PPTP VPN) fail prior to XP announcing a
    lost connection.

    When I put the antenna back and try to ping the neighbors router, it
    takes about 20 seconds to re-establish the connection. Yours
    apparently takes either much longer or never succeeds. I just did it
    again, but this time, I had a continuously running FPING session
    running. The reconnection was about 5 seconds. This is the way it
    should work.
    Nice:
    <http://www.trangobroadband.com/products/fox5310_international.shtml>
    5.3GHz. No mesh network. No microwave oven interference. Do you
    have line of sight? How far away is the central access point.
    Perfect. No problems with the IP setup. I can't seem to get the
    secondary DNS server to respond to my DNS queries, but it might be
    firewalled to accept queries only from the WISP's network.
    nslookup
    Default Server: dns1.snfcca.sbcglobal.net
    Address: 206.13.28.12
    Default Server: [201.55.12.1]
    Address: 201.55.12.1
    Server: [201.55.12.1]
    Address: 201.55.12.1

    DNS request timed out.
    timeout was 2 seconds.
    DNS request timed out.
    timeout was 2 seconds.
    *** Request to [201.55.12.1] timed-out

    This is probably unrelated to the current problem, but you should
    check if your secondary DNS server is functional from your end.
    Are the ping times (latency in msec) constant? In other words, do
    they always show the same number of msec, or do they vary all over the
    place? If they vary, it's a sign of interference or possibly wireless
    congestion. The extra delays are signs of packet retransmissions.
    Unfortunately, I can't tell where the gateway IP is located in your
    WISP's network, so it's difficult to isolate just your traffic
    results.
    It requires traffic to fix itself. If the arp cache is being flushed,
    it won't repopulate the ARP cache untill it sends something to the
    gateway. What I find interesting is that the gateway appears to be
    functional, but nothing beyond it. Try using traceroute (Windoze
    tracert) to something else is going down along the path. It might be
    the backhaul between the central access point and where it hits a
    wired connection.
     
    Jeff Liebermann, Jan 3, 2007
    #19
  20. 00-02-A5-xx-xx-xx is owned by Compaq Computahs:
    <http://www.coffer.com/mac_find/?string=00:02:a5>
    Well, that makes sense as the gateway is also a DNS server.

    From your previous posting, the arp -a results are identical before
    and after the disconnect. If you preload the ARP cache with:

    arp -s 192.168.252.254 00-02-a5-02-44-bd

    methinks I can eliminate the arp cache as a probable culprit and move
    onward to whatever is preventing the connection from recovering
    gracefully. As far as I can tell, your system is operating normally
    except in one respect. It does not recover quickly or gracefully from
    a disconnect. I'm still not sure why, but in every other respect, it
    functions exactly like my quick test previously mentioned.

    Also, I think you would do better to determine (or guess) why the
    system is showing disconnects in the first place. My guess(tm) is
    some obstructions in the path (trees, cars, excessive path) or
    interference from other users of this WISP system.
     
    Jeff Liebermann, Jan 3, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.