RAID Hard disk, Promise FastTrak 378, K8V SE Asus-MoBo.

Discussion in 'Windows 64bit' started by Dennis Pack, Sep 27, 2006.

  1. Dennis Pack

    Dennis Pack Guest

    The latest driver for the Fasttrack 378 is 1.00.039. After
    downloading the driver from Asus you have to unzip the download. After the
    download is unzipped there will be 1 folder and 3 files in the download.
    These have to be copied to a floppy for installation.
    Dennis Pack, Sep 27, 2006
    1. Advertisements

  2. Dennis Pack

    hectorg Guest

    My MoBo is ASUS K8V SE, has a promise RAID controller, & FASTTRAK 378.
    All works fine with Xp 32, now I want Xp 64 bit.:wink:
    Latest 64 bit Promise RAID driver revision ASUS web-support download is, but can't get it to work.
    - During install, I hit F6, and it loads the driver, reboots,
    finished install, then, nada. Continuous reboots.
    - I tried small IDE HDD, then updating driver afterwards within Xp64,
    does not work either. Does not load driver, I'm without RAID.
    - I tried BIOS switching from RAID to IDE and back.Promise website mentions no support for MB with embedded controller & to
    go to mfg of Mobo, ASUS.

    Any suggestions?:roll:
    Do we have working RAID HDD drivers for Promise 378 and VISTA64bit?
    plz, help...:?
    hectorg, Sep 28, 2006
    1. Advertisements

  3. If you are having RAID and IDE both, make sure that your RAID is set as the
    first drive - and note that your BIOS may have the RAID listed in the IDE
    section too, make it the first drive and then set the boot-order.

    If this does not work, try disabling everything that you don't need for the
    machine to boot. When the machine is running then it should be alright to
    enable the stuff that you are going to need, leave everything else disbaled.

    And to expand on Denis's excellent point on unzipping the file, if that's
    your problem - make sure that you copy the part of the directory structure
    such that the file TXTSETUP.OEM lands in the root of the floppy!

    Tony. . .

    mentions no support for MB with embedded controller & to
    Tony Sperling, Sep 28, 2006
  4. Dennis Pack

    hectorg Guest

    I posted this version of the driver, but not on how to use it, and
    _*I_did_all_of_that,_if_you_read_carefully*_. That is the exact version
    I am using from the Asus website, plus I tried other BIOS versions, and
    beta's, just in case..;)

    I'll explain again:
    The install with F6 gets the driver, formats, copies, install continues
    fine afterwards, reboots and continues install, asks once on the logo
    testing to continue, then finishes install. After this reboot, it never
    comes back, and continues rebooting...:roll:

    I do truly appreciate your effort and time spent for posting a reply,
    and encourage you to continue. :cool:
    hectorg, Sep 28, 2006
  5. Dennis Pack

    hectorg Guest

    I replied to each of your paragraphs..

    hectorg, Sep 28, 2006
  6. Dennis Pack

    Dennis Pack Guest

    The Promise 378 driver was the only driver that
    Promise has released for x64. It covered the Fasttrack 378, S150TX series
    and TX4000 chipsets. During the x64 beta the original driver worked on the
    early versions but not the later versions and the updated driver became
    version After testing the driver from Asus I found that it won't
    install as you indicated. Go to, download the driver
    for the FastTrac S150 TX4. Unzip the download, ignore the bios file, open
    the "fts150tx_windrv_amd64_v1.00.1.39_with updated" file, copy
    contents to a floppy. This driver works on my SK8N mother board with the
    Promise 378 controller. The version on the Asus site is the early version
    without the updated .INF file. Sorry about the delay in posting the proper
    drivers but I'm not running raid on that system anymore and had to find the
    proper driver file.
    Dennis Pack, Sep 28, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.