QOS PROBLEM

Discussion in 'Cisco' started by nico, Jan 31, 2004.

  1. nico

    nico Guest

    Hello

    I have problems with a Cisco 3640 and QOS Service Policy

    Infra :

    LAN -> ROUTER -> SWITCH -> INTERNET

    I create ACL and put them in a policy map with a priority of 1Mb/s

    One client is in a class , second client is'nt in any class-map

    When i simulate a congestion - rate limit of internet on the SW
    The class of the 1st client (with prioriy of 1Mb) isn't reached
    and the default class isn't falling to give bandwidth for the 1st client..

    What can i do to give garanted bp to clients...

    Cisco has IOS 12.3.
    I enable IP CEF but no results after that.

    First client :

    class xxx
    priority 1000


    IF
    !
    interface FastEthernet3/0
    ip address xxx
    service-policy output yyy
    load-interval 60
    duplex auto
    speed 100
    !
    ip http server
    ip classless
    ip cef
    ip cef accounting non-recursive



    Thanks to help me

    Nico
     
    nico, Jan 31, 2004
    #1
    1. Advertisements

  2. nico

    nico Guest

    Anyone can help me ??
     
    nico, Feb 2, 2004
    #2
    1. Advertisements

  3. nico

    Ivan Ostres Guest

    It would be easier if you send the whole config..
     
    Ivan Ostres, Feb 3, 2004
    #3
  4. nico

    nico Guest

    what's config do you have need
    i have include class map config & iface config ..
     
    nico, Feb 3, 2004
    #4
  5. nico

    Ivan Ostres Guest

    Ok, please repost it, and explain exactly what do you want to do.
     
    Ivan Ostres, Feb 4, 2004
    #5
  6. nico

    Guest Guest

    I want to prioritize certain types of traffic
    and have garanteed bandwidth . I have a 10Mb link
    and if link is congestioned i want clients have
    his garanteed bandwidth. so here is config.

    policy-map servers
    class client
    priority 1000 (1mbits garanteed)

    IF
    interface FastEthernet3/0
    ip address xxx
    service-policy output servers
    duplex auto
    speed 100
    !
    ip http server
    ip classless
    ip cef
    ip cef accounting non-recursive

    acl are created and when i show policy map
    there is traffic on class default and traffic on client
    class but when the link is congested , client doesn't
    reach his priority by dropping bandwidth on default class.

    Nico
     
    Guest, Feb 4, 2004
    #6
  7. nico

    Ivan Ostres Guest

    seems you are missing:

    class-map match-all client
    match ... (something)

    You said that you have 10 Mb link but you have speed set to 100 Mb. I
    aslo thing that you need to specify bandwith with 'bandwidth' command
    (it makes sense with 'percent' command in policy-map) so you could put
    it anyway.

    One more thing... This will just reserve bandwidth in OUTGOING from
    interface, not incoming. How did you measure that it does not work?

    Can you provide us a 'sh policy-map int fa3/0' ?
     
    Ivan Ostres, Feb 4, 2004
    #7
  8. nico

    Guest Guest

    One more thing... This will just reserve bandwidth in OUTGOING from
    interface, not incoming. How did you measure that it does not work?

    I limit the link to 2Mb and class default has 1.5
    and client has 500k (not 1mb garanted).

    Class-map: client (match-any)
    30478215 packets, 30661485625 bytes
    1 minute offered rate 1438000 bps, drop rate 0 bps
    Match: access-group 110
    30478211 packets, 30661481553 bytes
    1 minute rate 1438000 bps
    Queueing
    Output Queue: Conversation 265
    Bandwidth 1000 (kbps) Max Threshold 64 (packets)
    (pkts matched/bytes matched) 2292/2185982
    (depth/total drops/no-buffer drops) 0/0/0

    Class-map: class-default (match-any)
    286422400 packets, 77094054526 bytes
    1 minute offered rate 2199000 bps, drop rate 0 bps
    Match: any
     
    Guest, Feb 4, 2004
    #8
  9. nico

    Ivan Ostres Guest

    This looks fine. Let's try something else. Try to specify bandwidth in
    your client class but without LLQ, just plain bandwidth. Also try to
    create class-default and add remaining bandwidth with 'remaining'
    keyword. Also, it would be good to add WRED to class-default.

    Which IOS do you use?
     
    Ivan Ostres, Feb 4, 2004
    #9
  10. nico

    Guest Guest

    This looks fine. Let's try something else. Try to specify bandwidth in
    your client class but without LLQ, just plain bandwidth.
    Also try to
    create class-default and add remaining bandwidth with 'remaining'
    keyword.
    Also, it would be good to add WRED to class-default.
    Which IOS do you use
     
    Guest, Feb 4, 2004
    #10
  11. nico

    nico Guest

    I enable wred. set bandw of IF to 2500 and do some stats + class default to
    bw remaining.


    Class-map: client (match-any)
    35740553 packets, 35805033296 bytes
    1 minute offered rate 1961000 bps, drop rate 0 bps
    Match: access-group 110
    35740550 packets, 35805029460 bytes
    1 minute rate 1961000 bps
    Queueing
    Strict Priority
    Output Queue: Conversation 264
    Bandwidth 1000 (kbps) Burst 25000 (Bytes)
    (pkts matched/bytes matched) 11/13706
    (total drops/bytes drops) 0/0


    class-map: class-default (match-any)
    307755610 packets, 83114905807 bytes
    1 minute offered rate 2180000 bps, drop rate 0 bps
    Match: any
    Queueing
    Output Queue: Conversation 265
    Bandwidth remaining 90 (%)
    (pkts matched/bytes matched) 513/107104
    (depth/total drops/no-buffer drops) 0/0/0
    exponential weight: 9
    mean queue depth: 0

    IF
    MTU 1500 bytes, BW 2500 Kbit, DLY 100 usec,
    reliability 255/255, txload 247/255, rxload 117/255
    Available Bandwidth 619 kilobits/sec
    1 minute input rate 1151000 bits/sec, 472 packets/sec
    1 minute output rate 4150000 bits/sec, 596 packets/sec

    Strange no ? bandwidth is set to 2500 and 1m output is 4Mb !!
     
    nico, Feb 4, 2004
    #11
  12. nico

    Ivan Ostres Guest

    No, it's not strange at all. 'bandwidth' command will not affect real
    bandwidth. It's just used to tell some routing protocols and some QoS
    mechanisms to find real or wanted bandwidth.

    Your output looks just fine. I hope it will work as it should.
     
    Ivan Ostres, Feb 5, 2004
    #12
  13. nico

    Guest Guest

    Yes but why the client exceed his 1Mb, if i i told
    the iface to have 2.5Mb of BW , why client exceeed
    his priority ..
     
    Guest, Feb 5, 2004
    #13
  14. nico

    Ivan Ostres Guest

    Because you have set the minimum bandwidth in the case of congestion. If
    you don't want for client to get more than 1Mb (congestion or not) you
    should use traffic shaping.

    If there is no congestion, the client will use all remaining bandwidth,
    not just specified amount.

    So, if you want to limit clients traffic.. word for you is traffic
    shaping and policing.
     
    Ivan Ostres, Feb 5, 2004
    #14
  15. nico

    Guest Guest

    no i don't want use shapping. but how can i simulate
    the congestion .?? if i limit the internet port to 2mb
    the routeur 'll have congestion ??
     
    Guest, Feb 5, 2004
    #15
  16. nico

    Ohad Dallal Guest

    There's a way you can force congestion - by using class-based WFQ and
    shaping.

    The configuration is as follows:

    policy-map MY_POLICY
    class servers
    bandwidth 1500 (reserve 1.5Mbps for servers)
    class telnet
    priority 10 (telnet traffic in rate of up to 10Kbps - put in
    low-latency queue)
    class class-default

    policy-map MASTER_LIMIT
    class class-default - take action on all traffic
    shape average 2000000 - limit BW to 2Mbps (out)
    service-policy MY_POLICY - manage congestion (2Mbps and above) by
    this policy

    Interface Ethernet0/0
    service-policy output MASTER_LIMIT


    in this situation, congestion will occur in 2Mbps rate on the
    interface, rather than "waiting" for 10Mbps rate.

    if only "servers" will talk, they can reach up to 2Mbps. if any other
    traffic will take place, it will take 500Kbps max (2 - 1.5), and
    "servers" will talk in at least\up to 1.5Mbps rate.

    even if line is fully congested, telnet sessions will still work fine
    under 10Kbps rate (which is far beyond what one session really needs)
    - beacuse they are promised to get minimal latency in this rate and
    below.

    if you wouldn't put the 'priority' command, telnets will suffer really
    high latency and sessions might fall.

    hope I could help.
    Ohad.
     
    Ohad Dallal, Feb 5, 2004
    #16
  17. nico

    Guest Guest

    I'll try this ....

    But it's sad that's not possible to specify rate
    on a SW after the router

    Router -> SW -> NET
    I can rate limit the port on SW..
    It's 'll be more easy to rate limit
    on each port on SW and when SW drop packets..
    the router can manage the congestion ..
    (for multi homed traffic)..

    If i have one link of 10m and a second link
    of 100M, what's the value i enter in the router :)
     
    Guest, Feb 6, 2004
    #17
  18. nico

    Ohad Dallal Guest

    well, it's not necessary to do anything on the switch level...
    assuming most of the traffic is TCP, the congenstion the router makes
    affects end-to-end - it delays\drops packets and the origin
    server\workstation window becomes smaller and the session "stables" on
    2Mbps end-to-end. but it's beeing managed more efficiantly by the
    router - packets are put into queues insted of just being droped.

    Ohad.
     
    Ohad Dallal, Feb 7, 2004
    #18
  19. nico

    nico Guest

    and in this cause, you think routeur gives priority ??
    and give 1mb to priority class & 1mb to all other classes ?
     
    nico, Feb 7, 2004
    #19
  20. nico

    nico Guest

    During Period of simulate congestion ..

    Sh queue

    Input queue: 0/75/15781/0 (size/max/drops/flushes); Total output drops:
    Queueing strategy: weighted fair
    Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations 0/2/256 (active/max active/max total)
    Reserved Conversations 1/1 (allocated/max allocated)
    Available Bandwidth 8444 kilobits/sec

    Normal ?:)
    I make a download on the client server (priority) and on a default server
    the speed of these are similar so.. It works or not :)
     
    nico, Feb 7, 2004
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.