Put Tcpdump on DD-Wrt Router

Discussion in 'Network Routers' started by Christopher Thiele, Jun 10, 2009.

  1. Hello everyone,

    I would like to install "tcpdump" (with libpcap) on my Buffalo WHR54 Router, which runs DD-WRT v24sp1 mini. I already found out, that I have to install the mini-firmware in order to access JFFS (which is not in the vpn-version) and have enough space on the device left.


    I tried several ways: Get the tcpdump-packet with wget, and also those two:
    1. ipkg -d root install tcpdump
    2. ipkg -force-depends -d root install tcpdump

    But the result always is:

    Downloading http://downloads.openwrt.org/whiterussian/packages/libpcap_0.9.4-1_mipsel.ipk ...
    Connecting to downloads.openwrt.org (195.56.146.238:80)
    libpcap_0.9.4-1_mips 100% |********************************************************************************************************************| 68534 00:00:00 ETA
    Done.
    tar: invalid tar magic
    tar: crc error
    tar: short read
    ipkg_install_file: ERROR unpacking control.tar.gz from /jffs/tmp/ipkg/libpcap_0.9.4-1_mipsel.ipk
    ipkg_get_install: ERROR: Failed to install /jffs/tmp/ipkg/libpcap_0.9.4-1_mipsel.ipk
    ipkg_get_install: I'll leave it there for you to try a manual installation


    I tried "ipkg update" which seems to work (no errors), but doesn't change anything :-((

    Could anybody help me, please?
    Thank you very much,
    Christopher
     
    Christopher Thiele, Jun 10, 2009
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.