problems with vp-2060 X-drive II

Discussion in 'Digital Photography' started by news-server.nc.rr.com, Sep 24, 2003.

  1. Put in my own hard disk.
    Formatted it with win98 as FAT32.
    Can access disk and read compact flash thru USB, but it won't copy data from
    memory cards to its disk (beeps once, then hangs) when not connected to
    computer.
    My search turns up nothing. Im absolutely sure its FAT32 (I'm a computer
    engineer).
    I even downloaded and installed their latest micocode (what a bitch, have to
    install it via win98).
    No luck.
    Trip coming up soon, and help greatly appreciated.
    Would be a great product if I can get it to work!!!

    -- David
     
    news-server.nc.rr.com, Sep 24, 2003
    #1
    1. Advertisements

  2. news-server.nc.rr.com

    MJ Guest

    I feel sure you've already done this and I'm just making a stupid
    suggestion, but I guess I must try anyway. Did you set the drive as
    slave to format it and forget to change it back to master? No, thought
    not. Sorry.

    MJ
     
    MJ, Sep 24, 2003
    #2
    1. Advertisements

  3. news-server.nc.rr.com

    Jimmy Guest

    Have you fully charged the battery or tried transferring with the AC adapter connected? Connected
    to the USB it can draw power from the computer, but in stand-alone setup it may have insufficient
    power for the drive to operate properly. After this is checked, you might want to take a look at
    the memory cards and pins in the unit's slots. Sometimes a pin will not engage properly and end up
    getting bent. Does (do) the memory card(s) still work properly in the camera? Have you tried
    different media? Going inside the unit, MJ in this thread suggested setting the drive to Master.
    This may or may not make a difference since you can access the drive via your computer. However,
    making this change certainly would eliminate that possibility.
     
    Jimmy, Sep 24, 2003
    #3
  4. Thank you both for your suggestions MJ and Jimmy.
    My xD card is readable via usb when attached to my notebook computer (via an
    xD to compact flash converter) so I have no worries about the memory card.
    I did check the docs on the IBM travelstar drive and with no jumpers it is
    set to be master.
    It must be something else...
    (BTW I tried to format it as a FAT16 drive via USB from the DOS window under
    winXP, and after more than an hour of progress, when it reached 100%
    formatted it yapped about how it can't convert a drive that large (30GB)!
    what a waste of time! I assume it spent that hour scanning the disk for
    errors and found none....)

    -- David
     
    news-server.nc.rr.com, Sep 24, 2003
    #4
  5. news-server.nc.rr.com

    Jimmy Guest

    Now that the power and mastering questions have been answered, the next logical step would be to
    look at the data input slots. If you have access to a CF card, try to copy pictures with this.
    Since this is a different slot than you would normally use with your xD/adapter combo, this would
    let you know if the unit is defective or if additional testing would be required on the slot you
    normally use. If it transfers okay, then the SD slot is defective or your xD/adapter isn't working
    in the X-Drive. If you try out a SD card and it doesn't work, then the slot is defective.
    However, if you can transfer from a SD card, then the problem should be wit the drive's inability to
    read the xD via the adapter.

    I have a VP-2030 X-Drive and haven't had problems when copying CF or SD media, unless the battery is
    low. However, I do not use a xD/adapter combo.

    For future reference, FAT16 is good up to 4GB partition sizes. FAT 32 partitions are suppose to go
    as large as 2TB, but WinXP and Win2000 can only format up to 32GB (Win98 can format to 2TB,
    however.). Go figure.
     
    Jimmy, Sep 24, 2003
    #5
  6. news-server.nc.rr.com

    MJ Guest

    I believe setting a drive to slave does make a difference. A few weeks
    ago I brought an X drive 2 back from Hong Kong without a drive. I took
    the old 20Gb drive out of my laptop and made it a slave to format it
    in my main pc. When I fitted it to the XS my heart sank as it started
    up and beeped with an error symbol. After a few seconds of thought I
    remembered the jumper, removed it and all was well.

    MJ
     
    MJ, Sep 24, 2003
    #6
  7. news-server.nc.rr.com

    Andrew Guest

    for what it's worth.......probably not much

    I have a X-drive 1 and have almost the reverse problem in that I cannot read
    the hard drive when plugged into my PC UNLESS a memory card is present in
    the X-Drive when I try to access the hard drive. check the

    After re-flashing your X-Drive, did you give it a good old hard reset
    through via the switch on the side. I've found this switch very "hit and
    miss" and had to re-jam a pin in there a few times before it 'caught on'

    Check the forums at http://www.dpreview.com/forums/forum.asp?forum=1023 and
    post for the attention of "Vasa" - he's the tech guy at
    www.powerinnumbers.com.au (or something like that) and seems to be the most
    clued up bloke on these products. He's pretty good at replying and
    contacting the manufacturers too, though don't know how keen he'd be unless
    he sold the product, but you can try.

    You'll see that there are a few posts relating to specific makes of CF card
    that are unreadable - maybe you just got unlucky - do you have another
    memory card brand you could try??


    having had all that pain, once you get it working you'll never travel with
    out it.

    Andrew
     
    Andrew, Sep 24, 2003
    #7
  8. news-server.nc.rr.com

    Jimmy Guest


    Vasa Carapic is the GM at Digital Store (aka www.powerinnumbers.com.au). His email address is
    vasa*1a*@powerinnumbers.com.au (remove *1a* for the correct address). Great person to work with
    and has a wealth of information on these units.
     
    Jimmy, Sep 25, 2003
    #8
  9. Thank you all again for your help.
    I contacted and they told me that to format the drive from
    xp you must use THEIR format software available on xs-drive.com.
    I nervously did use their format util, and the unit now seems to work. Will
    put it thru its paces tonight.
    Not sure why what they do is different than format e: /fs:FAT32 (might have
    something to do with boot records),
    but hey - life's too short to try to understand everything...

    8^)

    -- David
     
    news-server.nc.rr.com, Sep 25, 2003
    #9
  10. news-server.nc.rr.com

    Jimmy Guest

    Sounds like your in business. I tried the format program from www.xs-drive.com and noticed one
    problem while trying it out on my Xs Drive. The moment I select start, the FAT selection changed
    from FAT32 to FAT. I stopped it immediately since I didn't want to have my partition reduced to
    only 8GB. I went back through My Computer and did a quick format back to FAT32 and the partition
    size is correctly shown. You might want to check to see that the full drive size is being reported
    through XP.

    I noticed in their Readme file they suggest checking the fdisk selection. This would establish the
    partition tables for the drive and allow the FAT32 tables to be established properly. I wonder if
    this could have been part of your problem. Enjoy the vacation!
     
    Jimmy, Sep 25, 2003
    #10
  11. news-server.nc.rr.com

    MJ Guest

    I'm not sure either. As I said previously, I fitted an old drive out
    of my laptop, but I formatted it with Partition Magic. This worked for
    me. Worthwhile remembering this problem. I'm sure it will crop up
    again.

    MJ
     
    MJ, Sep 25, 2003
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.