Problems with streaming through my router

Discussion in 'Network Routers' started by Petter Solbu, Aug 9, 2007.

  1. Petter Solbu

    Petter Solbu Guest

    I have a problem with my router when it comes to a program I use for
    video streaming, Sopcast. When I start to stream, it works for 20
    minutes and then my internet connection is shut down by the router, and
    the router needs to be restarted to function again. This happens only
    when I use the Sopcast program. I have disabled the router firewall. I
    have read some places that it is best to open some ports on the router,
    but since it works in 20 minutes, I am not sure whether the ports is the
    problem or if there are other sources to my problem. Any ideas? I am not
    that good at opening ports either. "Port forwarding" and "port opening",
    any difference? I use Windows Vista Home Premium, and my router is a
    wired Belkin F5D5230y4 router.

    I would be thankful for any help!

    PS.
     
    Petter Solbu, Aug 9, 2007
    #1
    1. Advertisements

  2. Petter Solbu

    CaptCrazy Guest


    Hi Petter,

    I had a similar problem with a router, and after months of bafflement, I
    realised it felt a little warm to the touch.. So I turned it upside
    down so that the ventilation holes were exposed upwards, and this seemed
    to solve my problem.

    A colleague has had a similar experience with a 3com Enterprise level
    managed switch, in the end we found a 45degree inclination against a
    wall seemed to provide a medium it was happy to work in.

    its a bit of a long shot, but try changing the placement/position of
    yours and see if helps (especially with regards to the air vents).

    Cya!
     
    CaptCrazy, Aug 9, 2007
    #2
    1. Advertisements

  3. Petter Solbu

    Petter Solbu Guest

    CaptCrazy skrev:
    Thanks! I will try that. But did your problem only occur with (P2P)
    streaming as well? Why doesn't the router handle P2P streaming? You
    don't think it has anything to do with the ports? Since it works
    properly in 20 minutes, that sounds a bit odd, I think.

    PS.
     
    Petter Solbu, Aug 9, 2007
    #3
  4. Petter Solbu

    Petter Solbu Guest

    Petter Solbu skrev:
    By the way, I tried to stream the same channel with a different
    software, but with the same reaction from the router after half an hour.
    Strange..

    PS.
     
    Petter Solbu, Aug 9, 2007
    #4
  5. Petter Solbu

    CaptCrazy Guest

    Hi Peter,

    In my case it seemed to be just the constant barage of traffic caused
    the router's processor to work harder, and in working harder over a
    short but sustained period of time, it got too warm and started behaving
    weirdly.

    I dont think its to do with the ports - no.

    BUT, it could be your ISP noticing the traffic and sending creating a
    block to what is presumably your dynamically assigned IP address at the
    given time.

    Then, because you have to reconnect, you get a new IP address, you start
    up P2P traffic and the ISP notice it again and shut it down on your
    connection.

    Anyway, let me know how the repositioning of the router goes.

    Cya
     
    CaptCrazy, Aug 9, 2007
    #5
  6. Petter Solbu

    Petter Solbu Guest

    CaptCrazy skrev:
    Hi again! Well, my router is not that hot actually. And it doesn't seem
    to help to change its position. This only happens when I use P2P
    streaming software. I am going to try with a different PC now and see if
    that changes things. I use Vista, so maybe that could be an issue here.
    I have dynamic IP addressing, that's correct. But could it have anything
    to do with my router configurations besides the port thing? I am not an
    expert on router or network issues, not at all!:) But how could my ISP
    block my traffic automatically? I have used torrent software before, and
    that is no problem. Hm, strange stuff..

    PS.
     
    Petter Solbu, Aug 9, 2007
    #6
  7. Petter Solbu

    CaptCrazy Guest

    At the moment it would seem highly unlikely that your router is the
    problem. If your router configuration was going to cause a problem, then
    you shouldnt be able to achieve any P2P activity at all.
    ISP's have hardware which constantly monitors internet traffic coming in
    and out of their network. They can block whatever they want to block, at
    any time. MOST of the time, ISP's are happy to let you go about doing
    whatever you want to do. But some ISP's have been known to clamp down on
    certain internet traffic.

    Who is your ISP? and have you used BitTorrent P2P software on your
    current ISP successfully ever?

    Cya!
     
    CaptCrazy, Aug 9, 2007
    #7
  8. Petter Solbu

    Petter Solbu Guest

    CaptCrazy skrev:
    Hi again. I am Norwegian, my ISP is Canal Digital (www.canaldigital.no).
    I guess that is what you mean by my ISP? The company which gives me
    internet connection? And yes, I have used Utorrent several times with
    this internet connection with no problems at all. My router hasn't
    responded to that. The thing is that only my router needs to get
    restarted here! So I can't understand that my ISP has anything to do
    with this. If they had, wouldn't it make more sense that I needed to
    restart the modem?

    PS.
     
    Petter Solbu, Aug 9, 2007
    #8
  9. Petter Solbu

    CaptCrazy Guest

    Are your modem and router different devices then? Your router doesnt
    have a built in modem?

    If your modem IS a seperate device altogether, why not try connecting
    one of your computers straight onto the modem (download the drivers
    first of course).

    Then you'd be able to see if the router really is the problem or not.

    A quick scan of your ISP (Canal Digital) in Google didnt turn up
    anything which might suggest they are known for blocking P2P traffic.

    Your right - this is weird.
     
    CaptCrazy, Aug 9, 2007
    #9
  10. Petter Solbu

    Petter Solbu Guest

    First of all I will say that I now have tried to P2P stream from a
    different machine with XP Home Edition. Same response from the router
    after half an hour or so. So my OS or machine for that matter has
    nothing to do with this apparently.

    CaptCrazy skrev:
    They are different devices, yes. I don't think my router has any modem
    inside. It is a quite regular router, not very expensive. Belkin 4-port
    wired router, F5D5230y4 version.
    Due to the other machine(s) connected, that is not often possible, I am
    afraid. But I am pretty sure that my modem has nothing to do with this.
    I mean, how come I don't need to restart my modem? This has to do with
    the router, I can't think of anything else..
    Well, it is a Norwegian company. You probably won't find much about that
    company on Google :) But if my ISP is blocking this, it is going
    automatical, I guess? Noone sits there and supervise me all the time??
    Yes, it sure is!

    Thanks for help so far, by the way.

    PS.
     
    Petter Solbu, Aug 9, 2007
    #10
  11. Petter Solbu

    CaptCrazy Guest

    Hi again Petter,

    HmmmmmmmMMMMMMmmmmmmmmmmmmmmmMmmmmmmmmmmmmmmmmmm..

    Well, I have to agree with you - the router does seem to be at fault.

    If your ISP provided the router, I think your quickest fix for this
    (considering your response regarding the office environment) would be to
    either get Canal Digital to send you out a replacement unit (using
    whichever excuse you fancy, but "intermittent power failure" is
    important enough and vague enough for them not to argue too much and
    just do it), or buy yourself a replacement unit.

    In all honesty, it still sounds like the unit is suffering from a heat
    issue. Although it doesnt feel warm to touch, this could be because the
    casing is sufficiently wide enough so that the warm component cant
    transfer heat directly to the plastic. Instead, the air inside becomes
    warm and causes it to crash (thus requiring a reboot to get it working
    again).

    Another possibility is that its electrical supply isnt 'clean' enough.
    You could try pluggin the router into an unused power mains socket all
    by itself and see how long it 'stays alive' under P2P use then.

    Im confident its not a configuration problem - which only really leaves
    a physical problem. You could try replacing the cable that runs between
    the router and the modem - although I cant see how this would cause it
    to appear to crash and require a reboot.

    Weird :)

    Im 95% sure its a physical problem Petter - if ot was a configuration
    issue it either works, or it doesnt work. It doesnt work for x number
    of seconds/minutes/hours/days and then not work.

    Cya!
     
    CaptCrazy, Aug 10, 2007
    #11
  12. Petter Solbu

    Petter Solbu Guest

    CaptCrazy skrev:
    This is my own router, I'm afraid. So an opportunity is to buy a new
    router, but then I want to be sure that my router is the problem here,
    and that it can not be fixed.
    But why does the router only need a reboot when I use p2p streaming
    software?? Does the router work harder in only these cases?
    Ok, I'll try that.
    I am pretty sure that it is some problem with the router that cannot be
    fixed. It is some years old now, and was not the most expensive router
    on the market when it was bought. But, it is stupid to buy a new one
    without investigating the problem properly, I think. It will irritate me
    pretty much if a brand new router won't work with p2p either! :)

    PS.
     
    Petter Solbu, Aug 10, 2007
    #12
  13. Petter Solbu

    LC Guest

    I just briefly read your notes, but I had issues with my wireless once
    and P2P software. I disabled UPnP and stability was regained.
     
    LC, Aug 10, 2007
    #13
  14. Petter Solbu

    Petter Solbu Guest

    LC skrev:
    How do I do that? What are the disadvantages in disabling UPnP?

    PS.
     
    Petter Solbu, Aug 10, 2007
    #14
  15. Petter Solbu

    Petter Solbu Guest

    CaptCrazy skrev:
    Actually I have now switched the outlet that my router is connected to,
    and also changed the router's position a little bit. As we speak my P2P
    streaming software has run for almost an hour, which is a solid record
    :). I am not sure that this is a permanent solution, and maybe P2P
    traffic can vary a little bit? I mean, when a popular channel is
    streamed, maybe the router has more work to do, or what do you think,
    CaptCrazy?

    PS.
     
    Petter Solbu, Aug 10, 2007
    #15
  16. Petter Solbu

    Petter Solbu Guest

    Petter Solbu skrev:
    And it was just temporary, I'm afraid. Just like I said, when the
    evening arrives and more people want to watch, the thing brokes down
    again. Damn. I think I would have to buy a new router. Can't see any
    other alternatives if I want to use this software. The thing that
    doesn't make sense is that my router does not respond to torrent
    software, or any other activity from my computer. Just this P2P
    Streaming thing. That makes me think that my router is not the only
    problem. This is one of the most irritating things I have experienced
    when it comes to networking!

    PS.
     
    Petter Solbu, Aug 10, 2007
    #16
  17. Petter Solbu

    LC Guest


    Ok. Unit is F5D5230. So your video streaming from Sopcast. Are you
    broadcasting? Are you receiving a broadcast from a peer? What happens
    when you video stream from YouTube? Can you place a pc experiencing
    this in DMZ ? Pg 32," streaming video applications can benefit from
    bypassing the NAT firewall security."

    How did you disable firewall? What is the site your trying to access
    to do test myself ?
    UPnP info at,http://en.wikipedia.org/wiki/Universal_Plug_and_Play

    but it appears that your unit may not support this function. Unless
    its in a new firmware version, not documented in the manual. Do you
    see this option on your web interface?

    What utilities do you have? Have you applied any firmware upgrades?
    Does this happen on all OSes? non-vista?
     
    LC, Aug 14, 2007
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.