Problems with Multilink PPP between Cisco and Junipers?

Discussion in 'Cisco' started by Andrew Gideon, Mar 21, 2005.

  1. We'd a one of two T-1s in a Multilink PPP bundle go down. Annoying. But
    this also appears to have somehow "broken" the Multilink itself. Very
    Annoying.

    I'm on the Cisco side: a 3662 running 12.2(23a). I've removed the "bad"
    serial line from the Multilink, as did a fellow on the Juniper side, but
    the link didn't return to a working state.

    When the broken serial line is fixed, we'll be able to do a little more
    testing. It *might* only be a coincidence that both the Multilink breaking
    and the serial line going down occurred at the exact same time. But I've
    my doubts.

    Anyone have any thoughts or ideas?

    I've no minimum number of member links set on my side, and the Juniper side
    had a minimum of one (and we did confirm that the remaining T-1 was
    working). The Multilink reported itself as up on both sides, but we
    couldn't ping each other's IPs. I couldn't even ping my own!

    Both IPs could be pinged from elsewhere, however.

    The configuration for the multilink on my side is pretty basic:

    interface multilink 2
    description Upstream 2
    no ip address
    ip address a.b.c.d 255.255.255.252
    ip nat outside
    ppp multilink
    multilink-group 2
    ip access-group 101 in
    ip access-group out-to-world out
    no ip directed-broadcast
    no ip unreachables
    no cdp enable

    with a couple of serial interfaces "joining" via:

    encapsulation ppp
    ppp multilink

    Any thoughts or suggestions welcome...

    Andrew
     
    Andrew Gideon, Mar 21, 2005
    #1
    1. Advertisements

  2. Andrew Gideon

    aunraza Guest

    Did you try pinging from the inside? Or sourcing the ping on the router
    from the internal interface?
     
    aunraza, Mar 21, 2005
    #2
    1. Advertisements

  3. Andrew Gideon

    Hansang Bae Guest

    Let us know how it turns out. Might be a Cisco/Juniper thing.


    --

    hsb


    "Somehow I imagined this experience would be more rewarding" Calvin
    **************************ROT13 MY ADDRESS*************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
     
    Hansang Bae, Mar 22, 2005
    #3
  4. The T-1 was brought back into service. The Multilink was reestablished on
    both sides, and all was well. I could ping both my side of the link and
    the remote site, and traffic moved properly.

    I'm leaning slightly towards the Cisco/Juniper "thing" idea, except I'd be
    hard pressed to describe the details of the thing. I know that I (on the
    Cisco side) had at one point completely removed the Multilink interface and
    rebuilt it with the lone working circuit. I believe that this was done on
    the Juniper side too.

    Yet that didn't provide a working Multilink. How could that not, unless one
    cannot build a Multilink out of a single circuit between Cisco and Juniper?

    Another puzzle to me within the larger puzzle is why I couldn't ping my side
    of the Multilink. How could that not be possible?

    - Andrew
     
    Andrew Gideon, Mar 22, 2005
    #4
  5. I don't recall doing this. I suspect that it would have worked, but gone
    "the long way round". That is, the pings to those IPs would have left my
    "inside" via another egress path and then worked their way back.
    I did source the ping to the far side of the Multilink from the near side's
    IP to no effect. I didn't try sourcing the pings to the near side from
    anything in particular; I'm not sure what source would have been
    "interesting".

    - Andrew
     
    Andrew Gideon, Mar 22, 2005
    #5
  6. Andrew Gideon

    Rob Guest

    Yes, there is a known issue between Cisco and Juniper doing MLPPP. At
    least that is what Global Crossing told me when they wouldn't let me
    do it until Juniper fixed their code. That was back in December.
    Now, I don't know if this fix was specific for the ISP Global Crossing
    or public. You'll have to ask Juniper.

    BTW, it works fine now. I have several Cisco routers (mostly 2600XM
    series) doing MLPPP with either two or four T1's to Global Crossing,
    and they only run Juniper. There were some specific commands that
    needed to be done, like turn off MLPPP fragmentation on both sides,
    and an MTU bug which affects only OSPF, but that's it.

    -Bob
     
    Rob, Mar 23, 2005
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.