Problems with a WD 1TB Network drive

Discussion in 'Network Routers' started by Iced Tea, Nov 9, 2008.

  1. Iced Tea

    Iced Tea Guest

    I have a Linksys WRT54GL Wireless Router on my network and a Western Digital
    My Book World Edition 1TB Network Drive. For some reason after several
    hours (haven't timed it so I don't actually know how long)on the network the
    WD Network drive becomes inaccessible. I sent back the first drive and got
    another one brand new right out of the box and I have the same issues.

    Contacted WD Supprt and so far no success on the problem as to why this
    happens. the only way that I can get then network to see the drive again is
    to unplug the power from the back of the WD Network drive. I have an HP
    Officejet that is on the network and I don't have any problems with it.

    Anyone familiar with the router and network drive I have? Will taking any
    help at this point.
    Iced Tea, Nov 9, 2008
    1. Advertisements

  2. Iced Tea

    Bob M Guest

    While this may not resolve your problem it wouldn't hurt to try and
    configure the drive for "static" IP and assign it an address on your
    network. The reason is that if your DHCP "lease" is expiring the drive
    controller may not be reacquiring a new address.

    Just a hunch... Good luck.
    Bob M, Nov 9, 2008
    1. Advertisements

  3. Iced Tea

    Iced Tea Guest

    I know how to manually configure the WD Network Drive for a static IP but
    not sure on the router though???
    Iced Tea, Nov 10, 2008
  4. Nothing is usually needed to be done at the router except to possibly put a
    limit on the maximum number of DHCP address values it can assign. Just make
    sure that the fixed IP is not one that the router has permission to assign
    using DHCP. In my case I have my router limited to the first 50 address
    entries for DHCP starting with Any fixed IP's I assign to
    devices like servers or test machines all in the - 254 range.
    That way there is never an overlap caused by the router giving out an IP
    already in use by a fixed IP device and I still have room to expand the DHCP
    range if needed..
    GlowingBlueMist, Nov 10, 2008
  5. Iced Tea

    Iced Tea Guest

    I am not sure what to fill in where when setting the static IP on this
    network drive. I am so new to networking, I am learning and looking at
    getting a book or two to expand my knowledge.

    Anyway when I go into the manual configuration on the network drive it asks
    the following:

    Step #1 - Network Address and Subnet Settings
    Network Address:

    Subnet Mask:

    Step #2 - Gateway

    DNS Servers:

    NTP Server:

    Not sure what goes, but this is my guess bases on what little I have

    Network Address: static IP I would assign to the network
    Subnet Mask: I dont know
    Gateway: IP address of my router
    DNS Servers: I don't know
    NTP Server: I don't know

    Any help would be greatly appreciated.

    Iced Tea, Nov 12, 2008
  6. Iced Tea

    1PW Guest

    Make this the same as the former DHCP address for now. In the future,
    you may wish to make this /above/ the range of your router's usual DHCP
    allotments. Example: if you were to use the above example. typically
    On your Windows PC, and from a "CMD" prompt: >ipconfig/all

    Pick out the DNS server addresses, in the order given, by your ISP.
    Pick a geographical nearby "Stratum 2" Network Time Protocol server.
    Best wishes to you Carl.
    1PW, Nov 12, 2008
  7. Iced Tea

    Iced Tea Guest

    So the NTP Server is just a name I need to assign?

    Iced Tea, Nov 14, 2008
  8. Iced Tea

    1PW Guest

    1PW, Nov 14, 2008
  9. Iced Tea

    Iced Tea Guest

    I haven't yet changed the Network Drive to s static IP yet. I don have
    another question though. As I was looking through what few menus exist on
    the drive for settings, I did come across where you can change the device
    name and the workgroup name. How important is this? I found nothing on the
    WD site about it, but I know when I set up my desktop and laptop I thought I
    remember something to the fact about having the workgroup names the same. At
    this time the Network Drive does have a different workgroup name. Just
    something else I thought I would ask about.

    I also thought about buying a book or 2 to learn about networking, does
    anyone have any suggestions? Are there some that are better than others?


    Iced Tea, Nov 15, 2008
  10. Iced Tea

    Bob M Guest

    IMHO - the workgroup on ALL your networked devices need to be the same to
    allow then to "see" each other. That includes your PC's and NAS's.

    One book that might help is the standard yellow and black "Networking for
    Dummies" which you should be able to find used on books for a
    buck or two.

    Hope this helps.
    Bob M, Nov 15, 2008
  11. Iced Tea

    Iced Tea Guest

    Drive now has a static IP and the workgroup name matches and still the same
    result. The only support I can get from WD is that it is the router or
    something in the configuration. So at this point it sounds like they are
    going to be much help. They offered yet another exchange but I can't see
    getting 2 of them that are defective. I have even connected the network
    drive to different ports on the router and I get the same result. Even used
    the ethernet cable that was supplied with the drive. At this point I am out
    of answers and it looks like I will be out some more money to send this
    thing back. Anyway have any more suggetions?

    Iced Tea, Nov 22, 2008
  12. Iced Tea

    1PW Guest

    Hello Carl:

    Now, won't you need to go into your router's setup and make a
    sympathetic entry to match static IP you've just created?

    Does it seem to have been a DHCP lease expiration issue?

    1PW, Nov 22, 2008
  13. Iced Tea

    Iced Tea Guest

    Not sure if I need to or not, I have a Linksys WRT54GL Wireless Router.

    On the expiration issue that is what I thought at first, I could reset the
    drive back to a DHCP and then look at the expiration and keep an eye on it
    to see if that is when the drive disappears from the network.

    I appreciate your help in trying to resolve my issues with this thing.

    Iced Tea, Nov 22, 2008
  14. Iced Tea

    1PW Guest

    Hello Carl:

    I tried looking at the illustrations in the Linksys WRT54GL User Guide,
    but their on-line pdf does not work well with enlargement of its
    embedded images. I tried to see if the DHCP lease time could be set to
    some extremely large time value and I was also trying to see if the
    router /itself/ could declare some addresses as static.

    Ultimately, maybe you might need to contact Linksys/Cisco technical
    support. Your router may have had a firmware update issued earlier this
    year, and tech support may possibly ask you to verify that your firmware
    is the latest.

    It's a pleasure to help you. I've actually dreamed up an idea of trying
    to cascade my Linksys Gateway and my Linksys Router in my own SOHO
    installation. That came about during this thread. Thank YOU!

    1PW, Nov 22, 2008
  15. Iced Tea

    Iced Tea Guest

    Iced Tea, Nov 22, 2008
  16. Iced Tea

    Iced Tea Guest

    I will try the support tomorrow when I have plenty of time. If you think of
    anything that I could try please let me know. Glad my problem created an
    idea for you!!!

    Iced Tea, Nov 22, 2008
  17. Iced Tea

    Iced Tea Guest

    Contact Linksys this morning and they had me change the IP address of the
    NAS, to see if that would resolve the problem. The only other thing they
    asked me to do is if the problem continued was to contact the NAS mfg and
    see if certain ports need to be open or opened. Is there anything on my NIC
    that would be causing the problem?

    Iced Tea, Nov 23, 2008
  18. Iced Tea

    1PW Guest

    1PW, Nov 25, 2008
  19. Iced Tea

    Iced Tea Guest

    Good Morning, hope you are having or have a GREAT Thanksgiving!!!

    While I am no further today in getting a stable connection on the NAS. I
    have tried various things in the past couple of days and to no avail nothing
    has worked.
    For the most part,

    1. I have finally got some better answers from Western Digital on the NAS.
    Try another network/router (which I think was suggested here), also try
    hooking the NAS directly to the NIC, plus some standard stuff which I had
    already done, but with no change.

    2. I tried the NAS at my brothers network (all dhcp, including when we
    hooked the NAS up), The only difference was his router (D-Link DI-524) which
    after 24 hours on the network, the NAS was still there!!! Yeah!!! Which
    leads me to believe now that it is my router or my NIC (which is has onboard
    LAN built into the motherboard, Intel DP35DP, Gigabit (10/100/1000
    Mbits/sec) LAN subsystem using the IntelĀ® 82566DC Gigabit Ethernet

    3. I connected the NAS directly to the NIC last night when I got home from
    work and 10 hours later it is still visible and accessible on the network.

    So this has now narrowed ot down to the router, BUT what? Linksys has asked
    about specific ports needing to be opened to the drive. According to WD
    (which they did include the ports) the ports only needed to be opened if you
    used the Mionet software which enables you to access the NAS away from home.

    At this point I am out of any ideas, as I am going to try and contact
    Linksys support again and see what they can offer since I do have it
    narrowed down to what seems to be the router. Everything on this computer
    (with the exception of the tower and power supply are only a little over a 1
    1/2 months old). I can't return anything to NewEgg where I bought everything
    since they only have a 30 day return/refund exchange on most items. My
    brother suggested just buying another router but unless I get the exact same
    one he has, there is no gaurantee that I won't have the same issues with
    another one (different brand or model).

    Let me know if I have shed anything new on this issue since it now sounds as
    though I have narrowed it down to the router. I will follow up here with
    what I found out from Linksys.

    Iced Tea, Nov 27, 2008
  20. Iced Tea

    1PW Guest

    ....and to you Carl.
    Nice troubleshooting above. Good stuff!
    This seems to have some significance. What port(s) would the NAS use
    while receiving/sending files via backup and restore?
    Although I do note with interest that your NAS worked at your brother's,
    even in a DHCP mode, I'd still like to see you set up a static IP
    between your router and NAS. Even if this meant setting up static IPs
    for everything you have.

    You probably can't state how long the DHCP lease period was on your
    brother's D-Link router. Might it have been set to more than 24 hours?

    Did you ever make sure you had the latest firmware in your Linksys

    Have a nice Thanksgiving.
    1PW, Nov 27, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.