Problems installing network card (ethernet 10/100 NIC PCI)

Discussion in 'Computer Information' started by Bazzer Smith, May 5, 2006.

  1. Bazzer Smith

    Bazzer Smith Guest

    I bough a cheap network card 10/100 NIC PCI ethernet card
    and a cross over cable with the intent of conecting 2 PC's.

    Anyway I had some problem's installing it with the supplied
    installation disk. At some point during the installation disk it
    would say 'insert your windows98SE CDROM', I have
    just windows98 not 98SE but I stuck that disk in anyway.
    Then it tries to copy a pile of files off that disk but it says
    it can't find them, so basically it fails to install. I have had
    a 'browse' of my windows98 disk (and disk which came
    with the card, but I could not seem to find the files either).

    The files concerned (probably over 40 of em) were named
    such as - dhcpcsvc.dll, icmp.dll Routetab.dll etc....
    I noticed some of these files were already on my machine
    in the system folder (probably quite a lot of em), I also know
    I can download mising dll's from the net, however some
    of the files were called 'networks' and 'protocol' (try googling
    on those words for a file to download and you can see that
    you will have problems cos you will get millions of irrelevant
    things returned).

    Anyway I tried to connect up the computers with a crossover cable
    but it didn't seem to work.I also tried to connect to my cable modem
    via the ethernet card but that didn't work either.

    So I am not sure where I am or how to proceed, any ideas?
    The computer I put the card in is an old one,Cryix MII 300,
    maybe it can't use ethernet (I am out of my depth here!!).

    Is there a 'standard' instalation I can download from somewhere?
    I have never installed one of these cards before so I have nothing
    to go on really so I would appreciate any help from anyone
    who is familliar with these cards and their installation etc..


    TIA.
     
    Bazzer Smith, May 5, 2006
    #1
    1. Advertisements

  2. Bazzer Smith

    Bazzer Smith Guest

    Prehaps I should add that I connected the computer I put the
    card in to my new computer which already had an ethernet
    card in it (Win XP) and it detected the connection but then timed
    out cos I don't think it was getting any response.
    Thanks once again!!
     
    Bazzer Smith, May 5, 2006
    #2
    1. Advertisements

  3. Bazzer Smith

    kony Guest

    It might help to identify this card, the chipset it uses.
    Look on the card at the markings on the main (big) chip. If
    there is a sticker over it, write down what is on that
    sticker, for preservation purposes, then take off the
    sticker and read off what is on the chip.

    The point of this is that some NICs have you do entirely
    unnecessary things that have no good use.

    A typical PCI nic for Win98 has a driver with about 2 files.
    Taking Realtek 8139 for example (is on a ton of
    motherboards, and cheap generic network cards), the driver
    for Win98 is comprised of (the file names may vary slightly
    but follow this general theme):


    netrtl4.inf
    rtlnic4.sys

    These two files are about 11K and 80K respectively.

    So on Realtek's website, there might be (I haven't checked
    on Win98 "FE" (first edition) recently) two or more version
    of the file... a small version, maybe a few dozen KB in size
    and the overbloated version of several hundred KB if not
    over 1MB.

    You only need the smaller file and it is a better option.
    It might be a zip file, so you'd just unzip to a folder then
    uninstall any/all other things you had previously for the
    card. Perhaps in add/remove programs. The next time
    windows boots (reboot the system), if windows prompts for
    the driver you browse to the location of the folder you
    unzipped the files to. If windows automatically finds a
    driver instead, then go into Device Manager, the properties
    for this network adapter, and there you change the driver by
    browsing to that new folder with the very few files in it.
    Usually a Win9x (win95, 98, 98SE, or ME) driver will work on
    98. If in doubt, choose an older driver, for example since
    you have 98 and if there were only a Win95 and Win98SE or ME
    driver available, choose the Win95 driver.

    IN an attempt to follow Microsoft's lead and dumb-down
    everything, doing simple things is becoming ever more
    complex and subject to human errors (by those creating these
    driver packages). The method I described above is almost
    always the best way, to do it even the first time, never
    trying the driver installer package at all.


    Those are probably just Windows files, not that came with
    the network card CD. If they're already in the system
    folder, sometimes you can just point (browse to) that
    location when it is looking for them. However, what it
    wants is either the original windows CD or the folder on the
    hard drive where (you or an OEM, typically) had put the
    windows installation files, those named *.cab)... so it's
    really looking for a *.cab file, which it decompressed to
    find the files within. If you did a Find->Files and
    searched for files named *.cab, containing text
    "dhcpcsvc.dll", etc, it would take a while but probably find
    the cab file that particular "dhcpcsvc.dll" file was in.

    If I recall correctly, this happens with any network adapter
    driver installation so even using the small driver above,
    you will need the windows CD or to browse to where those
    files are on your hard drive. I had thought when you
    browsed to them, it showed something like the cab file name,
    then a comma, and then the internal file name, in the field
    at the bottom of the browse-to window.

    ALL the files you will need are either on your Windows CD or
    in the small network adapter file mentioned initially. If
    your system is an OEM with only a restore disc, not a full
    windows CD, those files will be in a folder on the hard
    drive somewhere... do a find->files for *.cab and the folder
    would be the one that has most of them in it... several
    dozen MB worth.

    Until the driver and files are installed, there's no point
    in trying the cable connection. After they're installed,
    Device Manager should show the device working properly, and
    if you clicked [Start] button, "Run", (and then type)
    "Winipcfg" {hit enter key}, it should show the IP
    configuration utility which lists the network adapters and
    their configuration, and this new adapter would show up
    there if properly installed and configured.

    Well I don't know if it having a Cyrix MII CPU could be a
    compatibility issue or not, but I'd get a driver from the
    network adapter chipset manufacturer, just ignoring the
    included CD altogether. I've _never_ had to use the
    included CD or floppy to install a network adapter and I
    never do it, I just throw those away as they are useless, in
    my option. Not that they can't work but are never any
    better than the other alternative.

    Yes, I probably have the driver you need if the chipset
    manufacturer doesn't anymore, but first we need to know the
    markings on the primary (big) chip on it.
     
    kony, May 5, 2006
    #3
  4. Bazzer Smith

    Bazzer Smith Guest


    Thanks there is a lot for me to look into there, I will have a
    look on the computer (Im on my new one now) a bit later
    and have a look inside to see what is on the chip

    Just looking at my scrawled noted and it says
    Realtec rtl8...... (something I partially wrote down, might be
    a .dll)

    I think one bit of the installation worked ok were it instaled
    some stuff, but then you have to reboot and do the bit which
    doesn't work

    OK just been on the old computer with the card in it and
    I looked in system- device manager and it said
    Realtec RTL8129 PCI Fast Ethernet.


    Also I have setup file in windows/options/cabs
    which seem to have a few more file than those
    on the installation disk, but the folders lool
    fairly similar in content with lots of cab files.
    How do you tell the process installer to look inside
    those cab files?
    Will it do it automatically?

    Thanks!!

    I will try installing it again a bit later, and provide
    any info I missed out here.
     
    Bazzer Smith, May 5, 2006
    #4
  5. Bazzer Smith

    beenthere Guest

    If you still have troubles Baz, I`ve found the drivers here:
    http://www.network-drivers.com/companies/891.htm

    Realtek 8129.. scan down the page till you find your OS.
    It`s a zipped file.
    Delete existing refs in Device manager, and restart machine,
    and tell the system where the file is, or you might be able to install
    from the package, then restart.
    __
    bw..OJ
     
    beenthere, May 5, 2006
    #5
  6. Bazzer Smith

    Bazzer Smith Guest


    I think I might have just downloaded that from elsewhere not
    a very big file about 84k so I don't now how that effects
    the installation prog looking for scores of dll's (probably
    not needed I hope).

    Trouble is I downloaded it to my new machine and need to transfer it.
    If only I have an ethernet connection set up I could copy it accross!!

    I will give it a go later anyway. I think I will transfer it by
    'swap slave hardrive net'.
     
    Bazzer Smith, May 5, 2006
    #6
  7. Bazzer Smith

    Bazzer Smith Guest


    OK I got the zip and tried it but it kind of did the same thing, ie it
    sort of in stalled it and then asked me to put my Windows CD in
    the drive as it wanted another bunch of files dhpcsvs.dll etc...
    So it basically seened to be doing the same thing.


    Anyway...I unzipped a load of the cab files I have and it seems
    a lot of the stuff if in there, (the above .dll for iinstance) also
    other stuff such as 'network' and ' protocol' which
    sound like the right stuff. I found such stuff in net7.cab - net10.cab
    which seems the right kind of place. However I think it wants to
    find these files on a CD (Windows), I don't think I can just specify a
    location (unfortunately) so I will try again and if necessary burn the
    files on to a CD and use that when it says 'insert windows cd'
    Got to be worth a try ;O)

    I will no doubt report back that it failed miserably shortly!!!!
     
    Bazzer Smith, May 5, 2006
    #7
  8. Bazzer Smith

    Bazzer Smith Guest

    Failed miserably!! :O)

    Well I got a little further, but no success in he end yet.
    I managed to get it to copy all the files off the disk I made,
    and it seemed to find them all on there. However after it had copied
    them across it started prompting me that the existing file was newer
    and asking if I wanted to keep the existing file, recommending yes.
    So I clicked yes and the first few files went OK, then it got to one
    file, I clicked yes and the system just hung. I tried it again and it
    hung again (one the file telenet.exe) I am unsure if it was the same
    file, I can't remember.
    I have noticed though, that when it asks you to insert the CDROM
    you can manually change where it copies the files from if you type it
    in yourself.
    Also I think I may have screwed up the comms on that computer
    by now for USB internet access (cos it hung, so I didconnected
    the USB and it would boot then) but I ain't sure.Anyway I am getting a bit
    fed
    up with it now so I will leave it for now and try again soem other time.
     
    Bazzer Smith, May 6, 2006
    #8
  9. Bazzer Smith

    Bazzer Smith Guest

    Tired several time but it won't work, sometime I fininish the
    installation process but when I reboot it just hangs so I
    have to power off so the system ignores the device.
     
    Bazzer Smith, May 6, 2006
    #9
  10. Bazzer Smith

    Ron Guest

    See if you can find the Microsoft broadband networking utility. I had the
    same problem, but I had a installation disk for a Microsoft product.
    It had the correct files.
    You should be able to download the Microsoft Broadband Networking utility
    from the Microsoft support site.
    If you do install it and then when you install your card it will get the
    correct files almost instantly.
    Ron
     
    Ron, May 6, 2006
    #10
  11. Bazzer Smith

    Bazzer Smith Guest

    I am kind of pulling my hair out over this, I am getting so confused.
    I actually had a look at the details on the chip and it says RTL8139D
    on it. Prior to that I had being 8129 (not 3) was the number I had seen.
    Anyway I downloaded that but it didn't seem to think the driver
    was in there at all (or the .inf file) I have had so many errors but know
    I don't know what I am doing. I tried starting from the beginning and
    it didn't seem to find the drivers it was looking for, but I think it
    did before or I though it was looking for something else and I pointed
    it to a load of files I unzipped from .cab files. Anyway I got it to
    go right to the end and it just said "drive not installed"!! Click finish.
    I didn't say what was the problem. Half the time I don't know
    what it is meant to be looking for, and it is asking for disks
    I don't have, its utter madness.
    I will have a look for that anyway I am getting so fed up with this, it only
    cost
    £5 but has caused £50 worth of misery. Not worth 50p.
    I think I will take it back to the shop, they are OK with refunds.
    But I will see if microsoft have anything which will sort out the mess
    I don't want it for BB though just to connect to computers if I can.
    I already have BB on USB, I expect it will screw that up knowing
    mu luck.
     
    Bazzer Smith, May 6, 2006
    #11
  12. Bazzer Smith

    Noozer Guest

    I am kind of pulling my hair out over this, I am getting so confused.
    This is a Realtek chip and generic drivers for the 8139 should work. Have
    you visited Realteks website and tried their drivers? (www.realtek.com.tw)

    What does the entry in Device Manager call this device? Without any drivers
    it should fall under "Other Devices" as a "PCI Network controller" or
    something similar.

    If it has already been unsuccessfully installed with different drivers, try
    removing the drivers from ADD/REMOVE programs. If you can't do that, then
    try the Update Driver option from the Device Mangler.
     
    Noozer, May 7, 2006
    #12
  13. Bazzer Smith

    Bazzer Smith Guest

    I think I have tried just about everything :O) and every combination of
    everything!!
    It says which is, I believe where I got
    the 8129 number from, it may well call it that during the set-up too if I
    recall
    from my now so confused mind!!

    I have an idea is that the 8139 if the OEM (whatever that means) version of
    8129
    and I have just downloaded a pile of the OEM 8139 stuff from the site you
    mentioned.
    Mine is an OEM machine I believe.

    I tried running the set up but it didn't work (sort of, it came up with an
    illegal operation/
    page fault but it still seemed to finish whatever it was doing (having a
    laugh probably)
    but it still says the device is not working in the control panel. Maybe I
    should have
    deleted the device before I started the set-up. I will try that next, but
    when that
    fails (I know it will) I think I will have finally ran out of ideas!!

    That sort of fits in a bit with something I have been thinking because now
    it seems that it does not find drivers which it found before when I tell
    it to look in the same folder. It is like it remembered that that driver
    didn't
    work and then ignores it. However it is very unclear which drivers it is
    looking for during the set-up process and I just end up pointing it to
    various
    folders with 'stuff' in untill it find something it likes to let get a bit
    further
    in the process which inevitably ends up in failure!! I am quite surprised
    my machine has not blown itself up by now!!!
    I have tried so many things I doubt the system is in it's original state
    by now although it stilll runs ok (using it now).

    Another thing is that it was very hard to get the card into the slot
    so maybe it was not fully inserted, however if the PC detected the
    card well enough to be able to say it's a "Realtek RTL8129 PCI Fast
    Ethernet"
    then one would assume it is inserted correctly?
    Actually when I definately had it fully inserted (in a different slot) the
    machine
    would not boot up at all!!

    I think I will give it one last go and then admit defeat. The card cost me
    about £5, less than the 1 metre cross over cable IIRC. I think I will
    probably take it back. If they give me my money back no probs I might
    buy a more expensive card from them (on the assumption they would
    take that back too if it wouldn't work. I don't actually need to get it
    working, other than for to satisfy my curiosity as to what I will be
    able to do with it as I have never had a 'network' so to speak.

    I will give it one last try but I know it won't work so I will have
    to admit defeat methinks.
     
    Bazzer Smith, May 7, 2006
    #13
  14. Bazzer Smith

    Bazzer Smith Guest

    I will give it one last try but I know it won't work so I will have
    Nope it didn't work!!
    What a waste of time!!
     
    Bazzer Smith, May 7, 2006
    #14
  15. Bazzer Smith

    kony Guest

    Make sure no driver for this nic is listed in Add/remove
    programs, uninstall any driver listing that remains.

    Delete it (remove from) Device Manager.

    Make sure you have your Windows CDROM or the location of the
    folder with the cab files. You should not need to
    decompress all the cab files, only to browse to the folder
    containing all the cab files when windows prompts for the
    files. There is also some registry hack that specifies to
    windows, the default location of the Windows installation
    files and thus you wouldn't need to ever browse to this
    folder, but for the time being it should still (as mentioned
    previously) be looking for the cab file itself, even though
    it is mentioning the files within it, it "knows" to look for
    the corresponding cab file too if only you tell it where the
    folder is that contains them (in cab file form).

    Have the two files I mentioned previously (the "small"
    driver) in a folder somewhere. When windows prompts for
    drivers, browse to this folder. If windows installs a
    different driver, ONLY go into device manager, the
    properties for the nic and change the driver, then browsing
    to the folder these two files are in.

    Is it possible your windows installation is damaged?
    Sometimes irreparable damage is done to the networking
    entries and it is best to just delete them all... but i
    hesitate to tell you to do this because not seeing the
    system I can't recall any specific issues in setting it up
    again... i mean the potential snags... since usually this
    nic you have is easy to install... and indeed if you
    randomly bought another nic, odds are pretty high that it
    could have the same realtek 8139 chip on it and need the
    exact same driver. If it is instead your windows OS
    installation that is messed up, any other nic (different
    chip on it I mean), could also be subject to similar
    problems.

    Essentially you are trying to undo everything that has
    happened since first trying to install the card, and
    removing all entries from the networking in control panel
    then readding them if all else fails.
     
    kony, May 7, 2006
    #15
  16. Bazzer Smith

    Bazzer Smith Guest

    My new machine does have realtek 8139 listed in system
    (not the 8129 listed in okd machine).


    I might try to install windows on the blank slave drive,
    make it master and then try to install the card on that
    Thus it would be an error free system?
     
    Bazzer Smith, May 7, 2006
    #16
  17. Bazzer Smith

    kony Guest


    Well it is windows....
    but yes, that is about as comprehensive as possible.
    It's rare, but I have received defective/dead/etc network
    cards. I wouldn't jump to that conclusion yet though as
    there were a lot of variables when windows wouldn't find
    it's OS files and multiple drivers were tried.
     
    kony, May 8, 2006
    #17
  18. It may have already been tried and I could easily have missed it, but didn't the
    original installation CD have a "setup.exe" or somesuch on it? I've only seen
    the CD used early on in response to Windows installation prompts, but never as a
    case of running that setup simply on its own.

    Bob
     
    Robert Heiling, May 8, 2006
    #18
  19. Bazzer Smith

    Noozer Guest

    Actually, I just realized... The Realtek 8139 chip is supported out of the
    box on Windows XP. I always tell folks to buy these cards since they are
    just plug'n'go.

    I'd suspect a conflict with something else, or a damaged OS.

    Try the following steps...

    1. Go to ADD/REMOVE PROGRAMS and uninstall any drivers that you may have
    installed for this card.

    2. Reboot into SAFE MODE and remove everything under the Other Devices
    folder and anything under Network Adapters that you don't recognize. SAFE
    MODE allows you to also see devices that aren't installed, but still have
    software loaded.

    3. Do a Windows file repair - "Start->Run->SFC /SCANNOW" This will scan your
    Windows files and restore any that are damaged or wrong.

    4a. Put the card into a different PCI slot. Be SURE to pull the plug (or
    turn off the switch) at the BACK of the computer. There is always power on
    the PCI slots if the power supply is turned on.

    4b. While inside the PC, consider removing cards in other PCI slots.

    4c. When boooting, consider going into your BIOS settings and turning off
    any devices in your settings that you aren't using. COM ports, LPT ports,
    SATA controllers, etc. This may free up resources and allow the network card
    to work.

    5. Windows will load and SHOULD be able to load your drivers without any
    help. You might not even see the New Hardware Wizard.

    6. Go do a Windows Update (NEVER let it install HARDWARE drivers) to make
    sure that the Windows file repair you did earlier didn't undo any security
    updates.

    At this point, if it doesn't work, I'd try and exchange it for another card
    that uses a different chip. Avoid anything by Linksys... Their LNE-100 card
    has a few dozen versions, and no identifying part number - so you never know
    what driver is correct.
     
    Noozer, May 8, 2006
    #19
  20. Bazzer Smith

    Bazzer Smith Guest

    Well if the card was dead how would windows know it
    was a realtec 8129 (even though it says 8139 on it).
    It must have communicated with the card to discover that so
    I would say that probably rules out the card being duff?
    I did think the 'gold' on the connectors was very close to
    geather, maybe touching, but if so then that would have fried
    my computer completely.

    I think it couldn't find the files because they were zipped,
    when I unzipped them and put them elsewhere and pointed
    windows there it did find them. I didin't unzip everything mainly
    the net??.zip cos that looked like the stuff needed.
    Then it would say some files were older, do you want to keep
    this file, I say yes and it goes throuogh a few untill it got
    to telnet.exe (IIRC) then the machine just hung (had to
    remove the power cable!!!


    Actuallly I just loaded the manual (acrobat file) onto this machine so
    I could look at it easier (much quicker) and I noticed something.
    When you are asked to insert the windows CD it did not find the
    file it was looking for, however it is clear from the example that it
    didn't find it then either as you can see it say...
    "The file netmib1.dll could not be found...on windows (SE) CDROM
    ........"
    So they didn't find that file either!!!
    It goes on.. check the path below is correct (how would I know?)
    then click OK.
    Well if you click OK you just get the same message again.
    SO YOU CANNOT COMPLETE THE INSTALLATION FOLLOWING
    THEIR INSTRUCTION!!
    So the card cannot have been installed by the person producing the
    documentation
    and screen shots.

    I was going to add a copy of the 'manual' as an attachment but it is a bit
    big.
    17 meg.

    Also in a readme file in section 'drivers' I note there is no driver for
    windows98:-
    REALTEK

    REALTEK

    For WIN98SE EA1110R\EA1115R
    :\Driver\REALTEK\Windows\VEN_10EC_DEV_8139\WIN98SE

    REALTEK

    For WINME EA1110R\EA1115R :\Driver\REALTEK\Windows\VEN_10EC_DEV_8139\WINME

    REALTEK

    For WIN2000 EA1110R\EA1115R
    :\Driver\REALTEK\Windows\VEN_10EC_DEV_8139\WIN2000

    REALTEK

    For WINXP EA1110R\EA1115R :\Driver\REALTEK\Windows\VEN_10EC_DEV_8139\WINXP

    REALTEK

    For Linux22x EA1110R\EA1115R
    :\Driver\REALTEK\Unix\linux22x-8139cp(100)\linux-2.2.x

    REALTEK

    For Linux24x EA1110R\EA1115R :\Driver\REALTEK\Unix\linux24x-8139cp(160)


    **************** There is one in this section under VIA ************?

    VIA

    VIA

    For WIN98 EA1110V\EA1115V :\Driver\VIA\VEN_1106_DEV_3106

    VIA

    For WINME EA1110V\EA1115V :\Driver\VIA\VEN_1106_DEV_3106

    VIA

    For WIN2000 EA1110V\EA1115V :\Driver\VIA\VEN_1106_DEV_3106

    VIA

    For WINXP EA1110V\EA1115V :\Driver\VIA\VEN_1106_DEV_3106

    VIA

    For LINUX EA1110V\EA1115V :\Driver\VIA\VEN_1106_DEV_3106\LINUX





    So.........it seems the driver could not have been installed by the people
    who

    sold the product. So where does that leave me?



    No wonder it was only £5!!!!!



    HAving said that it should be possible to install it with the correct files?

    And how does it know which files it wants off the windows CD?
     
    Bazzer Smith, May 8, 2006
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.