Problems in XP enabeling UDMA66 on the VIA Apollo Pro 133A Chipset (TYAN S1854 MoBo)

Discussion in 'Computer Support' started by Tim, Jan 6, 2004.

  1. Tim

    Tim Guest

    ok, have a shiny new 80 pin IDE connector, two drives on the channel.
    BIOS says UDMA-4 (UDMA-66) enabled, Windows XP says UDMA-3 (UDMA-33).

    Can't find any info anywhere or any registry edits to enable UDMA-66
    in XP on this chipset (just the intel hack - added the key and nothing
    changed).


    ideas?? TIA
     
    Tim, Jan 6, 2004
    #1
    1. Advertisements

  2. Tim

    ICee Guest

    What are the two drives on the channel? Are both UDMA 66? Are they set
    as Master and Slave or Cable Select?
     
    ICee, Jan 6, 2004
    #2
    1. Advertisements

  3. Tim

    Tim Guest



    Using 2 seagate drives that are both ATA100 - 40GB one is set to
    master, 80GB is slave. IDE Cable is brand new and 80 pin.

    BIOS screen confirms its set to UDMA-66 (thats the max for the Tyan
    S1854 mobo).

    Tried just the master drive on the primary IDE channel by itself,
    didn't make a difference.

    It appears to be set by windows... man... I'm stumped!!
     
    Tim, Jan 6, 2004
    #3
  4. Tim

    ICee Guest

    That is odd. Unfortunately, I have no idea what the solution is. XP
    seems to set the DMA mode on it's own and there is only a selection
    between PIO mode and DMA if available.
    Hopefully, someone will come along with an idea what to do.
     
    ICee, Jan 7, 2004
    #4
  5. Howdy!

    And how is the cable run? If you turn the cable around, the cable
    doesn't ID to the MB as an ATA-66+ cable.

    RwP
     
    Ralph Wade Phillips, Jan 7, 2004
    #5
  6. Tim

    Unk Guest

    Maybe some help here:

    Ultra DMA Mode 6 Devices Are Not Enabled on VIA Motherboards
    After You Install Windows XP SP1
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q327805

    Windows XP Service Pack 1 Incorrectly Identifies the VIA
    VT82C686B Chipset as Supporting Ultra DMA Mode 6
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q813861

    Integrated Technology Express Devices May Not Work with Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q329180

    HOW TO: Troubleshoot Issues That Occur When You Write Data
    to a CD-R or CD-RW Optical Disc in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q324129

    How to Troubleshoot Issues with Reading CD, CD-R, CD-RW,
    and DVD Discs
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q321641
    HOW TO: Manage Devices in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q283658

    HOW TO: Configure Devices By Using Device Manager in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;307970
     
    Unk, Jan 7, 2004
    #6
  7. Tim

    Tim Guest


    Hi,


    The section of cable with the two clips on each end are attached to
    the motherboard. The other two pieces that are notched are attached to
    the drives... haven't tried reversing them. I did try a plain ole' 40
    pin IDE cable on one of the drives just to see what would happen and
    it forced it do UDMA-1 for some reason (again BIOS shows UDMA-4).


    Quirky!
     
    Tim, Jan 7, 2004
    #7
  8. Tim

    Tim Guest



    Tried the top 2, my chipset is VT82C694X but the problem people were
    having is oddly similar - UDMA-5 drive/board but XP will only run in
    UDMA-4.

    Anyway, have the latest IDE VIA drivers installed on this hunk.. this
    is starting to drive me insane.


    I wanted to get the ABIT VP6 (for dual p3 1ghz CPUs and an extra DIMM
    bank).. it has 4 IDE channels, ATA100 and RAID but it has the same
    VIA 133 VT82C694X chipset... if the drivers are going to be messed up
    with that board its kinda pointless.
     
    Tim, Jan 7, 2004
    #8
  9. Tim

    Sano Guest

    In my limited experience, that chipset is shit.

    It got harder and harder to find references to it on the Via site, about a
    year ago. And any reference to it in their forums seems to be absent.

    <insert convenient conspiracy theory here ____________>
     
    Sano, Jan 7, 2004
    #9
  10. Tim

    ICee Guest

    That part is not quirky. ATA-66 and above require a 80 conductor, 40
    pin cable.
     
    ICee, Jan 7, 2004
    #10
  11. Tim

    Tim Guest


    I am inclined to agree on this... can't find any other descent dual
    p3/1ghz boards with 4 DIMMS & RAID though so Abit VP6 it is.


    Found the answer to my problem on the VIA forums though... sort of odd
    that you have to uninstall their driver to fix the bloody problem..
    thats some pretty questionable support :)


    http://forums.viaarena.com/messageview.cfm?catid=6&threadid=45244&FTVAR_MSGDBTABLE=

    1) Goto Device Manager
    2) Double-click on the VIA IDE Controller and choose 'Update Driver'
    3) Choose 'Install from a list or a specific Location'
    4) Choose 'Don't search, I will choose the driver to install'
    5) Choose 'Standard Dual PCI IDE Controller', if not there then back
    to step 3 choose 'Install the software automatically' and then repeat
    steps again from number 1 as it will appear then.
    6) You will after after successfully updating will need to reboot the
    system !
     
    Tim, Jan 7, 2004
    #11
  12. Tim

    Sano Guest

    Thanks. I put *that* mobo in my parents machine. It won't cause anyone any
    problems there. ;)
     
    Sano, Jan 7, 2004
    #12
  13. Tim

    Scotoma Guest

    Hi Tim
    You may want to look here.
    http://www.pureperformance.com/js/showtip.asp?id=23 . I have udma66 enabled
    without this patch in xp but I am only running 1 udma66 (ata100) HD. In
    device manger it is running in ultra dma mode 5 at present. Try forcing it
    with the reg patch as I've read that xp does not always (so it seems :-o)
    enable udma66. (backup reg first!!! edit the reg manually. It will give you
    more bandwidth even if this does not fix your problem.
     
    Scotoma, Jan 7, 2004
    #13
  14. Tim

    Tim Guest


    Hi - thats the first thing I tired but it didn't work for my
    particular situation. Adding the UDMA66 DWORD to the reg will only
    work on the Intel chipsets apparently!
     
    Tim, Jan 7, 2004
    #14
  15. Tim

    Scotoma Guest

    Didn't know that. Cheers :))
    What about the cable like Ralph Wade Phillips suggested or jumper switches
    or bios settings? If you had udma66 running ok before, then maybe the cable
    is at fault. Good luck anyways. :))
     
    Scotoma, Jan 7, 2004
    #15
  16. Howdy!

    As has been pointed out, that's due to the MB not setting above
    ATA-33 on a 40 pin cable.

    I'm anxiously watching - I have one customer with one machine on a
    SiS chipset that runs PIO 4 on a UDMA 4 drive ... with ATA-66 IDE ports.

    RwP
     
    Ralph Wade Phillips, Jan 9, 2004
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.