Problem with Vosonic 2060 X-Drive II

Discussion in 'Hardware' started by michael_95, Aug 13, 2006.

  1. michael_95

    michael_95

    Joined:
    Aug 13, 2006
    Messages:
    2
    Likes Received:
    0
    Hi,

    I'm having some major problems with my x-drive...
    I've stored a whole load of holiday photos on my x-drive, got back home connected it to my PC but my machine doesn't recognize the x drive. Note that the X Drive has previously been connected to this machine on many previous occasions - I have also tried to connect the x drive to two other PCs with no success, all machines run XP professional.

    Seems to be a USB problem on the X-Drive itself as I can smell a faintly burning smell from the USB port, also I got a power surge on USB hub message on one of the connection attempts. I'm pretty confident that the hard drive on the X-Drive is working OK as it goes through the copying process from my memory stick OK, when using a Lexar memory stick I can see the light flashing as the X-Drive accesses the memory stick.

    Can anyone advise me as to the options open to me. Is it possible to remove the hard disk from the X-Drive and if so what can I do to recover the many precious photos I have stored ? I'm trying to contact Vosonic here in the UK but can't find a telephone number on their website.

    Any help would be much appreciated.

    Yours desparately,

    Michael
     
    michael_95, Aug 13, 2006
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.