Problem with small home network.

Discussion in 'Home Networking' started by Flyiñg Ñuñ 2°11 + on desktop, Jun 13, 2011.

  1. Added data. If I ping 192.168.2.1 from Novatech it also times out, so
    Novatech cannot ping it's own ethernet adapter. :(
     
    Flyiñg Ñuñ 2°11 + on desktop, Jul 2, 2011
    #41
    1. Advertisements

  2. Flyiñg Ñuñ 2°11 + on desktop

    James Egan Guest

    This is fine for the wireless adaptor but there is nothing listed for
    the wired adaptor at all. Like it's not there!

    The above is the novatech routing table. The wireless router will have
    its own. You have set that correctly.

    Yes. The novatech wired adaptor is your problem. You may need to
    remove and reinstall it from the device manager.

    When you get it working correctly, the routing table should contain
    all the entries as per your post plus some others relating to network
    192.168.2.0

    It's no doubt the same reason the bridge option failed so after you
    resolve this hardware issue you might want to revert to that simpler
    setup. Your next step is to reinstall and reconfigure the wired
    adaptor so that the machine can ping itself.


    Jim
     
    James Egan, Jul 2, 2011
    #42
    1. Advertisements

  3. That's put me in a bit of a quandary as the wired adapter was integral with
    the Novatech computer when I bought it so I don't have a CD for it, just
    the Novatech restore CD, which I think is just the Windows XP OS, and the
    Mobo Winfast Utility CD. Would the installation software and drivers for
    the adapter be on one of those?
     
    Flyiñg Ñuñ 2°11 + on desktop, Jul 2, 2011
    #43
  4. Try running a program called siw.exe found at:
    http://www.gtopala.com/
    and see if it can identify the make/model of the internal Ethernet
    adapter. The freeware version can be downloaded from the above main
    page using the icon at the lower right of the screen.

    If it does identify the adapter you may be able to go to the original
    manufacturer of that part and download a driver directly from them.
    The adapter(s) can usually be found under the Hardware|Devices|Network
    Adapters section.
     
    GlowingBlueMist, Jul 2, 2011
    #44
  5. Thanks I'll give that a go then. I've managed to overwrite the driver by
    getting Windows to search the Winfast Utility CD from device manager. Yet
    to find check to see if that worked, but if not I'll try out your little
    program.
     
    Flyiñg Ñuñ 2°11 + on desktop, Jul 3, 2011
    #45
  6. Flyiñg Ñuñ 2°11 + on desktop

    James Egan Guest

    I couldn't say for sure but it may be on the utility cd. If you go
    into the device manager and look under network adaptors. Right click
    -> Properties on the wired adaptor and it will tell you what type it
    is and driver details etc. Make a note of all the info, run it through
    google and it should come up with somewhere you can get the latest
    driver or install program. You might even get away with just pointing
    at your windows\system32\drivers directory if it asks you what driver
    to use.

    If you're worried about pressing the delete button on the network
    adaptor in case you can't install it again, post what type it is here
    and we can look into what's required before you zap and reinstall it.


    Jim
     
    James Egan, Jul 3, 2011
    #46
  7. Flyiñg Ñuñ 2°11 + on desktop

    James Egan Guest

    Okay. This has crossed with my other post so you can ignore that.

    If it's not working, delete the network adaptor from the device
    manager and reboot then install the driver again.


    Jim
     
    James Egan, Jul 3, 2011
    #47
  8. Yep I found it, uninstalled then reinstalled the ethernet adapter. I then
    found more up to date drivers on the Internet and installed those.
    Situation now is:

    From Tiny.
    Can successfully ping 192.168.2.1 (Novatech ethernet adapter) but not
    192.168.1.254 (2wire Router), so still cannot access network nor Internet
    from Tiny.

    From Novatech.
    Can successfully ping it's ethernet adapter 192.168.2.1 when Tiny is running
    (but not if Tiny is off), but not Tiny's ethernet adapter (192.168.2.2)

    ipconfig /all does show both adapters 192.168.1.200 and 192.168.2.1

    Internet list (c:\rprint.txt) still doesn't show the route
    192.168.2.0/255.255.255.0 192.168.1.200 although it is still shown in the
    Static Route List in the router.

    Interface List
    0x1 ........................... MS TCP Loopback interface
    0x2 ...00 01 6c a4 9e 56 ...... SiS 900-Based PCI Fast Ethernet Adapter -
    Packet Scheduler Miniport
    0x10004 ...00 27 19 b9 89 91 ...... TL-WN321G USB Wireless Adapter - Packet
    Scheduler Miniport
    ===========================================================================
    ===========================================================================
    Active Routes:
    Network Destination Netmask Gateway Interface Metric
    0.0.0.0 0.0.0.0 192.168.1.254 192.168.1.200 25
    127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
    192.168.1.0 255.255.255.0 192.168.1.200 192.168.1.200 25
    192.168.1.200 255.255.255.255 127.0.0.1 127.0.0.1 25
    192.168.1.255 255.255.255.255 192.168.1.200 192.168.1.200 25
    224.0.0.0 240.0.0.0 192.168.1.200 192.168.1.200 25
    255.255.255.255 255.255.255.255 192.168.1.200 2 1
    255.255.255.255 255.255.255.255 192.168.1.200 192.168.1.200 1
    Default Gateway: 192.168.1.254
    ===========================================================================
    Persistent Routes:
    None

    From 2wire Router:
    Can ping Novatech 192.168.1.200 OK but not Novatech's ethernet adapter
    192.168.2.1 nor Tiny's.

    So it looks like nothing has really been gained by the re-installation of
    the SIS-900 ethernet adapter. Looks to me like it's something in settings
    somewhere in Novatech since Tiny can find Novatech's adapter, Novatech
    finds it's own adapter, router finds Novatech but not Novatech's ethernet
    adapter.
     
    Flyiñg Ñuñ 2°11 + on desktop, Jul 3, 2011
    #48
  9. Flyiñg Ñuñ 2°11 + on desktop

    James Egan Guest

    Yes. it looks like new drivers haven't improved the situation. The key
    pointer is the routing table on the novatech just showing routes for
    the wireless adaptor. While that situation remains it will never work.

    Does the device manager say that this adaptor is enabled and working
    okay? I can't say I've ever come across anything like that before.
    Perhaps there's a hardware fault in which case any amount of fiddling
    isn't going to resolve it.


    Jim.
     
    James Egan, Jul 3, 2011
    #49
  10. Flyiñg Ñuñ 2°11 + on desktop

    James Egan Guest


    I just did a quick test on my xp pc here by enabling the otherwise
    unused wired adaptor and it threw up a similar routing table to yours.

    It was only when I connected something to it (ie similar to your tiny)
    and it reported it as connected that the routes showed up in the
    routing table.

    This is what mine looks like when set up similar to yours with my
    wireless on 192.168.7.0 and the wired on 192.168.2.0

    ===========================================================================
    Interface List
    0x1 ........................... MS TCP Loopback interface
    0x10003 ...00 17 3f 4e 45 d3 ...... Belkin Wireless G USB Network
    Adapter #6 - Packet Scheduler Miniport
    0x10004 ...00 13 20 e5 eb a0 ...... Intel(R) PRO/100 VE Network
    Connection - Packet Scheduler Miniport
    ===========================================================================
    ===========================================================================
    Active Routes:
    Network Destination Netmask Gateway Interface
    Metric
    0.0.0.0 0.0.0.0 192.168.7.1 192.168.7.50
    25
    127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1
    1
    192.168.2.0 255.255.255.0 192.168.2.1 192.168.2.1
    20
    192.168.2.1 255.255.255.255 127.0.0.1 127.0.0.1
    20
    192.168.2.255 255.255.255.255 192.168.2.1 192.168.2.1
    20
    192.168.7.0 255.255.255.0 192.168.7.50 192.168.7.50
    25
    192.168.7.50 255.255.255.255 127.0.0.1 127.0.0.1
    25
    192.168.7.255 255.255.255.255 192.168.7.50 192.168.7.50
    25
    224.0.0.0 240.0.0.0 192.168.2.1 192.168.2.1
    20
    224.0.0.0 240.0.0.0 192.168.7.50 192.168.7.50
    25
    255.255.255.255 255.255.255.255 192.168.2.1 192.168.2.1
    1
    255.255.255.255 255.255.255.255 192.168.7.50 192.168.7.50
    1
    Default Gateway: 192.168.7.1
    ===========================================================================
    Persistent Routes:
    None

    Therefore you need to ensure that your tiny machine is connected up
    and on otherwise you might resolve the issue and not even realise it.

    Looking back to your first post, you had the tiny and novatech file
    sharing okay so there really shouldn't be a problem with it now if you
    set the static addresses on the same subnet as per my earlier email.

    I'm starting to think misbehaving firewalls and when that happens
    temporarily disabling them doesn't always do the biz. Only if you
    uninstall them can you be sure that zonealarm isn't the cause of all
    your problems.

    You wouldn't be the first if you did that and suddenly everything came
    to life.


    Jim
     
    James Egan, Jul 3, 2011
    #50
  11. Yep Device Manager says it's both enabled and working properly.
     
    Flyiñg Ñuñ 2°11 + on desktop, Jul 3, 2011
    #51
  12. Looks like you could be on to something there Jim. I'd forgotten firewalls
    completely. So I've just gone into ZA on both Novatech and Tiny and added
    the IP Addresses 192.168.2.0, 192.168.2.1 and 192.168.2.2 to the firewall
    Trusted Zone and immediately was able to see Novatech from Tiny again, but
    not, unfortunately, Advent. Neither could I access the router or Internet
    from Tiny or Tiny from Novatech or Advent. Advent and Router could not
    ping Novatech etrhernet wired adapter or Tiny's wired ethernet adapter
    either. So I suppose next step is to uninstall ZA on each and see if that
    improves matters Fortunately I have the latest ZA software store in my
    downloads folder, so can reinstal them from their. The 2wire 2700HGV
    router also has a firewall, but I was thinking that it couldn't be part of
    the problem, or could it? Mind you I can't seem to find a way of
    switching it off anyway.

    Before doing that though I will just reboot both Novatech and Tiny on the
    offchance - - - - - you know what I mean! :)
     
    Flyiñg Ñuñ 2°11 + on desktop, Jul 4, 2011
    #52
  13. Well that didn't work. I unistalled ZA on both Novatech and Tiny and the
    state of play remained unchanged. Have reinstalled ZA without any change.
    Strangely, before uninstalling ZA i checked to see if I could ping the
    Novatech wifi adapter (192.168.1.200) from Tiny and yes I could do that. Je
    ne comprend. :(
     
    Flyiñg Ñuñ 2°11 + on desktop, Jul 4, 2011
    #53
  14. Flyiñg Ñuñ 2°11 + on desktop

    James Egan Guest

    What does the novatech routing table look like when the novatech and
    tiny are connected with zonealarm off?

    Is the IPEnableRouter registry value still set to 1?
    So you can access the novatech from tiny but not the other way round.
    That has all the hallmarks of a firewall issue and is likely the
    reason why the 192.168.2.0 routes aren't there.
    Presumably no other "security" software is installed and the windows
    firewalls are all off?


    Jim
     
    James Egan, Jul 4, 2011
    #54
  15. Flyiñg Ñuñ 2°11 + on desktop

    James Egan Guest

    Perhaps the tiny firewall is blocking incoming connections. Although
    you've tried uninstalling them you will still be advised to leave the
    firewalls off until you solve your problem. Everything is behind a nat
    device anyway so the firewalls are only of limited usefulness.



    Jim
     
    James Egan, Jul 4, 2011
    #55
  16. Yes, here's a screen print taken at 09:38 this morning
    http://www.flyingnun.co.uk/IPEnableRouter040611.jpg
    I have Trojan Hunter guard enabled and Avast real time shield too, but I
    wouldn't have thought they would block it. They didn't in the past before I
    re-installed XP on Novatech.
     
    Flyiñg Ñuñ 2°11 + on desktop, Jul 4, 2011
    #56
  17. Any idea what though? I'm completely confuddled.
     
    Flyiñg Ñuñ 2°11 + on desktop, Jul 5, 2011
    #57
  18. It definitely appears to be something that is preventing setting up the
    route between the Novatech IP Address (192.168.1.200) and it's wired
    Ethernet adapter IP Address (192.168.2.1) since:

    1 Both Advent (Netbook) , through wifi and Tiny, through the crossover
    ethernet lead can ping 192.168.1.200 successfully.

    2 Advent cannot ping the Novatech ethernet adapter (192.168.2.1) through
    wifi.

    3 Tiny can ping the Novatech wired ethernet adapter (192.168.2.1) through
    the crossover ethernet lead.

    4 Broadband isn't being connected between Novatech (192.168.1.200) and it's
    ethernet adapter (192.168.2.1)

    5 This is more confusing as Novatech (192.168.1.200) successfully pings it's
    ethernet adapter (19..168.2.1)

    What could cause this I have no idea, but it shouldn't be ZA firewall on
    Novatech or Tiny since Tiny can see Novatech and share data and copy it from
    Novatech, but could it be that there is some simple procedure that we may
    have overlooked when attempting to set up the static route in the 2wire
    2700HGV router. Here is a screenprint of the relevant router page as it is
    now.
    http://www.flyingnun.co.uk/staticroutelist050711.jpg
    Is there anything there that shouldn't be or anything missing that should be
    there?
     
    Flyiñg Ñuñ 2°11 + on desktop, Jul 5, 2011
    #58
  19. Flyiñg Ñuñ 2°11 + on desktop

    Rob Guest

    How about removing all software that has any firewall
    capabilities of its own, then (temporarily) disabling
    Windows firewall.
    As long as you are sitting behind a modem/router with NAT,
    you are pretty safe, as least for testing purposes.
    If you can't get it working like that, I would suggest
    that something is badly screwed in the OS. If you have
    a spare HD, you could test that theory by swapping it
    with the HD in the problem machine and doing a fresh
    basic test installation to it.
    HTH,
     
    Rob, Jul 5, 2011
    #59
  20. Flyiñg Ñuñ 2°11 + on desktop

    James Egan Guest

    There's nothing wrong with the wireless network. Everything is
    completely as expected on all machines including the novatech. The
    problem is the wired connection between the novatech and the tiny. The
    novatech won't show anything in its routing table until it accepts
    that there is a valid network there (which it doesn't). It is behaving
    like the network adaptor is enabled but with the cable unplugged.
    Clearly this isn't the case because the tiny accepts there is a valid
    192.168.2.0 network there (which there is). Whether this is a cable
    problem or a network adaptor problem or a firewall problem, I couldn't
    say.
    Everything is completely okay with your wireless setup. The route is
    in place to make everything work if and when you resolve the wired
    problem and it won't get in the way of anything else if you leave it
    there.

    Back the the actual problem, some network adaptors can autosense which
    wires are set to transmit and receive and other can't. Maybe the cable
    needs swapping around. Maybe try a different cable.

    All will be resolved if 192.168.2.1 can ping 192.168.2.2 *and*
    192.168.2.2 can ping 192.168.2.1

    If after swapping cables, reinstalling adaptors, disabling firewalls
    etc on the novatech and tiny you still can't do both the above then
    it's time to move on.

    My advice in that circumstance would be to get an old wireless router
    on ebay for <£10 which is re-configurable with dd-wrt firmware and set
    it up in client bridge mode which will effectively give the tiny its
    own wireless connection independent of the novatech.
    http://www.dd-wrt.com/site/support/router-database


    Jim
     
    James Egan, Jul 5, 2011
    #60
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.