Problem with small home network.

Discussion in 'Home Networking' started by Flyiñg Ñuñ 2°11 + on desktop, Jun 13, 2011.

  1. My network consists of a 2wire 2700HGV router which provides wifi
    connections to an Advent Netbook and a 5 year old Novatech desktop through
    an attached wifi dongle. Both these computers are running Windows XP Home
    Edition Service pack 3. A third archaic Tiny desktop (circa 1998) and
    running Windows 98 is connected to the Novatech by a crossover ethernet lead
    as 98 can't run a wifi system and I, for a variety of reasons, want to
    continue with 98 on that computer. Up to just over a week ago all were
    running fine with both file sharing between any two and also all sharing the
    printer which is connected to the Novatech desktop through the parallel
    port. Then for some reason both netbook and the Novatech crashed within an
    hour. I managed to recover the netbook - don't ask me how - but not the
    Novatech. So I had to format and reinstall Windows XP on the Novatech. I
    have struggled for several days to get the network working again and am
    almost there by having restored file sharing between netbook and the
    Novatech, and Novatech to the Tiny. Unfortunately I cannot share files
    between the netbook and the Tiny and the Tiny won't activate the printer.
    Also, although file sharing between the Novatech and Tiny has been restored
    the Tiny can't connect to the internet. Anyone any ideas how I can restore
    file sharing between the netbook and the Tiny and restore the Tiny to
    connect with the net. I presume that if I can restore the connection to the
    2700HGV from the Tiny that will automatically restore file sharing between
    netbook and Tiny. Anyone any ideas? I'm sure that it must simply be some
    settings that aren't correct, but what and where will I find them. All 3
    computers are running Zone Alarm firewalls.
     
    Flyiñg Ñuñ 2°11 + on desktop, Jun 13, 2011
    #1
    1. Advertisements

  2. Flyiñg Ñuñ 2°11 + on desktop

    Dave Saville Guest

    On Mon, 13 Jun 2011 22:49:13 UTC, "Flyiñg uñ 2°11 + on desktop"

    <snip>

    You did turn on "share my internet connection" or whatever it's called
    on the Novatech? Presumably the tiny gets to the rest of the world
    through the XP box.
     
    Dave Saville, Jun 14, 2011
    #2
    1. Advertisements

  3. Where abouts is the "share my internet connection" option in XP David. I
    couldn't find it, and yes the Tiny did see the rest of the world through
    the Novatech desktop.
     
    Flyiñg Ñuñ 2°11 + on desktop, Jun 14, 2011
    #3
  4. Flyiñg Ñuñ 2°11 + on desktop

    Howard Neil Guest

    Open Windows Explorer (windows key + "E"), right click on a disk and
    select properties. Click on the "sharing" tab.
     
    Howard Neil, Jun 14, 2011
    #4
  5. Flyiñg Ñuñ 2°11 + on desktop

    Jeff Gaines Guest

    That's sharing a disk, not sharing an Internet connection.
     
    Jeff Gaines, Jun 14, 2011
    #5
  6. Flyiñg Ñuñ 2°11 + on desktop

    PeeGee Guest

    IIRC, XP uses ICS to provide the service (run Help & Support and search
    for ICS). That will provide the "loop through" and DHCP for the Tiny.

    HTH

    --
    PeeGee

    "Nothing should be able to load itself onto a computer without the
    knowledge or consent of the computer user. Software should also be able
    to be removed from a computer easily."
    Peter Cullen, Microsoft Chief Privacy Strategist (Computing 18 Aug 05)
     
    PeeGee, Jun 14, 2011
    #6
  7. Flyiñg Ñuñ 2°11 + on desktop

    Rob Morley Guest

    And binds the DHCP server on the XP host to 192.168.0.1 even if you
    change the host address after installing ICS, which can cause some
    confusion. :-\
     
    Rob Morley, Jun 14, 2011
    #7
  8. Yep! I just spotted that too Jeff.
     
    Flyiñg Ñuñ 2°11 + on desktop, Jun 15, 2011
    #8
  9. That sounds confusing in itself to me Rob. :(
     
    Flyiñg Ñuñ 2°11 + on netbook, Jun 15, 2011
    #9
  10. I found that eventually Dave. R Click on the wireless network icon in
    Network Connections - then advanced tab, but it didn't help. So I set up
    a network bridge between the wireless connection and wireless connection
    and although the network bridge icon in the systray reports it is connected
    at a speed of 100.oMbps I still can't get the Internet and have lost the
    file sharing as well. I'm totally clueless about what to try next.
     
    Flyiñg Ñuñ 2°11 + on netbook, Jun 15, 2011
    #10
  11. Flyiñg Ñuñ 2°11 + on desktop

    Glyn Morgan Guest


    Probably a long shot but I had a problem with bridging wireless to wired
    network connections which turned out to be my firewall. I was using the free
    version of the Sunbelt firewall (a long time ago called kerio). It turned
    out that this was blocking network sharing unless you had the
    payed-for-version.

    Glyn
     
    Glyn Morgan, Jun 18, 2011
    #11
  12. I won't connect with the firewall disable either Glyn, so Isuspect it isn't
    that.
     
    Flyiñg Ñuñ 2°11 + on netbook, Jun 18, 2011
    #12
  13. Flyiñg Ñuñ 2°11 + on desktop

    James Egan Guest

    Most of the replies to this post are about ICS from the novatech box
    but if the above statement is correct then you weren't running ICS
    because there could never be a path to share the Tiny's files from the
    wireless laptop.

    The bridge option you mentioned is probably the best bet. In that
    scenario you would normally set the tiny to receive an ip address
    automatically (from the router) and the novatech would automatically
    deal with the communication between wired and wireless.

    The only other alternative to bridging is to configure the novatech
    box with routing enabled and set one or two static routes.

    To enable routing in winxp/2k/NT/Vista you need to edit the registry
    as follows :-

    System Key:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
    Value Name: IPEnableRouter
    Data Type: REG_DWORD (DWORD Value)
    Value Data: (0 = disabled, 1 = enabled)

    Having done that you will need to put the tiny and the wired interface
    of the novatech onto a different subnet from all the wireless devices

    As an example, if the router is on 192.168.2.1/24 give the novatech
    wireless a static address of (say) 192.168.2.50/24 so it doesn't
    conflict with the router's dhcp pool then give the novatech wired a
    static address of 192.168.3.1/24 and the tiny a static address of
    192.168.3.2/24 all with the router's address or something external for
    nameserver (eg google 8.8.8.8).

    The last thing to do is to set a static route on the router to send
    all traffic destined for subnet 192.168.3.0/24 via the novatech box at
    192.168.2.50

    (note: replace the /24's above with 255.255.255.0 where appropriate)



    Jim
     
    James Egan, Jun 28, 2011
    #13
  14. Flyiñg Ñuñ 2°11 + on desktop

    James Egan Guest

    I forgot to mention. you need to ensure Internet Connection Sharing is
    switched OFF.


    Jim
     
    James Egan, Jun 28, 2011
    #14
  15. Flyiñg Ñuñ 2°11 + on desktop

    James Egan Guest

    Also forgot to say that the default gateway for the tiny needs to be
    192.168.3.1/24 with 192.168.2.1/24 as default gateway for everything
    else.


    Jim
     
    James Egan, Jun 28, 2011
    #15
  16. I have been continuing to find a solution James, and as I find your
    solution below a little difficult to follow, I have persevered with the
    network bridge path. I tried setting the Tiny to find an IP address
    automatically (but don't follow your 'from the router' description). When
    set like this the Tiny was being assigned the same IP address as the Network
    bridge (192.168.1.66, subnet mask 255.255.255.0) so giving a conflict. So
    I set the Tiny addy to 192.168.1.200. Now I can see and share with all the
    Novatech and Advent folders I have given permission to share, on Tiny but
    cannot see any of the permitted Tiny folders on Novatech or Advent. Also I
    still don't have an Internet connection on Tiny through the ethernet
    connection. I have seen some comments in forums of people having trouble
    viewing files and folders from XP machines on W98 machines but not vice
    versa, so suspect that I cannot be far away from setting that up.

    I'm afraid that setting up procedure may be a little beyond my capabilities
    Jim, I really am a numpty where this kind of stuff is concerned. This,
    and the fact I had the network working using a bridge before are my reasons
    for trying to stick with the bridge path towards a solution.
     
    Flyiñg Ñuñ 2°11 + on desktop, Jun 29, 2011
    #16
  17. Where exactly do I find that option, Jim?
     
    Flyiñg Ñuñ 2°11 + on desktop, Jun 29, 2011
    #17
  18. Just curious, as at the moment I am still pursuing the bridge path to
    finding a solution, but when you are quoting an address as 192.168.2.1/24
    what does the 24 stand for? All I could think of was you meant a range of
    addies between 192.168.2.1 to 192.168.2.24. And why do you state 2 as the
    3rd number in the IP address of the router and Novatech wifi and yet change
    to 3 for the 3rd number in the addresses of the default gateways?
     
    Flyiñg Ñuñ 2°11 + on desktop, Jun 29, 2011
    #18
  19. Flyiñg Ñuñ 2°11 + on desktop

    James Egan Guest

    Yes, that's the best and simplest option.
    When it's working correctly, it will be the router which allocates an
    ip address to the Tiny.
    Remove the bridge, change all the adaptors and also the Tiny back to
    receive an ip address automatically (their default configuration).
    Then reinstate the bridge. Then give the bridge (not the individual
    adaptors!) a static ip address outside the range of the dhcp pool
    used by the router. 192.168.1.200 is probably a good one.

    Then reboot the novatech and the tiny for good measure. When the tiny
    restarts it will look to be assigned an ip address, the novatech will
    forward the request onto the wireless router and the router should
    respond with an ip address out of its pool along with dns inforation.

    That should be it.


    Jim
     
    James Egan, Jun 29, 2011
    #19
  20. Flyiñg Ñuñ 2°11 + on desktop

    James Egan Guest

    Don't worry about that. It's off already otherwise it would have
    screwed up your ip addressing scheme with its own.


    Jim
     
    James Egan, Jun 29, 2011
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.