Problem with Qos and opening sites

Discussion in 'Cisco' started by rzirzi, Feb 23, 2006.

  1. rzirzi

    rzirzi Guest

    I have C1721 i my small LAN (10 users).
    Configuration is on bottom this message.
    I have two different problems:
    - one is www sites opening, i mean that some sites
    are not opening normally, but very slowly or none.
    I don't know why? many other sites are opening
    normally in web browser. One of the sites that
    is not opening is: www.kolo.com.pl
    Why many sites opening normally, but some not?
    - second problem is with QoS, exactly with PQ
    The PQ is not working, there is no packets in queues
    when i checking interface statistics - why?

    Best regards
    rzirzi
    ------------------------------------------------------
    Configuration

    Router#sh run
    Building configuration...

    Current configuration : 2553 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    enable password ***
    !
    no aaa new-model
    !
    resource policy
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip subnet-zero
    ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.10
    !
    ip dhcp pool LAN
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.10
    dns-server 192.168.1.10
    !
    ip dhcp pool MYPOOL
    host 192.168.1.130 255.255.255.0
    client-identifier 0100.065b.***
    default-router 192.168.1.10
    dns-server 192.168.1.10
    !
    !
    ip name-server 194.204.159.1
    ip name-server 194.204.152.34
    !

    !
    interface Ethernet0
    no ip address
    half-duplex
    pppoe enable
    pppoe-client dial-pool-number 1
    !
    interface FastEthernet0
    ip address 192.168.1.10 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    speed auto
    !
    interface Dialer1
    bandwidth 640
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    priority-group 10
    ppp authentication chap callin
    ppp chap hostname ***
    ppp chap password ***
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    !
    !
    no ip http server
    no ip http secure-server
    ip nat inside source list 1 interface Dialer1 overload
    ip dns server
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 100 permit udp any any range 16384 16482
    access-list 100 permit tcp any any eq www
    access-list 100 permit tcp any any eq 443
    access-list 100 permit icmp any any
    access-list 100 permit tcp any any eq 22
    access-list 100 permit tcp any any eq telnet
    access-list 100 permit udp any any eq domain
    access-list 110 permit tcp any any eq smtp
    access-list 110 permit tcp any any eq pop3
    access-list 110 permit tcp any any eq 143
    access-list 120 permit tcp any any eq ftp
    access-list 120 permit tcp any any eq ftp-data
    dialer-list 1 protocol ip permit
    priority-list 10 protocol ip high list 100
    priority-list 10 protocol ip medium list 110
    priority-list 10 protocol ip normal list 120
    priority-list 10 default low
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    end

    Router#
     
    rzirzi, Feb 23, 2006
    #1
    1. Advertisements

  2. rzirzi

    Charlie Root Guest

    Your configuration doesn't show ATM PVC part (encapsulation type if of main
    concern here), class-map and policy-map definitions and do you apply them
    to the interface.

    What it looks like to me is Path-MTU Discovery problem. If you're running
    PPPoE, your WAN MTU is probably 1492, but not specified. Web packets are
    often 1500 bytes with DF-bit set. Try following line on Dialer interface:

    int Dialer1
    mtu 1492

    and also put following on the LAN interface:

    int FastEthernet0
    ip tcp adjust-mss 1460

    This should resolve problem with opening websites. As for PQ - please show
    complete config.

    Kind regards,
    iLya
     
    Charlie Root, Feb 27, 2006
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.