Problem when I will delete a specific key in Windows registry database

Discussion in 'Windows 64bit' started by Anders Boholdt-Petersen, Nov 26, 2010.

  1. Hi,

    I have a very frustrated problem when I tried to delete a specific key in
    the Windows registry Database (I using Windows 7 64-bit).

    First, I run the regedit.exe as administrator (I search after the program
    from the start menu, right click on it and select "run as administrator".

    After that I find the following key I will delete:

    When I wright click on the key I entered above and select "permissions", I
    can not change the permissions to full control so I could delete the key.

    Have other persons in this newsgroup a solution to how I can change the

    Very thanks for the help!

    / Anders
    Anders Boholdt-Petersen, Nov 26, 2010
    1. Advertisements

  2. Anders Boholdt-Petersen

    Carlos Guest

    Once you have clicked on permissions, click on advanced options, go to
    the owner tab and choose yourself as the owner.
    Then click Accept two times.
    Right click on the registry key again, click on permissions and now
    set your rights in the Security tab.
    Carlos, Nov 26, 2010
    1. Advertisements

  3. ---

    Very thanks for your answer.

    Now I have tried to follow the instruction, but unfortunately, I can still
    not delete the key!

    When I tried to delete the key, Windows say that a error has occured under
    deleting of the key.

    I will be very happy if other persons have solutions I can tried so I can
    delete the key!

    Thanks for the help.

    / Anders
    Anders Boholdt-Petersen, Nov 26, 2010
  4. Anders Boholdt-Petersen

    VanguardLH Guest

    If you actually logon under an admin-level account can you then edit
    permissions and delete that registry key?

    When changing permissions, did you go to the Advanced tab and disable
    inheritence from the parent key and enable replacement of your new
    permissions on the child objects?

    Why are you trying to delete the device enumerations listed under the
    backup ControlSet001? It may NOT be your current control set when you
    last booted. You could be editing the wrong one. Did you check which
    is the current one by looking at HKLM\SYSTEM\Select? Why aren't you
    editing those under the currently employed settings in
    "Multiple control sets (typically two) are kept, in the event that the
    settings contained in the currently-used one prohibit the system from
    booting. HKLM\SYSTEM contains control sets labeled ControlSet001,
    ControlSet002, etc., as well as CurrentControlSet. During regular
    operation, Windows uses CurrentControlSet to read and write information.
    CurrentControlSet is a reference to one of the control sets stored in
    the registry."
    VanguardLH, Nov 26, 2010
  5. Now I manually have deleted all subkeys under the first key in the registry
    database I send in the first message.

    First I set the permissions for all subkeys via the describtion from this
    newsgroup, and after that, I could delete first the subkeys, and after that
    the first key I asking about.

    After I have set the permissions, I should set the owner to my self for the
    subkeys before I could delete the keys.
    Very thanks for the links where I can read more about the control sets in
    Windows registry database. I will take a look on the describtions as soon as

    / Anders
    Anders Boholdt-Petersen, Nov 28, 2010
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.