Problem Daisy-Chaining 2950 Using Copper Giga

Discussion in 'Cisco' started by Aharon Schkolnik, Sep 22, 2005.

  1. Hi.

    I am having weird problems when I connect together three Catalyst 2950
    switches. I want to use the two gigaethernet interfaces on the middle
    switch to connect to two other 2950's using switchport mode trunk for VLAN
    support. Whenever I do this I see CRC errors on the gigaethernet ports
    (not a lot - about 1 error in 1000 packets). Also when I ping from a
    machine on one switch to a machine on another switch I see a few percent
    packet loss. It is not possible to sustain a remote desktop (terminal
    services) connection from one switch to another. In addition I see an
    extremely high number of input errors on the VLAN1 interface of the
    switches (for example -232203 packets input, 60958 input errors).

    The cables I am using were manufactured by a very respected company, and I
    have swapped cables multiple times. I have also completely
    switched the middle switch. I have tried various combinations of
    speed and duplex. Nothing helps.

    Any ideas, anyone ???

    TIA.


    Here is a slightly edited version of my configurations:


    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname MiddleSwitch
    !
    !
    ip subnet-zero
    !
    vtp mode transparent
    !
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    !
    !
    !
    !
    vlan 2-3,11,301,901
    !
    interface FastEthernet0/1
    switchport mode trunk
    speed 100
    duplex full
    !
    interface FastEthernet0/2
    switchport mode trunk
    speed 100
    duplex full
    !
    interface FastEthernet0/3
    switchport access vlan 3
    spanning-tree portfast


    interface GigabitEthernet0/1
    switchport mode trunk
    !
    interface GigabitEthernet0/2
    switchport mode trunk
    load-interval 30
    speed 1000
    duplex full
    !
    interface Vlan1
    ip address 172.16.253.1 255.255.0.0
    no ip route-cache
    !
    ip default-gateway 172.16.0.1
    ip http server
    !
    !
    end


    ===================================================================

    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname LowerSwitch
    !
    !
    ip subnet-zero
    !
    vtp mode transparent
    !
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    !
    !

    ! Vlan 3 is for external IPs

    vlan 3

    !
    !
    interface FastEthernet0/1
    spanning-tree portfast
    speed 100
    duplex full
    !
    !
    interface FastEthernet0/23
    switchport access vlan 3
    spanning-tree portfast
    speed 100
    duplex full
    !
    interface FastEthernet0/24
    switchport access vlan 3
    spanning-tree portfast
    speed 100
    duplex full
    !
    interface GigabitEthernet0/1
    switchport mode trunk
    !
    interface GigabitEthernet0/2
    !
    interface Vlan1
    ip address 172.16.253.5 255.255.0.0
    no ip route-cache
    !
    ip http server
    !
     
    Aharon Schkolnik, Sep 22, 2005
    #1
    1. Advertisements

  2. Aharon Schkolnik

    Merv Guest

    1. What IOS version(s) are running on the 2950 switches, please post
    show version ffor each of the three switches.

    2. How have you cabled the switch ports together. Indicate switch # and
    port nos that are connected together.
     
    Merv, Sep 22, 2005
    #2
    1. Advertisements

  3. Aharon Schkolnik

    Merv Guest

    also post show interface for each of the giga port that are calbed
    together.

    What are the colours of the giga port LEDS?
     
    Merv, Sep 22, 2005
    #3
  4. Aharon Schkolnik

    Fred Rabouw Guest

    Did you check the speed and duplex settings of the running ports.
    Not those of the config file, but the real status.
    My first thing to check would be to see whether one port came up in
    duplex and the other in half duplex or so.
     
    Fred Rabouw, Sep 23, 2005
    #4
  5. Aharon Schkolnik

    Sam Wilson Guest

    My experience if GigE is that it's difficult to make that happen.
    Negotiation is mandated; if you turn it off at one end the port that is
    trying to negotiate won't come up; if you turn it off at both ends you
    can cause a duplex problem, but why would you bother?

    Sam
     
    Sam Wilson, Sep 23, 2005
    #5
  6. Good idea, but no, both sides are reporting:

    Full-duplex, 1000Mb/s, media type is RJ45
     
    Aharon Schkolnik, Sep 25, 2005
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.