Problem connecting wif'd computer to non-wifi'd computer.

Discussion in 'Home Networking' started by Flyiñg Ñuñ 2°10 + on netbook, Jan 31, 2010.

  1. I found it and disabled it on the XP desktop computer, but seem to have
    lost the communication between desktops now. Will have to investigate
    further. Incidentally I can't find ICS on the W98 computer anywhere.
     
    Flyiñg Ñuñ 2°10 +, Feb 6, 2010
    #21
    1. Advertisements

  2. Flyiñg Ñuñ 2°10 + on netbook

    Rob Morley Guest

    You won't - it hadn't been invented then.
     
    Rob Morley, Feb 6, 2010
    #22
    1. Advertisements

  3. Flyiñg Ñuñ 2°10 + on netbook

    Rob Morley Guest

    That's because you removed its bridge to the network.
    It sounds to me that you really need to start over with a clean setup -
    from what I gather from skimming this thread the individual bits are
    working but you're not putting them together properly.
     
    Rob Morley, Feb 6, 2010
    #23
  4. Flyiñg Ñuñ 2°10 + on netbook

    James Egan Guest

    That explains a few things. Your best bet will be to disable ics and
    try to re-establish the bridge. It is probable that ics was causing
    the problem with the bridge in the first place.

    And they never will fully with the ics enabled and no bridge option.
    You can get a one way connection win98->notebook but not the other way
    round. Connections instigated by the notebook towards the win98 will
    always fail because the notebook can't traverse the xp desktop
    operating as a nat device. Also there is the added problem of two dhcp
    servers which can cause unexpected problems.

    iirc win98 didn't have ics until later editions so that could be why
    you can't find it.

    The optimum solution is actually the easiest to set up. Ensure all
    network interfaces on all the pc's have ics disabled and are set to
    receive an ip address automatically then establish a bridge between
    the wired and wireless on the xp desktop. That's all there is to it.


    Jim.
     
    James Egan, Feb 6, 2010
    #24
  5. Thanks Rob, I did wonder. :)
     
    Flyiñg Ñuñ 2°10 + on netbook, Feb 6, 2010
    #25
  6. Nope. I removed the network bridge about a week ago and had managed to get
    the two desktops transferring data and both connecting to the internet using
    a crossover ethernet lead between them and just the wifi dongle on the XP
    desktop. The W98 m/c also saw the wifi router and I could view it's data
    pages on the W98 pooter.
     
    Flyiñg Ñuñ 2°10 + on netbook, Feb 6, 2010
    #26
  7. But if I do that would I be able to connect the W98 to the internet through
    the ethernet lead and XP pooter's wifi dongle? Looks like I stillhave a lot
    of playing to do
     
    Flyiñg Ñuñ 2°10 + on netbook, Feb 6, 2010
    #27
  8. Flyiñg Ñuñ 2°10 + on netbook

    James Egan Guest

    Yes. That's what the bridge is for. Everything would be able to
    connect with everything else on the network and the Internet too. All
    controlled by the router.

    This will help you understand the bridging option
    http://technet.microsoft.com/en-us/library/bb457038.aspx


    Jim.
     
    James Egan, Feb 6, 2010
    #28
  9. I understand what you are saying Jim and have scanned the microsoft page you
    posted. Tried again yesterday evening again and set up a network bridge
    between the wifi dongle and the ethernet adapter on the XP desktop after
    setting the W98 desktop IP address and it's gateway manually so they were in
    the same 192.168.1.1 to 192.168.1.254 range. Still wouldn't talk to each
    other or connect to the Internet. So dismantled the bridge and left all the
    addresses as before. The XP desktop and W98 desktop were then talking but I
    couldn't get out to the internet through the wifi at all from either
    machine. All the signs said that it was connected but couldn't even ping
    the wifi router 192.168.1.254 - kept getting time outs. Then I discovered
    that if I disabled the ethernet adapter on the XP desktop then connection to
    router was restored. So it appears that having a connection to the W98
    desktop is some how preventing connection to the router. Obviously I have
    no idea why. Any ideas anyone?
     
    Flyiñg Ñuñ 2°10 +, Feb 7, 2010
    #29
  10. Flyiñg Ñuñ 2°10 + on netbook

    James Egan Guest


    You need to remove all traces of static ip addressing from all pc's
    and set everything to receive an ip address automatically. Note that
    this automatic addressing (by dhcp) does more than just dish out ip
    addresses. All the dns and gateway information is shared out too so if
    you persist with static addressing you need to manually enter
    nameservers and gateways.

    I am assuming the router's dhcp server is on and is dishing out ip
    addresses. You can check this by ensuring the laptop is set to receive
    an ip address automatically and seeing what address has been assigned.
    If anything fails to receive an ip address from the router it will
    assign itself an address in the range 169.254.0.0/16 which will
    indicate that there's a problem.

    Next step is to do the same with the xp desktop wireless adaptor.
    Don't bother with anything else until this too gets an ip address
    assigned in the range 192.168.1.0/24 from the router

    After this has been accomplished create a bridge between the wired and
    wireless on the xp desktop then reboot the win98 box and it too should
    now receive an ip address from the router.

    Report back what addresses are assigned.



    Jim.
     
    James Egan, Feb 7, 2010
    #30
  11. Before doing all that again, there is one comment I'd like to mention. Re:
    the behaviour of the wifi connection. I have been referred to this
    http://www.microsoft.com/windowsxp/using/networking/expert/crawford_02april22.mspx .
    do you not think that the comments in here may be pointing to something on
    my system that may have been contibuting to all the conflicting results I
    have been getting. ie. the bridge may not work with a nonipromiscuous mode
    network adapter (my wifi dongle)? What are your thoughts about following
    the advice given to set the wireless adapter to 'ForceCompatibilityMode?

    To try and clarify a potted history so far.
    Yes my router's dchp server is on as the following addresses were assigned
    by it when I had the XP Desktop, W98 Desktop and XP netbook (at one stage)
    connected to it by straight ethernet leads.
    2wire 2700HGV 192.168.1.254
    XP Desktop 192.168.1.64
    W98 Desktop 192.168.1.65
    XP netbook 192.168.1.67

    When I added the wifi dongle to the XP Desktop it was assigned 192.168.1.66
    and the
    XPnetbook on wifi was assigned 192.168.1.68

    When I later moved the 2wire 2700HGV downstairs to be sited next to the main
    'phone socket and connected the two desktops together with a crossover
    ethernet lead, the W98 Deskytop was assigned 192.168.0.147 and the
    'gateway' (presumably the ethernet adapter on the XPDesktop) was assigned
    192.168.0.1. With that arrangement both desktops were communicating with
    each other and would both connect to the Internet as long as the Internet
    Zone security on their installed ZA firewalls was set to Medium. The
    XPDesktop and XPnetbook would also communicate with each other - through
    wifi, but XPnetbook and W98Desktop would not. What I am ultimately trying
    to achieve is all three computers communicating with each other. Since
    trying to do this by using a network bridge on the XPDesktop then the
    problem with the wifi connection from XPDesktop to 2wire 2700HGV only
    functioning if the network adapter is disabled or W98Desktop switched off
    has appeared.
     
    Flyiñg Ñuñ 2°10 +, Feb 7, 2010
    #31
  12. Follow up.
    Looks like I'm there, but not exactly what you advised. After setting all
    pcs to receive an ip address automatically then setting up the bridge on the
    XPDesktop, the assigned addresses were, netbook(wifi) 192.168.1.68,
    XPDesktop (wifi) 192.168.1.66, W98 192.168.0.147 and gateway (presumably
    XPDesktop's ethernet adapter) 192.168.0.1 . The W98Desktop could still not
    communicate to either other computer. I thought if I rebooted both desktops
    then perhaps some helpful reconfiguration would help. I made sure that the
    XPDesktop and it's wifi adapter were fully operational before booting up the
    W98Desktop. During this boot up I got the error message "The following
    error has occurred while loading protocol number 0. Error 59. A network
    error has occurred" Clicking on the OK button got me through to the login
    page etc. When I checked ipconfig all addresses were 0.0.0.0. I then
    manually set up the ip address from the W98Desktop giving it the address
    192.168.1.200 and assigning the router address (192.168.1.254) as gateway.
    This has worked and I not have Internet access on all m/cs and data can be
    transferred between them all. So I think I will now leave well alone. Many
    thanks for all your help. Hopefully next time I boot up nothing will have
    changed.
     
    Flyiñg Ñuñ 2°10 +, Feb 7, 2010
    #32
  13. Flyiñg Ñuñ 2°10 + on netbook

    James Egan Guest

    I don't know if this is your problem or not but I do know from
    feedback that windows bridging is quite temperamental and doesn't
    always work as anticipated. For anyone in this predicament the
    alternative routing option is the way to go. I did post some details
    of this earlier in the thread and that is what I'd advise you to do.
    It appears complicated at first glance but it isn't. The only thing
    which might be new to you is setting up a static route in your router
    and maybe editing the registry.
    That's an address assigned by the xp desktop running with ics enabled.

    That's the ics server address which xindows gives itself when ics is
    enabled. It can't be changed to another address.
    The win98 would be able to access the XPnetbook but it's impossible
    the other way round.
    If you have two network adaptors on the same subnet (which you do
    currently on the xp desktop) then windows will always use the wired
    adaptor in preference to the wireless unless you manually change the
    metric settings in the tcp/ip properties. Disabling the wired adaptor
    (or switching off the connected win98 box) would then cause the
    wireless adaptor to work. This is what you're seeing.

    Your best bet as I said earlier is routing. Here's how to set up your
    computers AFTER disabling ics

    2wire dsl gateway at 192.168.1.254

    set a static route to send traffic for subnet 192.168.5.0 to go via
    192.168.1.2


    xpdesktop_wireless

    static ip address 192.168.1.2 mask 255.255.255.0
    default gateway 192.168.1.254
    dns server 192.168.1.254 or your isp's nameserver address


    xpdesktop_wired

    static ip address 192.168.5.1 mask 255.255.255.0
    default gateway leave blank


    98desktop_wired

    static ip address 192.168.5.2 mask 255.255.255.0
    default gateway 192.168.5.1
    dns server 192.168.1.254 or your isp's nameserver address


    You also need to edit the xpdesktop registry to enable routing between
    the wired and wireless interfaces as follows

    System Key:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
    Value Name: IPEnableRouter
    Data Type: REG_DWORD (DWORD Value)
    Value Data: (0 = disabled, 1 = enabled)


    Jim.
     
    James Egan, Feb 7, 2010
    #33
  14. Flyiñg Ñuñ 2°10 + on netbook

    James Egan Guest

    Hopefully.

    I suppose if it ain't broke don't fix it.

    I posted some further instructions which crossed with your post. Keep
    note of it for future reference in case you need it,


    Jim.
     
    James Egan, Feb 7, 2010
    #34
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.