Problem connecting wif'd computer to non-wifi'd computer.

Discussion in 'Home Networking' started by Flyiñg Ñuñ 2°10 + on netbook, Jan 31, 2010.

  1. Up 'til recently I have been running two desk top computers through ethernet
    connections and a netbook through wifi all networked through a 2wire
    2700HGV hub. I have now moved the hub some distance away from the two desk
    tops to improve my DSL connection (been getting many dropped connections of
    late - so connection directly to the main 'phone socket is needed to improve
    this situation). I have successfully connected the main desktop m/c to the
    hub by wifi using a wifi dongle, but as the second desktop is running
    Windows 98 I cannot find a wifi card or dongle that supports W98. So I'm
    playing around with using a short (2m) crossover ethernet lead between the
    desktops. So far so good as I can shift data between all three computers
    OK. Unfortunately I cannot get the W98 computer to connect to the Internet
    although I have set up a network bridge between wifi and LAN connection on
    the main desktop computer. It may be that I'm in the dark and confused
    about how to set up the various IP addresses for this, although since I am
    able to shift data from the wifi'd netbook to the W98 m/c I would have
    thought I'd got it correct. Any suggestions as to where I must be going
    wrong would be appreciated.
    Flyiñg Ñuñ 2°10 + on netbook, Jan 31, 2010
    1. Advertisements

  2. Flyiñg Ñuñ 2°10 + on netbook

    Rob Morley Guest

    If the W98 machine can see the router you just need to tell it to use
    that as its gateway, and make sure it has some DNS servers.
    Rob Morley, Jan 31, 2010
    1. Advertisements

  3. I'll try that Rob. Been playing with it quite a bit this evening and early
    morning. It seems that the Zone Alarm F/Ws I have installed on each m/c are
    some how preventing it connecting with the Internet. I had changed the
    TCP/IP properties so that it would see the desktop it was ethernet
    connected to as the gateway, and gave it the IP address that had been
    assigned by the router when it was connected to the router by ethernet
    before re-siting the router. That way I was able to shift data between all
    three computers. Instead, I tried allowing windows to obtain an IP
    address automatically. That way I found that I could connect to the
    Internet but then lost the ability to move data betweenall three computers .
    Shall try your suggestion later and report back. Thanks for the advice.
    Flyiñg Ñuñ 2°10 + on netbook, Feb 1, 2010
  4. Flyiñg Ñuñ 2°10 + on netbook

    James Egan Guest

    If you're bridging the interfaces then simply set up both the pc's to
    receive an ip address automatically. That should also deal with dns
    and if you cannot connect to the Internet it's probably a firewall
    issue as you said.

    If you want to experiment with the routing option it's a bit harder to
    configure. PC1_wired and PC2 needs to be on a separate subnet to
    PC1_wireless and router.

    Another alternative which you haven't considered yet is to get a
    separate wireless bridging device to work with the win98 box. You
    maybe don't have to buy something new. If you have an old wireless
    router you can usually download some updated firmware which will
    enable it to be configured as such a client bridging device.

    Regarding the routing option, a typical routed setup would be:-

    dsl gateway at

    set a static route to send traffic for subnet to go via


    static ip address mask
    default gateway
    dns server or your isp's nameserver address


    static ip address mask
    default gateway leave blank


    static ip address mask
    default gateway
    dns server or your isp's nameserver address

    You also need to edit the PC1 registry to enable routing between the
    wired and wireless interfaces as follows

    If PC1 is win9x this is

    System Key:
    Value Name: EnableRouting
    Data Type: (string value)
    Value Data: (0 = disabled, 1 = enabled)

    For winxp/2k/NT/Vista

    System Key:
    Value Name: IPEnableRouter
    Data Type: REG_DWORD (DWORD Value)
    Value Data: (0 = disabled, 1 = enabled)

    James Egan, Feb 1, 2010
  5. Yes I tried that, and have managed to get it to work with both computer f/ws
    (ZA) disablebled. Strangely enough I can transfer data between both
    computers with ZA on the W98 one, and with ZA on the host pooter. But with
    Internet Zone Security (ZA) set to high on the host computer the W98
    computer cannot connect to the net. Reducing that to Medium allows Internet
    traffic but for some reason prevents data transfer between the two
    computers. I'm sure what I want to acheive can be done by expertly setting
    up the IP addresses etc in the firewall Zones page, but so far I've not had
    much luck with it.
    Thanks for that James, but unfortunately, most of that is way above my
    head I'm afraid, but I'll copy it all and see what my much more
    knowledgeable contact can make of it all. I have considered the option of
    upgrading the W98 to W98SE, which is supported by current wifi dongles.
    Flyiñg Ñuñ 2°10 +, Feb 2, 2010
  6. Flyiñg Ñuñ 2°10 + on netbook

    Rob Morley Guest

    A wireless ethernet bridge (or a wireless router used in bridging mode)
    attaches to a regular ethernet card and translates it into wifi - as
    far as the PC is concerned it's just a regular wired connection, as far
    as the rest of the network is concerned it's regular wifi.
    Rob Morley, Feb 2, 2010
  7. Thanks Rob. I have a spare 2wire 2700HGV. Do you know if that can be
    operated in bridging mode?
    Flyiñg Ñuñ 2°10 +, Feb 2, 2010
  8. Flyiñg Ñuñ 2°10 + on netbook

    Rob Morley Guest

    Rob Morley, Feb 2, 2010
  9. Ta. So far I've now got the W98 and other desktop (XP) both able to
    download to each other and connect to the Internet. A simiple re-setting of
    the Internet Zone Security in the ZA firewall to medium instead of High
    achieved that step. My wifi'd netbook can now see the W98 m/c but isn't
    allowed to transfer data, but the W98 m/c, as yet, can't even see the
    netbook. So it seems like I'm getting there, albeit slowly. I've
    certainly got to what I wanted to do, connecting to the netbook
    successfully would be the cherry on the cake - so to speak. Thanks for all
    the advice.
    Flyiñg Ñuñ 2°10 +, Feb 2, 2010
  10. Flyiñg Ñuñ 2°10 + on netbook

    alanp Guest

    Ta. So far I've now got the W98 and other desktop (XP) both able to download
    Does your netbook have Vista ? If so it will default to a different
    workgroup name to the XP & W98 machines.

    Good MS networking info here :-

    alanp, Feb 2, 2010
  11. Nope both Netbook and main desktop have XP Home Edition Service pack 3.
    Strangely, although the netbook isn't shown up on the W98 network
    neigbourhood, you can successfully ping the netbook's IP addy from the the
    W98 pooter. And even though the W98 is shown on the netbook's network
    places, pinging the W98's IP addy from the netbook results in a time out
    every time. That doesn't sound right to me at all.
    Thanks Alan, I'll have a browse.
    Flyiñg Ñuñ 2°10 +, Feb 3, 2010
  12. Flyiñg Ñuñ 2°10 + on netbook

    James Egan Guest

    One way pings are generally down to firewalls. Does disabling
    zonealarm resolve the issue?

    Sometimes merely disabling a misbehaving firewall will not resolve the
    problem and an uninstallation is required. If necessary try
    uninstalling zonealarm. You can always re-install if you feel the need
    but personally, I wouldn't bother. I'd do without it since the pc is
    already operating behind a nat device and you'll also benefit from
    better pc performance.

    James Egan, Feb 4, 2010
  13. Flyiñg Ñuñ 2°10 + on netbook

    Jeff Gaines Guest

    What is assigning the IP addresses FN? Do you use DHCP on your router?
    Looks like addresses are being assigned more than once.
    Jeff Gaines, Feb 4, 2010
  14. Yes that's what is happening, and yes I believe DHCP is used, but that is
    getting beyond my current knowledge base. :(.

    Hiya Jeff I thought you were busy these days. Not seen you about for ages
    or I would have contacted you. Don't have your new 'phone number and
    thought you were still having connection issues. What I'm doing, or rather
    trying to do, is connect my netbook, W98 pooter and XP desktop into a
    similar network that I had before all ethernet connected to the 2700HGV. I'm
    using a crossover ethernet lead between XP desktop and as I have re-sited my
    router away from the pooter room and wifi'd the the XP desktop. As I
    cannot find a wifi card or dongle that supports W98 (which I want to retain
    on the old pooter) I thought (as did others) that the crossover would be
    easiest. The other route I considered was upgrading the W98 to W98SE which
    is supported by current wifi dongles, but that became fraught with
    The XP desktop (I am letting windows automatically assign an IP address on
    all pooters) is assigning the W98 the addy and itself, but my 2700HGV router is assigning the XP desktop, the netbook but can't appear to see the W98
    computer. You've read the rest of the story except for me to say that
    transferring data both ways between both desktops (connected by the
    crossover ethernet) and printing (printer lead connected to XP desktop),
    which is what I have always wanted the system to do, is fine. But it would
    be nice to be able to include the netbook in that as well. Currently I can
    transfer data both ways between netbook and XP desktop but cannot print from
    the netbook, don't know why, as it was possible some months ago.
    Flyiñg Ñuñ 2°10 +, Feb 4, 2010
  15. Flyiñg Ñuñ 2°10 + on netbook

    Jeff Gaines Guest

    OK, can I clarify the connections:

    2700HGV - connects to:
    XP Desktop by WiFi
    Netbook by WiFi
    These PC's should be able to 'see' each other and connect to the Internet.

    W98 Desktop connects to XP Desktop by crossover cable.
    W98 should be able to see XP (and vice versa) but W98 won't be able to
    connect to the Internet (its IP address range is different to that used by
    the router).

    I am a bit puzzled by 'Windows' assigning IP addresses - did you mean that
    or have you set up fixed IP addresses yourself? If you have set up fixed
    addresses then try changing that to obtain an IP address automatically. Or
    change them to addresses in the 192.168.1.x range - although you have to
    be careful you don't duplicate the addresses dished out by the DHCP server.

    My reply to address is valid, drop me an email if you wish and I'll let
    you have my new 'phone number.
    Jeff Gaines, Feb 4, 2010
  16. email sent.
    Flyiñg Ñuñ 2°10 + on netbook, Feb 5, 2010
  17. Flyiñg Ñuñ 2°10 + on netbook

    James Egan Guest

    It sounds like you have internet connection sharing enabled on this
    desktop. You shouldn't do that. ICS should be disabled and the bridged
    interface should be set to receive and ip address automatically (from
    the router). That will enable the other pc to receive an ip address
    from the router automatically too.

    ICS automatically installs a dhcp server of its own so if that was on
    you would be running conflicting dhcp servers and all sorts of
    unexpected things could happen.

    James Egan, Feb 5, 2010
  18. Where do I find ICS so that I could disable it Jim, and would this affect
    my ability to have netmeeting sessions?
    Flyiñg Ñuñ 2°10 +, Feb 5, 2010
  19. Flyiñg Ñuñ 2°10 + on netbook

    James Egan Guest

    It's on the advanced tab of the network adaptor's properties (ie right
    click the network adaptor and select properties).

    I'm not familiar enough to give you a step by step procedure but you
    might have to remove the bridge, take off ics from the wired interface
    and re-establish the bridge. Or you might be able to do it with the
    bridge already established. But one way or the other it has to be

    Disabling it won't stop anything from working. The router is already
    sharing your Internet connection so you don't need to share it twice.

    James Egan, Feb 5, 2010
  20. Forgot to say Jim that as we couldn't get the network to operate as required
    with a network bridge that we removed it. Just running with the wifi and
    LAN adapers now. The thing that isn't working is the W98 pooter and XP
    netbook aren't communicating. Having said that, I've just booted everthing
    up this morning and the W98 computer can't communicate with anything, so
    I'll have to carry out further investigations later. Looks like thers could
    be some other underlying problems.
    Flyiñg Ñuñ 2°10 +, Feb 6, 2010
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.