Problem Configuring Access Mode on an Interface on a Catalyst 3500XL

Discussion in 'Cisco' started by tman, May 9, 2008.

  1. tman

    tman Guest

    I want to configure several FastEthernet interfaces on a Catalyst
    3500XL switch so they will not trunk. I used the following command:

    conf t
    int fa0/1
    switchport mode access

    It takes the command o.k. but when I do a sh run it does not show that
    the interface is in access mode. Moreover, when I connect another
    switch to fa0/1 with at cross-over cable, it trunks.

    When I use the same command on a Catalyst 2950 switch, this is what I
    see when I do a sh run:

    interface FastEthernet0/1
    switchport mode access

    Am I missing something?

    Thanks in advance.
     
    tman, May 9, 2008
    #1
    1. Advertisements

  2. You need to turn off Dynamic Trunking Protocol

    int fa0/1
    switchport mode access
    switchport nonegotiate
     
    Doug McIntyre, May 9, 2008
    #2
    1. Advertisements

  3. tman

    tman Guest

    I tried it but there is no such command as switchport nonegotiate.
    The only commands under switchport are:
    access
    mode
    multi
    priority
    trunk
    voice

    I tried the following command in interface config mode:

    no negotiation auto

    It returns the message: This command is not supported for
    FastEthernet0/1
     
    tman, May 9, 2008
    #3
  4. tman

    Merv Guest

    to disable trunking on a 3500XL, try the command

    no switchport mode
     
    Merv, May 9, 2008
    #4
  5. tman

    tman Guest

    I already tried that one. It doesn't seem to do anything. I can
    still plug another switch into the port and it lights up.
     
    tman, May 9, 2008
    #5
  6. tman

    Morph Guest

    In the message
    <> tman
    wrote:

    | > to disable trunking on a 3500XL, try the command
    | >
    | > no switchport mode
    |
    | I already tried that one. It doesn't seem to do anything. I can
    | still plug another switch into the port and it lights up.

    According to this:
    http://www.ciscopress.com/articles/article.asp?p=29803&seqNum=3

    "Cisco 2950 and 3500XL switches do not support DTP and are always in a
    mode similar to nonegotiate. If you turn trunking on for one of these
    devices, it will not negotiate with the other end of the link and
    requires that the other link be configured to on or nonegotiate."
     
    Morph, May 10, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.