private ip to host webserver to public (1700 router)

Discussion in 'Hardware' started by yadap, May 5, 2006.

  1. yadap

    yadap

    Joined:
    May 5, 2006
    Messages:
    6
    Likes Received:
    0
    Given the following configuration, how can i open my webserver/dns (ip 192.168.0.2 and 192.168.0.3 resp.) to public
    I actually wanted to map one of the xxx.xxx.xxx.xxx ip that's provided by isp, to the private ip mentioned above.
    Please reply with appropriate addition/modification in config. table.

    interface FastEthernet0
    ip address 192.168.0.1 255.255.255.0 secondary
    ip address xxx.xxx.xxx.81 255.255.255.240 (routable ip provided by isp)
    ip nat inside
    speed auto
    !
    interface Serial0
    ip address A.B.C.D 255.255.255.252
    ip nat outside
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0
    !
    no ip http server
    ip nat pool ittinalan xxx.xxx.xxx.83 xxx.xxx.xxx.84 netmask 255.255.255.240
    ip nat inside source list 101 pool ittinalan overload
    !
    access-list 101 permit ip 192.168.0.0 0.0.0.255 any
    !
     
    yadap, May 5, 2006
    #1
    1. Advertisements

  2. yadap

    unholy

    Joined:
    Jun 21, 2005
    Messages:
    3,899
    Likes Received:
    0
    Location:
    Australia
    You could Route ports 0 to what ever the highest port is, in your router.

    And when u post next time keep it in the apportiate Board :) thanks,
     
    unholy, May 6, 2006
    #2
    1. Advertisements

  3. yadap

    yadap

    Joined:
    May 5, 2006
    Messages:
    6
    Likes Received:
    0
    Dear unh...

    i sorry for the mistake that have posted my problem in inappropriate board as i am very new to this portal..

    anyway it would be great if u can help me...

    isp has given me a pool of public addresses (xxx.xxx.xxx.80/240 (14 routable ips)

    they have given three wan ips 59.145.XX.201 to 203, of which 202 is assighned in serial0 as nat outside..

    where should i put my xxx.xxx.xxx.82,85 in router so that i can redirect traffic coming onto 82,85 to my private ip, say 192.168.0.2,3)

    Please help me out..
     
    yadap, May 6, 2006
    #3
  4. yadap

    The Modfather

    Joined:
    Sep 11, 2005
    Messages:
    2,424
    Likes Received:
    0
    We never pay any attention to where we post around here, why should you break with the trend? :)

    You might want to try a program like dyndns. It will set up a dynamic domain name and associate it to your IP address, even if it's static, it sits there in memory and monitors your IP address and just redirects anyone who goes to the named URL to the correct IP. I use it for web radio broadcasting, works great.

    http://www.dyndns.com/
     
    The Modfather, May 6, 2006
    #4
  5. yadap

    unholy

    Joined:
    Jun 21, 2005
    Messages:
    3,899
    Likes Received:
    0
    Location:
    Australia
    Ummm Modfather that has nothing to do with his problem, u know the Difference between Lan and Wan i hope Modfather, DynDns just routers a Wan Ip to a Domain Name.

    What he wants to do is router the Wan ip to a Lan ip, Simalair to single port routing but he want to route the whole IP.

    yadap, if u got the .201-.203 working then follow the same proceedure, just replace the ips with the Wan Ips and Lan Ip's, but in this case u would be replacing serial0.

    Considering i dont know how ur router works, or how u route Ip's, or even if u can i am not sure. A suggestion would be look through the Manual or Attempt to do it through ur Console.

    ps, np's about posting in the wong board i just moved it for ya :)
     
    unholy, May 7, 2006
    #5
  6. yadap

    The Modfather

    Joined:
    Sep 11, 2005
    Messages:
    2,424
    Likes Received:
    0
    I am not a networking type of guy. I never can understand networking, I thought he wanted to run a website from his home network. :)
     
    The Modfather, May 7, 2006
    #6
  7. yadap

    yadap

    Joined:
    May 5, 2006
    Messages:
    6
    Likes Received:
    0
    thanks unholy...

    here i will make clear abt what ips do what things. First of all mine is a Lease line internet with 3 nos. of wan ips to connect from isp's wan switch to cse/dsu. In my router, serial0 has one out of those three wan ips for internet connection configured (59.145.xx.202). ISP configured the previously send configuration (see below). additionally i have purchased some 14 no. of public ips from the same isp which is different than wan ips i mentioned earlier. purchased ip looks something like 125.16.xxx.81 to 94 (mask 255.255.255.240) of which .81 is assighned to ethernet 0 of router which is nated inside( primary). And for private ips they have assighned 192.168.0.1 in the same ethernet0 as secondary. Rite now if we browse net.. everything gets dynamically nated to 125.16.xxx.83-84 as these are some of real ips and that's needed. Now what i want is ... i have already one webserver in place having private ip of 192.168.0.2 which want to be appear as 125.16.xxx.82 meaning that outsiders sud be able browse by 125.16.xxx.82......(mapping to 192.168.0.2).

    (wan ip-)
    ISP (59.145.xx.20x)------------------------------------------(csu/dsu---router>s0 (59.145.xx.202)/252

    purchased (routable ips 125.16.xxx.81 to 94)
    125.16.xxx.81 (ethernet0-inside nat-primary)
    125.16.xxx.83-84 is for dynamically natting 192.168.0.0 for internet use.

    i want 125.16.xxx.82 be apprear as webserver ip which i have not connected or configured to any node. i just want to forwared request coming onto that ip to 192.168.0.2

    please get me back as this is very urgent...

    thanks in advance.

    i hope u understood what i wanted to do.
    CONFIGURATION DETAILS AS OF NOW.

    interface FastEthernet0
    ip address 192.168.0.1 255.255.255.0 secondary
    ip address 125.16.xxx.81 255.255.255.240 (routable ip provided by isp)
    ip nat inside
    speed auto
    !
    interface Serial0
    ip address 59.145.XX.202 255.255.255.252
    ip nat outside
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0
    !
    no ip http server
    ip nat pool ittinalan 125.16.xxx.83 125.16.xxx.84 netmask 255.255.255.240
    ip nat inside source list 101 pool ittinalan overload
    !
    access-list 101 permit ip 192.168.0.0 0.0.0.255 any
     
    yadap, May 8, 2006
    #7
  8. yadap

    unholy

    Joined:
    Jun 21, 2005
    Messages:
    3,899
    Likes Received:
    0
    Location:
    Australia
    I think this would lye with u understanding exactly how ur router works. And how to Mask and map Ip's

    I aint the pro at that, infact the least pro, i have my net running through a Computer!, that routes it out! :|
     
    unholy, May 9, 2006
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.