PRI with only 15 timeslots and mgcp

Discussion in 'Cisco' started by Dietmar Romer, Feb 8, 2005.

  1. Hi all,

    is there a possibility to manage a PRI interface with only 15 timeslots with
    CCM 3.3 (using MGCP)?

    Gateway: 2651XM
    Module: NM-HDV
    WIC: VWIC-1MFT-E1

    Background: The E1 has 31 timeslots but the upper 15 are disabled by the
    provider. When dialing out the gateway tries to use timeslot 31, even
    though "Channel Selection order" has been set to "bottom up". Setting
    "pri-group timeslots 1-16 service mgcp" on the gateway works until the
    router is rebooted.

    How can I tell the gateway not to use the upper channels permanently?


    Dietmar
     
    Dietmar Romer, Feb 8, 2005
    #1
    1. Advertisements

  2. Dietmar Romer

    Ivan Ostreš Guest

    Not sure it will help, but you might try to create channel group (to
    your E1 config) and add to it just first 15 channels.
     
    Ivan Ostreš, Feb 8, 2005
    #2
    1. Advertisements

  3. I have already tried this, but the Callmanager overwrites everything in the
    controller section...


    Dietmar
     
    Dietmar Romer, Feb 8, 2005
    #3
  4. Dietmar Romer

    Gunkanjima Guest

    The channelisation is being over-written by the Call Manager. You can
    overcome this problem by removing the command 'ccm-manager config' from
    the router config. You do this after the router has associated with the
    Call Manager but before you reboot.
    Be aware that this will remove some of the control over the router from
    the CM.
    We had a lot of issues with E1 channelisation and MGCP, in the end
    Cisco advised us to go to H323. However I have spoken to a number of
    engineers who have had no problems with it.
    You can also alter the channel order selection on the CM to go from top
    or bottom (to start with channel 1 or channel 31) but this may cause
    problems with the channel selection process from the provider.
     
    Gunkanjima, Feb 9, 2005
    #4
  5. Hi,

    removing the "ccm-manager config" sounds good - we will give it a trial.

    Unfortunately, the "Channel Selection Order" parameter in CM has not any
    effect on the router. It always starts with channel 31. Even setting "isdn
    bchan-number-order ascending" does not help. It is only accepted when in
    SRST mode.

    Any idea what's going wrong there?


    Dietmar
     
    Dietmar Romer, Feb 9, 2005
    #5
  6. Dietmar Romer

    voipguy Guest

    Ivan,
    If you remove the "CCM CONFIG" statement from your gateway,
    then it won't behave properly when you press "restart" or "reset", so
    this isn't really an option. You will find that CCM won't route any
    calls out that trunk
    after you press either of those buttons.
    This is because the configuration code also handles backhaul messages
    for reset and restart. These come over the TCP backhaul link. When it
    gets one, it cause the GW to send "RSIP Restart"
    on the MGCP session. If you turn it off, that won't happen.

    You might try removing some PVDM
    cards from your voice card so you only have enough DSPs for 15
    channels.

    When CCM audits the interface (MGCP "AUEP" command), the GW will
    respond
    to only 15 DS0s with a "200 OK". The higher ones will be rejected with
    a 5xx
    error, and CCM will know not to use them.

    Exactly how many PVDMs to remove I'm not sure, you'll have to
    experiment.
    On the topic of changing the channel selection order, that should have
    worked,
    I've used it in the past.

    Hope this helps.
     
    voipguy, Feb 22, 2005
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.