PRI to BRI multilink failure.

Discussion in 'Cisco' started by Jeff Pratt, Jul 13, 2005.

  1. Jeff Pratt

    Jeff Pratt Guest

    Far end is a 3Com ISDN U lanmodem. It is configured for dialin and
    multilink.

    Near end is a C2610 with a 2ct1 network module.

    config:

    Current configuration : 1725 bytes
    !
    version 12.1
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname filet-rtr
    !
    enable secret 5 ************************
    enable password *************
    !
    !
    !
    !
    !
    ip subnet-zero
    no ip finger
    !
    isdn switch-type primary-ni
    !
    !
    controller T1 1/0
    framing esf
    linecode b8zs
    pri-group timeslots 1-10,24
    !
    controller T1 1/1
    !
    !
    interface Ethernet0/0
    ip address 192.9.200.249 255.255.255.0
    no ip mroute-cache
    no cdp enable
    !
    interface Serial1/0:23
    no ip address
    encapsulation ppp
    no ip route-cache
    dialer pool-member 1
    isdn switch-type primary-ni
    isdn calling-number 7807023021
    no cdp enable
    ppp multilink
    multilink max-links 2
    !
    interface Dialer1
    ip unnumbered Ethernet0/0
    encapsulation ppp
    shutdown
    dialer pool 1
    dialer remote-name agent1289
    dialer rotor best
    dialer idle-timeout 20
    dialer string 7804089168
    dialer string 7804089169
    dialer hold-queue 10
    dialer load-threshold 3 outbound
    dialer-group 1
    no fair-queue
    no cdp enable
    ppp authentication pap callin
    ppp chap refuse
    ppp pap sent-username iq-rtr password 7 ********************
    ppp multilink bap
    ppp bap call accept
    ppp bap callback accept
    ppp bap timeout pending 20
    ppp bap max dialers 2
    multilink max-links 2
    !
    ip classless
    ip route 10.10.5.0 255.255.255.0 10.10.5.1
    ip route 10.10.5.1 255.255.255.255 Dialer1
    no ip http server
    !
    access-list 101 permit ip 192.9.200.0 0.0.0.255 10.10.5.0 0.0.0.255
    dialer-list 1 protocol ip list 101
    no cdp run
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    password **********
    login
    !
    end

    Debugs are:

    filet-rtr#sh deb
    Dial on demand:
    Dial on demand events debugging is on
    PPP:
    Multilink events debugging is on
    BAP:
    BAP general debugging is on
    BAP negotiation debugging is on
    BAP error debugging is on
    ISDN:
    ISDN Q931 packets debugging is on
    ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-)
    DSL 0 --> 31
    1 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


    Call come up fine, on one B channel:

    2d00h: Di1 DDR: Call connected, 1 packets unqueued, 1 transmitted, 0
    discarded
    2d00h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0:9, changed
    state to up
    2d00h: Di1 BAP: Group "0030.1e3f.0ad7" (10) (multilink) with precedence
    created
    2d00h: 0030.1e3f.0ad7 MLP: Established BAP group 10 on Di1, physical Se1/0:9


    When I try to add a channel to the bundle, however:

    2d00h: Di1 BAP: Received CallbackReq, id 24, len 13
    2d00h: 0030.1e3f.0ad7 BAP: I CallbackReq [Idle] id 24 len 17
    2d00h: 0030.1e3f.0ad7 BAP: LinkType 64 kbps type isdn (0x0105004001)
    2d00h: 0030.1e3f.0ad7 BAP: PhoneDelta
    2d00h: 0030.1e3f.0ad7 BAP: UniqueDigits 1 (0x010301)
    2d00h: 0030.1e3f.0ad7 BAP: SubscriberNumber 9 (0x020339)
    2d00h: 0030.1e3f.0ad7 BAP: I CallbackReq, id 24
    2d00h: Se1/0:23 DDR: has 10 ongoing call(s), maximum allowed call(s) 10 on
    pool 1, exceeded max
    2d00h: DDR: rotor dialout [best] least recent failure is also most recent
    failure
    2d00h: DDR: rotor dialout [best] also has most recent failure
    2d00h: BAP: bap_link_is_free passed NULL idb
    2d00h: DDR: rotor dialout [best]
    2d00h: 0030.1e3f.0ad7 BAP: O NAK for CallbackReq, id 24
    2d00h: 0030.1e3f.0ad7 BAP: Sending CallbackRsp, id 24, len 55 on Di1 to
    remote
    2d00h: 0030.1e3f.0ad7 BAP: O CallbackRsp [Idle] id 24 len 51 NAK
    2d00h: 0030.1e3f.0ad7 BAP: LinkType 64 kbps type isdn (0x0105004001)
    2d00h: 0030.1e3f.0ad7 BAP: Reason No links of specified type(s) available
    2d00h: 0030.1e3f.0ad7 BAP: (0x04294E6F206C696E6B73206F66207370)
    2d00h: 0030.1e3f.0ad7 BAP: (0x65636966696564207479706528732920)
    2d00h: 0030.1e3f.0ad7 BAP: (0x617661696C61626C65)

    Which would seem to indicate I am out of B channels on my PRI. But... show
    isdn service gives me:

    filet-rtr#sh is se
    PRI Channel Statistics:
    ISDN Se1/0:23, Channel [1-24]
    Configured Isdn Interface (dsl) 0
    Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart
    5=Maint_Pend)
    Channel : 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State : 0 0 0 0 0 0 0 0 0 2 3 3 3 3 3 3 3 3 3 3 3 3 3 3
    Service State (0=Inservice 1=Maint 2=Outofservice)
    Channel : 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State : 0 0 0 0 0 0 0 0 0 0 2 2 2 2 2 2 2 2 2 2 2 2 2 2

    I'm stumped. Can anyone out there help?

    Jeff
     
    Jeff Pratt, Jul 13, 2005
    #1
    1. Advertisements

  2. Jeff Pratt

    Tosh Guest

    Which would seem to indicate I am out of B channels on my PRI. But...
    Maybe the last channels are configured by the carrier for receiving calls
    only, try to revert the order the router picks a b channel issueing the
    following command at the serial interface:
    isdn bchan-number-order ascending
    Bye,
    Tosh.
     
    Tosh, Jul 14, 2005
    #2
    1. Advertisements

  3. Jeff Pratt

    Jeff Pratt Guest

    Thanks.. I tried it though, and no joy. All channels are configured for
    inbound and outbound.

    Thanks,

    Jeff
     
    Jeff Pratt, Jul 14, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.