pppoe server configuration help in cisco 2801

Discussion in 'Cisco' started by Vani, Jul 18, 2005.

  1. Vani

    Vani Guest

    Hi All,

    I am running IOS 12.39(11)T in my cisco 2801 router. I'm not getting
    response for the PADI packets received by 2801.
    Under the vpdn-group, accept dialin, protocols i dont see pppoe. It
    shows only pptp,l2tp..So i specified the protocol as 'any'. When i
    enable the pppoe debug logs, it is showing that the PADI packets are
    being received but not PADO being sent out..Do i need to change the IOS
    to support pppoe server

    Attached is my running config


    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname sngdemo
    !

    username cisco privilege 15 secret 5 $1$pvH8$PBwgTSwLcoguIW.m45JxJ0
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    !
    !
    ip domain name yourdomain.com
    virtual-profile virtual-template 1
    vpdn enable
    !
    vpdn-group 1
    ! Default L2TP VPDN group
    ! Default PPTP VPDN group
    accept-dialin
    protocol any
    virtual-template 1
    local name miniv
    !
    vpdn-group 2
    !
    no ftp-server write-enable
    !
    !
    !
    !
    interface FastEthernet0/0
    description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
    ip address 192.167.10.1 255.255.255.0
    speed auto
    full-duplex
    pppoe enable
    no cdp enable
    no mop enabled
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    speed auto
    full-duplex
    no cdp enable
    no mop enabled
    !
    interface Serial0/1/0
    no ip address
    shutdown
    clockrate 2000000
    !
    interface Virtual-Template1
    mtu 500
    ip unnumbered FastEthernet0/0
    peer default ip address pool pppoe-pool
    ppp authentication chap callin miniv
    ppp chap hostname miniv
    ppp chap password 0 test
    !
    interface Dialer1
    ip address negotiated
    ip mtu 500
    shutdown
    dialer pool 1
    dialer-group 1
    fair-queue
    !
    ip local pool pppoe-pool 192.167.10.10 192.167.10.100
    ip classless
    !
    ip http server
    ip http authentication local
    !
    snmp-server community public RO
    no cdp run
    !
    !
     
    Vani, Jul 18, 2005
    #1
    1. Advertisements

  2. Vani

    Vani Guest

    Sorry there was a typo. The IOS that i am using is 12.3(11)T2.
    (C2801-IPBASE-M)
     
    Vani, Jul 19, 2005
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.