Please Help, I am about to go nuts, Cisco 7940

Discussion in 'UK VOIP' started by RH, Jun 3, 2006.

  1. RH

    RH Guest

    Anyone good with cisco phone, I am going nuts here

    Just got a secon user 7940 from ebay,a nd can not for the life of me getting
    thing to work in SIP mode
    Its a 7940G unit with App loaded P00305000300 which is call manager I thing

    Googling around I understand all I need to configure it with latest firmware
    is have TFTP server
    place the SIP files and away it goes

    Via [email protected] I have placed the files and teh config files

    Now when I reboot the phone it get to the stage
    defauting CM to TFTP server
    Regsitration rejected

    Where is this rejection happening?

    I am a bit confused by an entry in the SIP<MAC ADDRESS>.cnf where it talks
    Phone prompt/password for telnet/console session, what login and password is
    this for, and how do I know what it is
    RH, Jun 3, 2006
    1. Advertisements

  2. RH

    RH Guest

    Typical, just after sent the message Got it passed that stage , now stuck
    in a protocol Application invalid message :(
    RH, Jun 3, 2006
    1. Advertisements

  3. RH

    TheMgt Guest

    Ah, the 'useless brick' stage.

    Do you have a 'XMLDefault.cnf.xml' file? It should look something like this.

    <member priority="0">
    <loadInformation6 model="IP Phone 7910"></loadInformation6>
    <loadInformation124 model="Addon 7914"></loadInformation124>
    <loadInformation9 model="IP Phone 7935"></loadInformation9>
    <loadInformation8 model="IP Phone 7940">P0S3-07-4-00</loadInformation8>
    <loadInformation7 model="IP Phone 7960"></loadInformation7>
    <loadInformation20000 model="IP Phone 7905"></loadInformation20000>
    <loadInformation30008 model="IP Phone 7902"></loadInformation30008>
    <loadInformation30007 model="IP Phone 7912"></loadInformation30007>

    The 'P0S3-07-4-00' should be changed to the version of the sip firmware
    you're trying to load. Presumably P0S3-08-2-00.

    It helps if you can watch the logs of your TFTP server so you can see
    what the phone is looking for. Case of filenames sometimes matters.
    TheMgt, Jun 3, 2006
  4. RH

    RH Guest

    The 'P0S3-07-4-00' should be changed to the version of the sip firmware
    Thanks greatfully for the help

    Yes I did have the that file, looking at the logs it is requesting

    I readsomewhere that that you could just use a null name and that would
    work, but that does not
    if I do it find the file but just carries on saying protocol application

    Aragghh this is horrible!
    RH, Jun 3, 2006
  5. RH

    TheMgt Guest

    There's a few suggestions on this page if you've not found it already.
    TheMgt, Jun 3, 2006
  6. RH

    RH Guest

    Yep followed that earlier and still had the problem, I thought I a good
    thing to do would be to do a factory reset so I followed
    the instructions also on the age forcing the system to factory set its
    networking settings but still locked with the universal application loader
    and protocol invalid settings with no hope of getting new firmware files to
    the unit.

    I have tested some god awful chinese phones which I have pretty much thrown
    away, but they were much better than this cisco unit!
    RH, Jun 3, 2006
  7. RH

    Ron Lowe Guest

    protocol application invalid

    I had this error recently when upgrading a 7940 from SCCP 3.x to SIP 8.2.
    ( I'm working from memory here, the phone system is at a different
    location. )

    I dumped the 8.2 SIP firmware in the TFTP root, along with an XMLDefault
    file I cut-and-pasted from here:

    I edited the 7940 entry to point to the ver 8.2 firmware filename (
    un-edited line shown below )
    <loadInformation8 model="Cisco 7940">P00308000100</loadInformation8>

    I also had SIPDefault and SIP<mac-address> config files too.
    Ensure these point to the 8.2 firmware image too.

    This *should* be all you need to get the firmware upgraded.

    When the phone booted, it picked up the TFTP server address from DHCP.
    It looks like you've got that far.

    At this point, it upgraded the application loader, but then failed to
    upgrade the actual application.
    It errored out with 'protocol application invalid'

    I screwed around for a while, and the thing I did in the end that fixed it
    was this:

    I edited the XMLDefault file.
    I seem to remember that the instructions had me point it to the P00... file,
    as in the above example.( look in the firmware zip for the exact name ), but
    after I changed it to point to the P0S- filename instead, it suddenly
    worked. The phone went to 'upgrading application', and then it was done.

    Another phone I upgraded later complained about that, and I had to re-set
    the XMLDefault to point to the P00.. file again.

    Either way, all the phones upgraded in the end!
    Ron Lowe, Jun 3, 2006
  8. RH

    RH Guest

    Thanks for the info, very much appreciated, I will try what you suggest
    RH, Jun 3, 2006
  9. RH

    RH Guest

    Thanks for your help, I did have the phone picking up from the TFTP server
    however after
    i reset the the phone (this just seems to have lost the config settings and
    turned on everything to DHCP) I think I have lost the conectivity to the
    TFTP server, to be honest Setting up DHCP server for a TFTPserver seems
    somewhat complex, none of the simple DHCP server have the option or TFTP
    or documentation to explain what value is set for the DHCP server, on Magik
    DHCP teh value appears not to be an IP address so I am very confused

    Anyone know of any companies which can service these phone?
    RH, Jun 11, 2006
  10. RH

    Ron Lowe Guest

    Setting up DHCP server for a TFTPserver seems somewhat complex, none of

    This one does, and it also has a tftp server built-in too:

    I've used this on a simple LAN ( 1 laptop, 1 hub, 1 7940 phone ) to upgrade
    this model phone.
    Just configure the PC with a static IP address, set up a basic DHCP scope,
    and configure Boot Server IP address in the DHCP options to point to itself.

    Use the log viewer to see what files the phone is requesting over TFTP.
    Ron Lowe, Jun 11, 2006
  11. RH

    Ron Lowe Guest

    Anyone know of any companies which can service these phone?

    Where are you ( geographically speaking )?

    If you e-mail me on ron[at]lowe-family[dot]me[dot]uk,
    I can probably get you fixed up for free.
    Ron Lowe, Jun 11, 2006
  12. RH

    rick Guest

    From the phones that i have tried upgrading firmware for, the only
    solution i found when it gets stuck in the 'protocol application
    invalid' stage is to do "step" firmware upgrading. that is, to
    upgrade to a lower sip version, then upgrade to the sip version you
    want. im not sure if you tried this already, but i would try
    upgrading to version 6.x, then try 8.x and see if that works. that's
    the only solution i found to have worked for me.


    * We buy and sell new/used networking equipment. Please contact me if
    you have any offers or are interested in buying *

    ** VG224 NEW IN BOX @ $3500/each, in stock! **
    ** VG248 NEW IN BOX @ $5000/each, in stock! **

    Rick Truong
    TruTech Systems
    AIM: ricktrutek
    E-Mail: rick at trutechsystems dot net
    rick, Jun 12, 2006
  13. RH


    Aug 11, 2006
    Likes Received:
    Loading SIP on Cisco 7940/7960

    Converting a Cisco 7940 SCCP Phone to a SIP Phone

    One would think that upgrading a cisco 7940 from sccp to sip protocol would be's link with all the files that you'll need to upgrade to SIP P0S3-08-2-00 including the configuration files (SIPDefault, XMLDefault, ..)

    http://circa30 dot com/

    All you have to do is assign your phone an ip address in the same subnet as your computer running tftp and copying the files to its tftp folder.
    Last edited: Aug 11, 2006
    Ben2006, Aug 11, 2006
  14. RH

    John d B

    Nov 11, 2006
    Likes Received:
    Maybe you can help.

    Hi, I'm John from the Netherlands and took some good info from your thread around enabling a 7940 phone on a 3rd party SIP server.
    I've gone through the FTP process / changed the firmware (P003-08-2-00), and everthing looks ok.....besides the phone doesn't register, which should be nice grrrrrr.

    How can I check the phone tries to register, in order to see I need to change add some info on the phone/ftp server? The only thing I'm not sure off is the "<processNodeName></processNodeName>" info in the XMLDefault.cnf.xml file. Some info on other forums tell me you should enter the IP address of the SIP server here? I entered the proxy (SIPDefault.cnf) info, but I'm not sure if this is enough.

    Any ideas?

    John d B, Nov 11, 2006
  15. RH


    Feb 6, 2009
    Likes Received:


    I looks as if you know what you're doing! I’m currently deployed to Iraq at the moment, I’m trying to get this phone working so I can call home for less money, and it uses less bandwidth. I understand it’s not you’re problem. I’m just looking for help. I'm struggling with this Cisco 7940 IP Phone. I don’t know what to do with this thing.
    Let me just tell you what I have to see if you can help me with you’re wisdom. (Please) Ok, here we go.
    The first question I have for you is. Do you have to have a data cable to load the firmware? I have my phone plugged in to my switch and my laptop plugged in the switch. The Internet is coming in the switch. Ok, I can ping the IP address to the phone, but I don’t know what I’m doing as far as using the TFTP server. In the phone I put the laptop’s IP address in the TFTP server, and set “Yes” to secondary TFTP server leaving the DHCP active. Ok, On the TFTP server, there are no logs of any kind. Nothing!!! What am I doing wrong? I have firmware SIP P0S3-07-5-00. When you talk about editing files, I really don’t know how to do that. I’m lost as a ball in high weeds. Actually, I know how, but I don’t understand what I’m editing. Is their a way you could shoot me a e-mail with a attachment with a good tftp server and a good edited version so the phone will take the load?? My AOL screenname is, (it won't let me write a link here so you have to add the, at aol at the end of my screenname)danielkburton Please help me. . . . . . .
    If the firmware ever loads, what happens to the Call Manager firmware?? Is their a way to delete it? Get it out?? Or does it matter? Does the phone need the TFTP server every time the phone looses power? And re boots.
    Thanks for you’re time
    ndburton, Feb 7, 2009
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.