Pix to Pix vpn connection will connect but no traffic passed over

Discussion in 'Cisco' started by Alex, Aug 27, 2008.

  1. Alex

    Alex Guest

    Hi,

    I have had a VPN connection setup between two pix's for about two
    years and then last week the router at the remote site died. I swapped
    out the router and reloaded both pix config's and the VPN started
    working again.

    Then on Tuesday I got a call saying it was down again I restarted the
    remote pix's and all was well again but then it happen again this
    morning but this time it will not let traffic over but it does show on
    the PDM a connected tunnel on each side.

    heres both config's

    506e

    PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 auto
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    hostname pixfirewall
    domain-name ciscopix.com
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    no fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    access-list inside_outbound_nat0_acl permit ip 10.35.104.0
    255.255.255.0 Eltham 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any 10.35.104.240
    255.255.255.248
    access-list outside_cryptomap_20 permit ip 10.35.104.0 255.255.255.0
    Eltham 255.255.255.0
    access-list outside_access_in permit tcp any any eq smtp
    access-list outside_cryptomap_dyn_20 permit ip any 10.35.104.240
    255.255.255.248
    access-list EMIS-ELTHAM_splitTunnelAcl permit ip any any
    access-list outside_cryptomap_dyn_40 permit ip any 10.35.104.240
    255.255.255.248
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 192.168.0.254 255.255.255.0
    ip address inside 10.35.104.100 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool REMOTE 10.35.104.240-10.35.104.245
    pdm location 0.0.0.0 255.255.255.255 inside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 192.168.0.1 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    http server enable
    http 10.35.104.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto dynamic-map outside_dyn_map 20 match address
    outside_cryptomap_dyn_20
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
    crypto dynamic-map outside_dyn_map 40 match address
    outside_cryptomap_dyn_40
    crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
    crypto map outside_map 20 ipsec-isakmp
    crypto map outside_map 20 match address outside_cryptomap_20
    crypto map outside_map 20 set peer a.a.a.a
    crypto map outside_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp key ******** address a.a.a.a netmask 255.255.255.255 no-xauth
    no-config-mode
    isakmp nat-traversal 20
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    vpngroup MASON-REMOTE address-pool REMOTE
    vpngroup MASON-REMOTE dns-server 10.35.104.106
    vpngroup MASON-REMOTE default-domain dh2.co.uk
    vpngroup MASON-REMOTE idle-time 1800
    vpngroup MASON-REMOTE password ********
    vpngroup EMIS-ELTHAM address-pool REMOTE
    vpngroup EMIS-ELTHAM dns-server 10.35.104.106
    vpngroup EMIS-ELTHAM split-tunnel EMIS-ELTHAM_splitTunnelAcl
    vpngroup EMIS-ELTHAM idle-time 1800
    vpngroup EMIS-ELTHAM password ********
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd address 10.35.104.101-10.35.104.254 inside
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    dhcpd enable inside
    terminal width 80

    remote - 501

    PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    hostname pixfirewall
    domain-name ciscopix.com
    clock timezone GMT/BST 0
    clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct
    2:00
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name 10.35.104.0 Welling
    access-list inside_outbound_nat0_acl permit ip 192.168.1.0
    255.255.255.0 Welling 255.255.255.0
    access-list outside_cryptomap_20 permit ip 192.168.1.0 255.255.255.0
    Welling 255.255.255.0
    pager lines 24
    logging on
    logging timestamp
    logging trap debugging
    logging host inside 192.168.1.12
    mtu outside 1500
    mtu inside 1500
    ip address outside b.b.b.b 255.255.255.0
    ip address inside 192.168.1.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm location Welling 255.255.255.0 outside
    pdm location 192.168.1.12 255.255.255.255 inside
    pdm logging debugging 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    route outside 0.0.0.0 0.0.0.0 b.b.b.b 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto map outside_map 20 ipsec-isakmp
    crypto map outside_map 20 match address outside_cryptomap_20
    crypto map outside_map 20 set peer c.c.c.c
    crypto map outside_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp key ******** address c.c.c.c netmask 255.255.255.255 no-xauth
    no-config-mode
    isakmp nat-traversal 20
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd address 192.168.1.2-192.168.1.129 inside
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    dhcpd enable inside
    terminal width 80

    a.a.a.a - remote pix outside ip
    b.b.b.b - remote routers ip
    c.c.c.c - my pix's outside ip

    Any ideas ?

    Thanks

    Alex
     
    Alex, Aug 27, 2008
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.