PIX 501 open ports for Remote Desktop Web

Discussion in 'Cisco' started by rufus, Oct 31, 2007.

  1. rufus

    rufus

    Joined:
    Oct 31, 2007
    Messages:
    1
    Likes Received:
    0
    I am trying to open up my firewall to allow Remote Desktop Web Connection through to one of the computer on our network.

    I did a whois from the computer where Remote Desktop Web is setup and I got back the IP 216.254.215.11

    The computer I want to setup the connection on has an IP of 192.168.16.122
    I have changed the Default Web Site port in IIS manager to 10000

    Going to http://192.168.16.122:10000/tsweb from inside the network, works fine. When I try to go to http://216.254.215.11:10000/tsweb from outside the network, I don't get anywhere.

    Any help would be much appreciated.

    Here is my config, it's all full of junk now from me trying to open these ports.

    PIX Version 6.3(3)
    interface ethernet0 10baset
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password .75ZjeRCpOxSMJuz encrypted
    passwd VCfZrAmtudsVnZKx encrypted
    hostname PIX501-16
    domain-name MYDOMAIN.NET
    clock timezone EST -5
    clock summer-time EDT recurring
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol http 10000
    fixup protocol ils 389
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list 101 permit ip 192.168.16.0 255.255.255.0 172.22.9.0
    255.255.255.0
    access-list 101 permit ip 192.168.16.0 255.255.255.0 172.22.1.0 255.255.255.0
    access-list 101 permit ip 192.168.16.0 255.255.255.0 192.168.10.0 255.255.255.0
    access-list 101 permit ip 192.168.16.0 255.255.255.0 192.168.50.0 255.255.255.0
    access-list 101 permit ip 192.168.16.0 255.255.255.0 192.168.14.0 255.255.255.0
    access-list 101 permit ip 192.168.16.0 255.255.255.0 192.168.0.0 255.255.255.0
    access-list 101 permit ip 192.168.16.0 255.255.255.0 192.168.15.0 255.255.255.0
    access-list 101 permit ip 192.168.16.0 255.255.255.0 172.22.0.0 255.255.0.0
    access-list 101 permit tcp any any eq 10000
    access-list 101 permit tcp any any eq www
    access-list 101 permit tcp any host 216.254.216.11 eq www
    access-list 101 permit tcp any host 216.254.216.11 eq 10000
    access-list 101 permit tcp any host 216.254.215.11 eq 3389
    access-list 102 permit ip 192.168.16.0 255.255.255.0 192.168.10.0 255.255.255.0
    access-list 102 permit ip 192.168.16.0 255.255.255.0 192.168.14.0 255.255.255.0
    access-list 102 permit ip 192.168.16.0 255.255.255.0 192.168.50.0 255.255.255.0
    access-list 102 permit ip 192.168.16.0 255.255.255.0 172.22.1.0 255.255.255.0
    access-list 103 permit ip 192.168.16.0 255.255.255.0 192.168.15.0 255.255.255.0
    access-list outside permit tcp any interface outside eq 3389
    access-list outside permit tcp any interface outside eq 444
    access-list outside permit tcp any interface outside eq 4125
    access-list outside permit tcp any interface outside eq www
    access-list outside permit tcp any interface outside eq https
    access-list outside permit tcp any interface outside eq 10000
    access-list inside permit tcp any interface inside eq 4125
    access-list inside permit tcp any interface inside eq 444
    access-list inside permit tcp any interface inside eq 3389
    access-list inside permit tcp any interface inside eq https
    access-list inside permit tcp any interface inside eq www
    access-list inside permit tcp any interface inside eq 10000
    access-list 110 permit tcp any host 192.168.16.122 eq 3389
    access-list 110 permit tcp any host 192.168.16.122 eq 10000
    access-list 120 permit tcp any host 216.254.215.11 eq 10000
    access-list 120 permit tcp any host 216.254.215.11 eq 3389
    pager lines 24
    logging on
    logging console notifications
    logging monitor notifications
    logging buffered notifications
    logging trap debugging
    logging host inside 192.168.16.108
    mtu outside 1500
    mtu inside 1500
    ip address outside 216.254.215.10 255.255.255.248
    ip address inside 192.168.16.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm location 172.22.1.7 255.255.255.255 inside
    pdm location 172.22.0.0 255.255.0.0 inside
    pdm location 192.168.0.0 255.255.0.0 inside
    pdm location 192.168.10.0 255.255.255.0 outside
    pdm location 172.22.9.0 255.255.255.0 outside
    pdm location 172.22.1.0 255.255.255.0 outside
    pdm location 192.168.1.0 255.255.255.0 inside
    pdm location 172.22.0.0 255.255.0.0 outside
    pdm location 192.168.0.0 255.255.255.0 outside
    pdm location 192.168.14.0 255.255.255.0 outside
    pdm location 192.168.15.0 255.255.255.0 outside
    pdm location 192.168.50.0 255.255.255.0 outside
    pdm location 192.168.16.108 255.255.255.255 inside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 216.254.215.11
    nat (inside) 0 access-list 101
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (outside,inside) tcp 192.168.16.122 3389 216.254.215.11 3389 netmask 255.
    255.255.255 0 0
    static (outside,inside) tcp 192.168.16.122 10000 216.254.215.11 10000 netmask 25
    5.255.255.255 0 0
    static (inside,outside) 192.168.16.122 216.254.215.11 netmask 255.255.255.255 0
    0
    static (outside,inside) 216.254.215.11 192.168.16.122 netmask 255.255.255.255 0
    0
    access-group 120 in interface outside
    route outside 0.0.0.0 0.0.0.0 216.254.215.9 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    http 192.168.0.0 255.255.0.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto map extend 10 ipsec-isakmp
    crypto map extend 10 match address 102
    crypto map extend 10 set peer 216.129.193.66
    crypto map extend 10 set transform-set ESP-DES-SHA
    crypto map extend 30 ipsec-isakmp
    crypto map extend 30 match address 103
    crypto map extend 30 set peer 216.138.246.50
    crypto map extend 30 set transform-set ESP-DES-SHA
    crypto map extend interface outside
    isakmp enable outside
    isakmp key ******** address 216.138.246.50 netmask 255.255.255.255
    isakmp key ******** address 216.129.193.66 netmask 255.255.255.255
    isakmp identity address
    isakmp policy 10 authentication pre-share
    isakmp policy 10 encryption des
    isakmp policy 10 hash sha
    isakmp policy 10 group 2
    isakmp policy 10 lifetime 86400
    telnet 192.168.0.0 255.255.0.0 inside
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 outside
    ssh 0.0.0.0 0.0.0.0 inside
    ssh timeout 5
    console timeout 0
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    terminal width 80
     
    rufus, Oct 31, 2007
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.