pcmcia.sys cardbus driver causing asynchronous wireless speeds with the Texas Instruments 6xx1/7xx1

Discussion in 'Wireless Networking' started by josephlanders, Jan 30, 2007.

  1. Hi guys,

    I purchased a Compaq V2417AU (V2000 series) laptop over a year ago
    (jan '06) and I later purchased a D-Link DWL-G630 54mbit/s (wireless
    G) PC Card (32bit Cardbus card).

    I noticed the asymmetric speed issues immediately, with 3Mbyte/s
    downstream and 900KByte/s upstream.

    Under Linux Ubuntu Dapper with the Madwifi drivers I noticed I had a
    good 3Mbps up/down.

    I put it down to a driver issue as I had nothing else to test the card

    Now I have finally purchased the wireless Rangemax 240 WPNT121 Usb 2.0
    and WPNT511 PCMCIA 32-bit cardbus card for my WPNT834 Rangemax 240
    router, throughput is very high with the USB2.0 unit plugged into my
    PC around 100mbit/s with my laptop connected via ethernet. With my new
    cardbus card I still get 3Mbyte/s / 900KByte/s.

    This is extremely frustrating for me, as you can understand.

    My Laptop uses a Texas Instruments 6x21/7x21 driver, i've taken the
    laptop apart and it indeed uses the TI PCI7411 chipset.

    I have checked online documentation for this chipset provided by TI,
    the card supports up to 100/200/400mbit/s it appears also that the
    PCMCIA cardbus standard allows 33/66/133mbyte/s burst speed depending
    on data size (byte/word/dword) and it states that no drivers are
    needed under WIndows as there is a pcmcia.sys driver provided under
    Windows (by MS from TI? it's driver version 5.1.2600.2180 xpsp_sp2_rtm.
    040803-2158). I have used the compaq provided driver version
    and I have tried to install the sony version but the sony
    installer blocks me from proceeding and the drivers do not extract
    anywhere. I believe these only install flashmedia card drivers and
    merely update the name of the cardbus controller.

    This time I have installed Ubuntu Edgy 7.04 herd 2 (alpha 2) and I
    have compiled ndiswrapper 0.36rc1, ndiswrapper allows you to use
    windows drivers under Linux.

    I have so far managed to attain 7.33 Mbyte/s (i.e. 400MB in 55
    seconds) downstream and 10.6 Mbyte/s upstream.

    So I say, please can you fix this issue, I will also be contacting
    Texas Instruments. Compaq have not bothered to get back to me on this
    so far.

    Kind regards


    My original post was in reply to this thread:

    Here is my post on the MS wireless networking group

    here's a thread on another forum
    josephlanders, Jan 30, 2007
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.