Outgoing Dial Rules in [email protected]

Discussion in 'UK VOIP' started by Jono, Oct 5, 2005.

  1. Jono

    Jono Guest

    Hello,

    I've finally got Voipbuster working as an IAX trunk.

    I've configured the Outbound Routing as 9|. so that I can use Voipbuster by
    dialling 9. Then all the digits dialled after the 9 are sent to the trunk
    (with the 9 stripped)

    Then, in Outgoing Dial Rules, I've added 00441274+NXXXXX which simply adds
    all the extra bits to our six digit local numbers - this works fine.

    The problem I'm having is what to do with other STDs. I would like to dial
    9, followed by an 11 digit UK number, then have asterisk strip the 9, then
    strip the 1st 0, then add 0044.

    This 0|0044+[12]XXXXXXXXX doesn't seem to work.
     
    Jono, Oct 5, 2005
    #1
    1. Advertisements

  2. Jono

    Sparks Guest

    Do you want to have to dial a 9?

    If not, try this...

    Outbound Routing - VoipBuster
    00441.
    00442.
    0|1.
    0|2.
    0|3.
    0|800.
    0|808.
    [2-8].


    Trunks - Voipbuster
    0044+XXXXXXXXXX
    00441274+XXXXXX

    -----------
    But if you really want to dial a 9, try this...
    Outbound Routing - VoipBuster
    901|.
    902|.
    903|.

    Trunks - Voipbuster
    0044+XXXXXXXXXX



    Sparks...
     
    Sparks, Oct 5, 2005
    #2
    1. Advertisements

  3. Jono

    Jono Guest

    Sparks wrote:
    ||| This 0|0044+[12]XXXXXXXXX doesn't seem to work.
    |||
    ||
    || Do you want to have to dial a 9?
    ||
    || If not, try this...
    ||
    || Outbound Routing - VoipBuster
    || 00441.
    || 00442.
    || 0|1.
    || 0|2.
    || 0|3.
    || 0|800.
    || 0|808.
    || [2-8].
    ||
    ||
    || Trunks - Voipbuster
    || 0044+XXXXXXXXXX
    || 00441274+XXXXXX
    ||
    || -----------
    || But if you really want to dial a 9, try this...
    || Outbound Routing - VoipBuster
    || 901|.
    || 902|.
    || 903|.
    ||
    || Trunks - Voipbuster
    || 0044+XXXXXXXXXX
    ||
    ||
    ||
    || Sparks...

    Thanks for the reply.

    Unfortunately, I'm already using 0| for another trunk........

    Using your 901|. suggestion, where would the 6 digit local numbers fit in?
     
    Jono, Oct 5, 2005
    #3
  4. Jono

    Sparks Guest

    I do apologise, I meant 90|. not 901|. 902|. 903|.

    This will catch all 0XXXXXXXXXX (So mobiles too)

    If you only want 01 02 03 numbers passed to VoIPBuster, then I think this
    will do it

    Outbound Routing - VoipBuster
    90|[123].

    Trunks - Voipbuster
    0044+XXXXXXXXXX

    Sparks...
     
    Sparks, Oct 5, 2005
    #4
  5. Jono

    Sparks Guest

    ....and for the local 6 digit number

    Outbound Routing - VoipBuster
    9.[2-9]XXXXX


    Trunks - Voipbuster
    00441274+XXXXXX

    Sparks...
     
    Sparks, Oct 5, 2005
    #5
  6. Jono

    Sparks Guest

    ....sorry, that should be.... (I am tired!!)


    Outbound Routing - VoipBuster
    9|[2-9]XXXXX


    Trunks - Voipbuster
    00441274+XXXXXX

    Sparks...
     
    Sparks, Oct 5, 2005
    #6
  7. Jono

    RH Guest

    Dont suppose you can share the settings that you are using in [email protected] trunk
    settings?
     
    RH, Oct 6, 2005
    #7
  8. Jono

    Sparks Guest

    Mine are...

    Trunk IAX2/voipbuster

    host=213.61.187.150
    insecure=very
    notransfer=yes
    secret=PASSWORD
    type=peer
    username=USERNAME

    Just replace USERNAME and PASSWORD with yours, and you should be laughing!

    Make sure you pass the full international number to it, even for UK calls

    Dial Rules
    0044+XXXXXXXXXX
    00441689+XXXXXX (Replace 1689 with your area code)

    If you are in an 020 area code, replace the second line with
    004420+XXXXXXXX
    -----------

    Then in Outbound Routing -> VoipBuster

    00441.
    00442.
    00443.
    0|1.
    0|2.
    0|3.
    0|800.
    0|808.
    [2-8].


    Sparks...
     
    Sparks, Oct 6, 2005
    #8
  9. Jono

    Matt Guest

    Cheers for posting the settings.

    A couple of quck questions...

    1) Do you have a registration entry?


    2) Any ideas why I get this?...

    Oct 7 21:54:40 VERBOSE[1070]: -- Executing Dial("SIP/200-67f5",
    "IAX2/vbuster/00441213332xxx") in new stack
    Oct 7 21:54:40 WARNING[1070]: No such host: vbuster
    Oct 7 21:54:40 NOTICE[1070]: Unable to create channel of type 'IAX2'
    Oct 7 21:54:40 VERBOSE[1070]: == Everyone is busy/congested at this
    time
    Oct 7 21:54:40 DEBUG[1070]: Exiting with DIALSTATUS=CHANUNAVAIL.

    Many thanks


    Matthew
     
    Matt, Oct 7, 2005
    #9
  10. Jono

    Jono Guest

    Matt wrote:
    || Cheers for posting the settings.
    ||
    || A couple of quck questions...
    ||
    || 1) Do you have a registration entry?
    ||
    ||
    || 2) Any ideas why I get this?...
    ||
    || Oct 7 21:54:40 VERBOSE[1070]: -- Executing Dial("SIP/200-67f5",
    || "IAX2/vbuster/00441213332xxx") in new stack
    || Oct 7 21:54:40 WARNING[1070]: No such host: vbuster
    || Oct 7 21:54:40 NOTICE[1070]: Unable to create channel of type 'IAX2'
    || Oct 7 21:54:40 VERBOSE[1070]: == Everyone is busy/congested at this
    || time
    || Oct 7 21:54:40 DEBUG[1070]: Exiting with DIALSTATUS=CHANUNAVAIL.
    ||
    || Many thanks
    ||
    ||
    || Matthew

    I'm using the following to register

    username:p[email protected]
     
    Jono, Oct 7, 2005
    #10
  11. Jono

    Matt Guest

    username:p[email protected]

    host=213.61.187.150


    2 different IP addresses.... now I am really confused!
     
    Matt, Oct 7, 2005
    #11
  12. Jono

    Matt Guest

    Still get the same error

    Oct 7 22:34:19 VERBOSE[1070]: -- Executing Dial("SIP/200-2d52",
    "IAX2/vbuster/00441213332XXX") in new stack
    Oct 7 22:34:20 WARNING[1070]: No such host: vbuster
    Oct 7 22:34:20 NOTICE[1070]: Unable to create channel of type 'IAX2'

    Any other ideas?
     
    Matt, Oct 7, 2005
    #12
  13. Jono

    Sparks Guest

    It sounds like it is trying to lookup a hostname of "vbuster"

    Can you post both your trunk and outbound routing for this call here?

    ....and you dont need it to register, unless you are using it for inbound
    calls

    Sparks...
     
    Sparks, Oct 8, 2005
    #13
  14. Jono

    Jono Guest

    Sparks wrote:

    <snip>

    || ...and you dont need it to register, unless you are using it for
    || inbound calls
    ||
    || Sparks...

    That's interesting. I couldn't get outbound working until I put the Register
    line in. Coincidence, perhaps.

    It's a while since I downloaded their softfone & paid my I
    Euro.............what's my "number" to receive calls on?
     
    Jono, Oct 8, 2005
    #14
  15. Jono

    Matt Guest

    Cheers everyone,

    Trunk Settings...


    General Settings
    Outgoing Dial Rules
    0044+XXXXXXXXXX
    00441827+XXXXXX

    Trunk Name vbuster

    PEER Details
    :
    host=213.61.187.150
    insecure=very
    notransfer=yes
    secret=xxxxx
    type=peer
    username=xxxx




    Registration

    XXXXX:[email protected]


    Outbound Routing

    Route Name = vb

    Dial Pattern = 0|.

    Routing = IAX2/vbuster

    Thanks again,


    Matthew


    PS Don't suppose anyone can help me with BIND DNS Problem too!
     
    Matt, Oct 8, 2005
    #15
  16. Jono

    Sparks Guest

    Where exactly is this?
    In my [email protected] I dont have this in the trunk anywhere, only in the
    Outbouund routing.
    What version of [email protected] are you on (I am on 1.3)?
    What's this : for above?
    I don't have anything in here, but I dont have an inbound number with
    VoIPBuster

    My Dial pattern would be what you have in your "Trunk Settings -> General
    settings" - maybe you have a different verison of [email protected]?
     
    Sparks, Oct 8, 2005
    #16
  17. Jono

    Matt Guest

    I''m running AAH 1.5.

    The Outgoing Dialing Rules appear on the Edit Trunk Page, under the
    general settings.

    The : under "Peer Details" is a typo from my cutting and pasting
    attempt - sorry to confuse.

    I don't have an inbound number, either - but I thought I'd see if it
    helped. It doesn't seem to have helped!
    Still can't see why this happens - by outbound routing via sipgate is
    fine!

    Cheers for all the help.

    Matthew
     
    Matt, Oct 8, 2005
    #17
  18. Jono

    Sparks Guest

    Ah, they must have changed some things then!
    Maybe I will install AAH 1.5, then we can both ask for help! :)

    It does look like your sustem is trying to resolve the name vbuster to an IP
    address for some reason, you could try editing your hosts file, and add the
    following line

    213.61.187.150 vbuster

    That may fix it (but not solve why it is doing it!

    Sparks...
     
    Sparks, Oct 8, 2005
    #18
  19. Jono

    Matt Guest

    Getting better....

    That gives

    Oct 8 22:34:28 VERBOSE[1070]: -- Called vbuster/01213332xxxx
    Oct 8 22:34:29 WARNING[1070]: Call rejected by 213.61.187.150: No
    authority found
    Oct 8 22:34:29 DEBUG[1070]: Immediately destroying 10, having received
    reject
    Oct 8 22:34:29 DEBUG[1070]: We're hanging up
    IAX2/213.61.187.150:4569/10 now...
    Oct 8 22:34:29 DEBUG[1070]: Really destroying
    IAX2/213.61.187.150:4569/10 now...
    Oct 8 22:34:29 VERBOSE[1070]: -- Hungup 'IAX2/213.61.187.150:4569/10'

    Is there another IP I can try?
     
    Matt, Oct 8, 2005
    #19
  20. Jono

    Sparks Guest

    Well that's the one I use for VoIPBuster!

    Are you using the exact same username and passowrd you used to log into
    www.voipbuster.com (and can you log into that OK?)

    Sparks...
     
    Sparks, Oct 8, 2005
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.